Results 1 to 8 of 8

Thread: Ubuntu-Foss install failure libgmp3

  1. #1
    mjfleck2000 is offline Senior Member
    Join Date
    Oct 2005
    Location
    Coeur d'Alene, ID
    Posts
    59
    Rep Power
    9

    Default Ubuntu-Foss install failure libgmp3

    I attempted to upgrade my ubuntu-dapper using the 4.0.2 Ubuntu tar ball. The install failed with " libgmp3...MISSING" error.

    For my current zimbra install, I had used the GA release of debian and used the Ubuntu patch from the wiki to get past the libgmp3 problem. The patch contained:

    The patch code from the wiki has:
    - PREREQ_PACKAGES="sudo libidn11 curl fetchmail libgmp3 libxml2 libstdc++6 openssl"
    + PREREQ_PACKAGES="sudo libidn11 curl fetchmail libgmp3c2 libgmp3-dev libxml2 libstdc++6 openssl"

    Perhaps the package requirements have not been updated on the Ubuntu release?

    Mike

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Interesting.. I wonder if this is just an upgrade issue. Did you try a clean install? Anybody else tested this with a clean install?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    9

    Default

    What does /opt/zimbra/libexec/get_plat_tag.sh return?

  4. #4
    mjfleck2000 is offline Senior Member
    Join Date
    Oct 2005
    Location
    Coeur d'Alene, ID
    Posts
    59
    Rep Power
    9

    Default

    >>What does /opt/zimbra/libexec/get_plat_tag.sh return?

    Debian3.1

    I changed /etc/debian_version to testing/unstable.
    Upgrading is now proceeding.

    Mike

  5. #5
    mjfleck2000 is offline Senior Member
    Join Date
    Oct 2005
    Location
    Coeur d'Alene, ID
    Posts
    59
    Rep Power
    9

    Default

    Okay, further info on the Ubuntu upgrade.

    The upgrade completed but I was unable to log in as a user on via the Admin panel.

    zimbra.log shows:

    2006-09-26 16:08:39,843 ERROR [main] [] Versions - DB Version Mismatch: ours="27" from
    DB="26"
    2006-09-26 16:08:39,845 FATAL [main] [] soap - Unable to start servlet
    java.lang.RuntimeException: Data version mismatch. Reinitialize or upgrade the backend data store.


    I had backed up my zimbra directory (of course) so I restored my machine to pre-Ubuntu-upgrade status. I did not see any error messages when I upgraded.

    Mike

  6. #6
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    9

    Default

    in general you should be able to run zmsetup.pl again and it should take care of the upgrade.

    With that said though its possible your /opt/zimbra/.install_history is whacked with various failed upgrade attempts, not to mention you installed the debian package and then upgraded with the ubuntu package.

    I would take a look at /tmp/zmsetup.log. from the last install to see if there was any specific schema upgrade errors before rerunning zmsetup.pl

  7. #7
    jordg is offline Junior Member
    Join Date
    Feb 2006
    Posts
    6
    Rep Power
    9

    Default

    Hi,

    I had problems with the same symptom. I am using Debiam etch.
    The installer is badly broken for etch.
    What I ended up doing was following the instructions below and at the end I rsynced it from the chroot to /opt and it is working OK now.

    http://forums.gentoo.org/viewtopic-t...ht-zimbra.html

  8. #8
    mjfleck2000 is offline Senior Member
    Join Date
    Oct 2005
    Location
    Coeur d'Alene, ID
    Posts
    59
    Rep Power
    9

    Default

    More on the hacked-debian-ubuntu to ubuntu upgrade:

    It is working!

    I have ubuntu-dapper installed. When I first installed Zimbra, I followed the wiki to modify the debian tar ball for ubuntu installation. It worked just fine. The changes worked out to be:
    1) different versions/names for libgmp (libgmp3 vs libgmp3c2)
    2) changed the preinstall package requirements to reflect #1 above
    3) changing the file /etc/debian_version (testing/unstable 3.1 vs testing/unstable)

    Those were the only changes so that debian tar ball would install on ubuntu.

    I moved my exsisting zcs directory out of the way and copied my exsisting zimbra directory to zimbra.backup.

    I downloaded the latest DEBIAN tar ball zcs-4.0.2_GA_362.DEBIAN3.1, extracted and upgraded. During upgrade, I noticed that the db was upgraded from version "26" to "27".

    I rebooted and tested Zimbra... everything appears to work.

    I downloaded the new Ubuntu-Foss tar ball zcs-4.0.2_GA_362.UBUNUTU, extracted and upgraded. There was a complaint about unknown command of rpm line 336 in util/utilfunc.sh... otherwise the install continued without any errors noted.

    I rebooted and tested Zimbra... everything appears to work.

    Well, there was a minor problem with documents (unidentifed attributes). I reentered passwords in the Zimbra Admin panel (wiki@my-server) and that problem disappeared.

    So, I am hoping that when the next Ubuntu version comes out, that I can use the Ubuntu version without having to first install the debian version and then the Ubuntu version.

    Mike

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 11:41 AM
  2. Unable to install on Ubuntu 7.04 64 bit
    By geekneck in forum Installation
    Replies: 5
    Last Post: 07-16-2007, 07:52 PM
  3. Unable to install on Ubuntu 7.04 64-bit
    By geekneck in forum Installation
    Replies: 3
    Last Post: 07-14-2007, 10:15 AM
  4. Ubuntu 6.06 LTS server install problems
    By Kavey1978 in forum Installation
    Replies: 17
    Last Post: 05-30-2007, 01:49 AM
  5. Smooth install of Zimbra in Ubuntu 6.10 (Edgy Eft)
    By martinfst in forum Zimbra Success Stories
    Replies: 11
    Last Post: 05-01-2007, 01:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •