Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Problem with server migration in final stage

  1. #1
    jwilliams@hometask.com is offline Active Member
    Join Date
    Aug 2010
    Posts
    36
    Rep Power
    5

    Default Problem with server migration in final stage

    Hi,

    I recently followed the migration steps detailed in Moving ZCS to Another Server » Zimbra :: Blog

    on the last step of running the install script, I am running into an error.

    "Setting defaults from ldap...done.
    ERROR: account.NO_SUCH_SERVER (no such server: mail.todoblue.com)
    ERROR: account.NO_SUCH_SERVER (no such server: mail.todoblue.com)"

    and then the script wont finish.

    I'm kinda freaking out. Any help would be appreciated.

    Thanks,

    Justin

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,580
    Rep Power
    57

    Default

    Have you checked that your DNS records point to the new server and the hostname in the hosts file is the same as your old server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    jwilliams@hometask.com is offline Active Member
    Join Date
    Aug 2010
    Posts
    36
    Rep Power
    5

    Default

    I did check, but will check again. This also happened when running the install script:

    "Do you want to verify message store database integrity? [Y]
    Verifying integrity of message store databases. This may take a while.
    Starting mysqld...done.
    Can't locate Data/UUID.pm in @INC (@INC contains: /opt/zimbra/zimbramon/lib /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 22.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 22.
    Compilation failed in require at bin/zmdbintegrityreport line 19.
    BEGIN failed--compilation aborted at bin/zmdbintegrityreport line 19.
    "

  4. #4
    jwilliams@hometask.com is offline Active Member
    Join Date
    Aug 2010
    Posts
    36
    Rep Power
    5

    Default

    this is what I end up with at the end...

    "Main menu

    1) Common Configuration:
    +Hostname: mail.todoblue.com
    +Ldap master host: mail.todoblue.com
    +Ldap port: 389
    +Ldap Admin password: set
    +Secure interprocess communications: yes
    +TimeZone: America/Los_Angeles

    2) zimbra-ldap: Enabled
    +Create Domain: no
    +Ldap root password: set
    +Ldap replication password: set
    ******* +Ldap postfix password: Not Verified
    ******* +Ldap amavis password: Not Verified
    +Ldap nginx password: set

    3) zimbra-store: Enabled
    +Create Admin User: no
    +Enable automated spam training: yes
    +Spam training user: spam.1f4wf1ah@mail.todoblue.com
    +Non-spam(Ham) training user: ham.zdi875ro@mail.todoblue.com
    +Global Documents Account: wiki@mail.todoblue.com
    +SMTP host: mail.todoblue.com
    +Web server HTTP port: 80
    +Web server HTTPS port: 443
    +Web server mode: http
    +IMAP server port: 143
    +IMAP server SSL port: 993
    +POP server port: 110
    +POP server SSL port: 995
    +Use spell check server: yes
    +Spell server URL: http://mail.todoblue.com:7780/aspell.php
    ******* +Enable version update checks: UNSET

    4) zimbra-mta: Enabled
    +MTA Auth host: mail.todoblue.com
    +Enable Spamassassin: no
    +Enable Clam AV: no
    ******* +Bind password for postfix ldap user: Not Verified
    ******* +Bind password for amavis ldap user: Not Verified

    5) zimbra-snmp: Enabled
    6) zimbra-logger: Enabled
    7) zimbra-spell: Enabled
    8) Default Class of Service Configuration:
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit
    "

  5. #5
    jwilliams@hometask.com is offline Active Member
    Join Date
    Aug 2010
    Posts
    36
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    Have you checked that your DNS records point to the new server and the hostname in the hosts file is the same as your old server?
    regarding this, the answer is yes. DNS is right and hostname is the same.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,580
    Rep Power
    57

  7. #7
    jwilliams@hometask.com is offline Active Member
    Join Date
    Aug 2010
    Posts
    36
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    Thanks, I have looked at a few of those, but will read through and try what might apply. 11 hours at this so far, so would like to get it wrapped up.

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,580
    Rep Power
    57

    Default

    Quote Originally Posted by jwilliams@hometask.com View Post
    I did check, but will check again. This also happened when running the install script:

    "Do you want to verify message store database integrity? [Y]
    Verifying integrity of message store databases. This may take a while.
    Starting mysqld...done.
    Can't locate Data/UUID.pm in @INC (@INC contains: /opt/zimbra/zimbramon/lib /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 22.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 22.
    Compilation failed in require at bin/zmdbintegrityreport line 19.
    BEGIN failed--compilation aborted at bin/zmdbintegrityreport line 19.
    "
    Sorry, I missed this item you'd posted.

    I should have asked this earlier, what are you moving from/to? Is it a 32bit to 64bit or a change of operating system or just a hardware move to the same architecture and o/s?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    jwilliams@hometask.com is offline Active Member
    Join Date
    Aug 2010
    Posts
    36
    Rep Power
    5

    Default

    going from 32 to 64 bit. OS is the same other than this. From what I read on the guide, it didn't seem like this would be a problem.

  10. #10
    jwilliams@hometask.com is offline Active Member
    Join Date
    Aug 2010
    Posts
    36
    Rep Power
    5

    Default

    do you know of a work around, or do I need to head down to the co-location and install 32 bit os?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. LDAP Cannot bind on migration to new server
    By neekster in forum Migration
    Replies: 23
    Last Post: 03-09-2009, 02:08 AM
  2. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  3. [SOLVED] Multi Server - DNS - Imapproxy
    By innercy in forum Installation
    Replies: 1
    Last Post: 12-29-2007, 10:21 PM
  4. Server Migration
    By Isi in forum Administrators
    Replies: 5
    Last Post: 06-06-2007, 05:51 AM
  5. Zimbra Installation Problem
    By AnilKumarYalla in forum Developers
    Replies: 0
    Last Post: 09-10-2006, 09:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •