Results 1 to 7 of 7

Thread: Pulling my hair out!

  1. #1
    fgaughan is offline Junior Member
    Join Date
    Sep 2006
    Posts
    6
    Rep Power
    8

    Default Pulling my hair out!

    Please point me to right direction as i am pulling my hair out.
    I am using Centos
    First time i installed Zimbra i didn't set host name etc and i had a play with Zimbra.
    Was impressed but obviously i couldnít send and receive mail as I was testing it out.
    So I decided to do a proper install.

    I registered a domain with 1and1.co.uk lets call it needhelp.co.uk

    In the control panel of 1and one I put in my fixed IP Address (A-Record)
    As I have been given 2 fixed ip address from my isp service provider
    Am I correct in doing that?
    What do I put in my etc/hosts?


    When installing zimbra it get the following
    DNS ERROR - none of the MX records ineedhelp.co.uk
    resolve to this host

    Now I donít understand fully about DNS and email mx Ďs

    The FAQ on 1and1 does not make sense to me to find out about DNS and MX

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Does 1&1 allow you to manage your DNS including setting up MX Records? If 1&1 don't allow you to set MX records then you need a DNS service that does have that facility such as dyndns.or or (I use) easydns.com

    I assume you're behind a NAT router? If so your /etc/hosts file would contain:

    127.0.0.1 localhost.localdomain
    192.168.x.x mail.ineedhelp.co.uk mail

    where 'mail' is the name of your server. There is a tutorial in the forums on DNS, have a look for 'DNS in a nutshell' it'll tell you what you need to know. You may also need a local DNS server so review the wiki on 'split-DNS' as you'll probably need to set that up.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    fgaughan is offline Junior Member
    Join Date
    Sep 2006
    Posts
    6
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix
    Does 1&1 allow you to manage your DNS including setting up MX Records? If 1&1 don't allow you to set MX records then you need a DNS service that does have that facility such as dyndns.or or (I use) easydns.com

    I assume you're behind a NAT router? If so your /etc/hosts file would contain:

    127.0.0.1 localhost.localdomain
    192.168.x.x mail.ineedhelp.co.uk mail

    where 'mail' is the name of your server. There is a tutorial in the forums on DNS, have a look for 'DNS in a nutshell' it'll tell you what you need to know. You may also need a local DNS server so review the wiki on 'split-DNS' as you'll probably need to set that up.
    Thanks for reply
    Its all coming a bit clearer to me

    Typing this at work so i wont be able to do this till i get home grr (thats how obsessed i am in getting it to work)

    1and 1 does allow me to manage DNS and setting up my MX records but trouble is i don't know what to put in it.

    Fintan

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Have a review of the DNS in a nutshell post and it should become clear what you need at 1&1.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    fgaughan is offline Junior Member
    Join Date
    Sep 2006
    Posts
    6
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix
    Have a review of the DNS in a nutshell post and it should become clear what you need at 1&1.

    Read it and reread it still getting nowhere

    in my host `hostname` gives this
    Host mail not found: 3(NXDOMAIN)

    ; <<>> DiG 9.2.4 <<>> a ineedhelp.co.uk
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51765
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;ineedhelp.co.uk. IN A

    ;; ANSWER SECTION:
    ineedhelp.co.uk. 83710 IN A xx.xxx.xx.xxx

    ;; Query time: 46 msec
    ;; SERVER: 212.104.130.9#53(212.104.130.9)
    ;; WHEN: Thu Sep 14 22:37:27 2006
    ;; MSG SIZE rcvd: 47

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Hi-
    You don't have an MX record.

    Your MX record needs to point to either:
    1) your router(if you have one), the port forward your router's mta port to your natted IP
    2) your machine.

    Your record should have a priority of 10, unless you have more than 1 mail server.

  7. #7
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    if the machine is named "mail.ineedhelp.co.uk" and you want to have email addresses like "fgaughan@ineedhelp.co.uk", you need to see results like this:

    $ host -t mx ineedhelp.co.uk
    ineedhelp.co.uk mail is handled by 10 mail.ineedhelp.co.uk.

    $ host mail.ineedhelp.co.uk
    mail.ineedhelp.co.uk has address A.B.C.D

    if the machine is on a lan with private ip addresses, you will have best luck running a nameserver locally returning the private ip address (as well as any other dns info for the domain, i.e. the mx record). the rest of the world outside the lan will get the public ip address from 1 and 1

    split dns
    dns
    how the mta routes mail

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pulling my hair out - SASL Login authentication failed
    By alloptions in forum Installation
    Replies: 4
    Last Post: 03-30-2007, 11:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •