Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: [SOLVED] Link to shared documents are broken after update -> 6.0.8

  1. #11
    fcjoe is offline Member
    Join Date
    Apr 2009
    Location
    Fredonia, NY
    Posts
    12
    Rep Power
    6

    Default

    Quote Originally Posted by LMStone View Post
    Hi Leonardo,

    Thanks for the reply, but based on Joe's response I think we will wait for the patch.



    Joe, once the patch is released I would be most grateful if you can report whether or not the patch fixes this for you please.

    Best regards to all,
    Mark
    I'd keep on waiting if I were you, or try it out on a test box.

    This (Fri 3 Sept 2010) morning's 6.0.8_P1 does nothing for me. (Post 194839) And I find it curious that I'm in such a small minority. Makes me wonder what I'm doing wrong.

    And I'm loath to submit a bug report for something that I seem to be the only person on the planet with this problem....

    Joe
    Last edited by fcjoe; 09-03-2010 at 07:21 AM.

  2. #12
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,367
    Rep Power
    10

    Default

    Quote Originally Posted by fcjoe View Post
    I'd keep on waiting if I were you, or try it out on a test box.

    This (Fri 3 Sept 2010) morning's 6.0.8_P1 does nothing for me. (Post 194839) And I find it curious that I'm in such a small minority. Makes me wonder what I'm doing wrong.

    And I'm loath to submit a bug report for something that I seem to be the only person on the planet with this problem....

    Joe
    Hi Joe,

    Thanks for following up and sorry you are having this issue. I see from your profile you are running FOSS, so no official Zimbra support, right?

    Since there is already a bug report on this, if you can find some errors in your logs, I'd recommend both posting those errors here (or in the other thread) as well as posting the errors to the bug report, and asking that the bug be reopened.

    The Zimbra developers do pay attention to Bugzilla, and if anyone here can help decipher your logs and perhaps suggest some things to try, then everyone is ahead.

    How does that sound?

    All the best,
    Mark

  3. #13
    fcjoe is offline Member
    Join Date
    Apr 2009
    Location
    Fredonia, NY
    Posts
    12
    Rep Power
    6

    Default Searchez Le Browser.....

    Quote Originally Posted by LMStone View Post

    How does that sound?
    Sounds great, Mark. Thanks.

    We're starting to make some headway---the Documents functionalilty

    • works in Firefox 3.6.8 (Win 7 but NOT OS X);

    • does NOT work for me in Internet Explorer 8.0.7600.16358 in EITHER Compatibility or non-compatibility mode.

    • works in Safari 5.0.1 (5533.17.8) in OS X (10.5.8).


    On to the logs and an interesting weekend.

    Joe K.

  4. #14
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,367
    Rep Power
    10

    Default

    Keep at it Joe; looks like you could be on to something here!

    All the best,
    Mark

  5. #15
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Ubuntu10_64 (wiped previous zimbra install) put on 6.0.8-2661 > created domain/2 users > using win XP IE8.0.6 created page 1 in user's notebook > shared to user2 with admin rights > logged into user2 > changed language to italian > mounted share > http 500 error on viewing the shared notebook > added patch 2673 > DIDN'T even run a zmcontrol restart as we say to in the directions > browser refresh > 500 error > clear browser cache (everything under ctrl+shift+del) > close browser > open browser & ran clear cache again just for kicks because i still had the zwc open when i had cleared cache before > load zwc > viola (i can now view the notebook and view/edit page 1) > mac osx106 ff 3.6.8 > ok > mac osx106 safari 5.0.1 > ok > linux ff 3.6.8 > ok.

    That's everything short of win 7 IE 8.0.7 but seeing as you said you hit the error on mac ff 3.6.8 while I can't, almost doubt there's much more in play as far as win version & browsers go (long as you are clearing cache between testing) so sounds like another factor - but I'll install win 7 tonight and check anyways - might also try to repo using a non-english windows/ie install itself (besides zcs language setting) - what's the language your using?

  6. #16
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Hm, just noticed fcjoe is using english - the whole point of the bug leocor opened was problems in languages except english - so we might be looking at something else here...

    *off to try and hit the error in english on fresh 2661 (might even do U8-64 FOSS and Win7 IE8.0.7 just for kicks)

  7. #17
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,367
    Rep Power
    10

    Default

    Quote Originally Posted by mmorse View Post
    Hm, just noticed fcjoe is using english - the whole point of the bug leocor opened was problems in languages except english - so we might be looking at something else here...

    *off to try and hit the error in english on fresh 2661 (might even do U8-64 FOSS and Win7 IE8.0.7 just for kicks)
    Mike,

    I REALLY REALLY appreciate you testing this in English!

    Thank you!!!

    With best regards,
    Mark

  8. #18
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Still no repo.

    @fcjoe can you increase logging in /opt/zimbra/conf/log4j.properties.in > log4j.logger.zimbra=DEBUG > zmmailbodctl restart > then check/post the log snip when you hit the error - interested to see if it's similar to http://bugzilla.zimbra.com/attachment.cgi?id=24281

    ~
    test log:

    ubuntu8.04.4_64 + few more updates > 6.0.7 2473 foss (didn't bother with proper dns) single server > create 2 domains (one with a domain level wiki account) and 4 users > win 7 pro 64 build 71037 english > added all important updates > ie 8.0. > login user1 > (using zcs default language of en_US ) > create new notebook folder 'test' (figured maybe folders besides the default one might play a role) with page 'ing' and content 'blah' > share this new folder from user1 > user2 > logout user1 > login user2 > mount folder > created page2 with some random text > 6.0.7 2476 patch > user3 (that uses domain level wiki templates) > create new notebook > share to user4 > upgrade to 6.0.8 2661 > login user2 > no issue viewing or editing the existing shared notebook
    no problem in linux ubuntu10_64 ff 3.6.8 > mac osx106 ff 3.6.8 - safari 5.0.1 - chrome 6.0.4 > or win 7 ff 3.6.8 either > do one more share from user3 to user4 with view perms > fine

    just to trigger: back to IE8 > user4> change language to spanish > reload browser at prompt > 500 error > close browser > install patch > restart zcs > login user4 > no error

    install.sh -u > re put on 6.0.8 2476 still single server but added proxy & memcached> zmproxyconfig -e -w -m -H hostname > user4 in ie8 via both 80 > no issue > & 8080 still no issue in english (or uk or aus)

  9. #19
    leocor is offline Active Member
    Join Date
    Jul 2009
    Location
    Schio (VI) Italy
    Posts
    26
    Rep Power
    6

    Default

    It is clear that fcjoe suffers from a different problem (or bug) ,because I tested the P1 patch for some days (about 50 users in 3 languages) and everything is fine and fixed (Thanks! :-) ).

    leocor
    Lrd

  10. #20
    fcjoe is offline Member
    Join Date
    Apr 2009
    Location
    Fredonia, NY
    Posts
    12
    Rep Power
    6

    Default

    Quote Originally Posted by mmorse View Post
    Still no repo.

    @fcjoe can you increase logging in /opt/zimbra/conf/log4j.properties.in > log4j.logger.zimbra=DEBUG > zmmailbodctl restart > then check/post the log snip when you hit the error - interested to see if it's similar to http://bugzilla.zimbra.com/attachment.cgi?id=24281
    Similar may be too subtle a term. Looks almost identical to me..

    2010-09-07 08:39:37,674 ERROR [btpool0-87://mail.fcsd.wnyric.org/home/~/?id=b7fb0dde-dd67-4ccd-a482-d5080e91e231%3A380&=&t=1283863331415&language=en] [] log - /service/home/~/
    java.lang.ArrayIndexOutOfBoundsException: 0
    at com.zimbra.common.util.HttpUtil.getURIParams(HttpU til.java:124)
    at com.zimbra.common.util.HttpUtil.getURIParams(HttpU til.java:112)
    at com.zimbra.cs.service.UserServlet$Context.(UserServlet.java:832)
    at com.zimbra.cs.service.UserServlet.doGet(UserServle t.java:403)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:707)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:181)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:511)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1166)
    at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(Set HeaderFilter.java:79)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1157)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:155)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1157)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:388)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:182)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:765)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:418)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:230)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:230)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.DebugHandler.handle(Debu gHandler.java:77)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.Server.handle(Server.java:326)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:543)
    at org.mortbay.jetty.HttpConnection$RequestHandler.he aderComplete(HttpConnection.java:924)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:547)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:212)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:405)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:413)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451)
    2010-09-07 08:39:37,674 ERROR [btpool0-89://mail.fcsd.wnyric.org/home/~/?id=b7fb0dde-dd67-4ccd-a482-d5080e91e231%3A380&=&t=1283863331425&language=en] [] log - /service/home/~/
    java.lang.ArrayIndexOutOfBoundsException: 0
    at com.zimbra.common.util.HttpUtil.getURIParams(HttpU til.java:124)
    at com.zimbra.common.util.HttpUtil.getURIParams(HttpU til.java:112)
    at com.zimbra.cs.service.UserServlet$Context.(UserServlet.java:832)
    at com.zimbra.cs.service.UserServlet.doGet(UserServle t.java:403)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:707)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:181)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:511)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1166)
    at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(Set HeaderFilter.java:79)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1157)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:155)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1157)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:388)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:182)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:765)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:418)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:230)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:230)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.DebugHandler.handle(Debu gHandler.java:77)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.Server.handle(Server.java:326)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:543)
    at org.mortbay.jetty.HttpConnection$RequestHandler.he aderComplete(HttpConnection.java:924)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:547)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:212)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:405)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:413)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451)

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Shared Documents acting squirrely...
    By REMcycle in forum Administrators
    Replies: 3
    Last Post: 10-21-2008, 01:45 PM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. [SOLVED] 5.0.1 to 5.0.2 NE - Documents Gone!
    By jhoelz in forum Installation
    Replies: 1
    Last Post: 02-02-2008, 12:45 AM
  4. Replies: 6
    Last Post: 09-26-2007, 12:38 PM
  5. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •