Upgrade went smooth from 3.1, however the aspell server was failing to start. When I ran 'zmcontrol start' from the command line apache was throwing this error:

/opt/zimbra/httpd-2.0.54/bin/httpd: error while loading shared libraries: libexpat.so.1: cannot open shared object file: No such file or directory

The fix of course it to get the libexpat library, so "apt-get install libexpat1" fixes this. Hope this helps others.

Cheers
Dan-