Results 1 to 2 of 2

Thread: installation failed - somthing with ldap

  1. #1
    matzup is offline Junior Member
    Join Date
    Jun 2010
    Posts
    9
    Rep Power
    5

    Question installation failed - somthing with ldap

    I've tried to install zimbra (OS-Version) on centos5 an ubuntu8.04
    it is always the same problem:

    It stop always here:
    Code:
    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes] 
    Save config in file: [/opt/zimbra/config.32666] 
    Saving config in /opt/zimbra/config.32666...done.
    The system will be modified - continue? [No] yes
    Operations logged to /tmp/zmsetup.07242010-231201.log
    Setting local config values...done.
    Setting up CA...done.
    Deploying CA to /opt/zimbra/conf/ca ...done.
    Creating SSL certificate...done.
    Installing mailboxd SSL certificates...done.
    Initializing ldap...failed. (28160)
    
    ERROR
    Configuration failed
    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.
    Errors have been logged to /tmp/zmsetup.07242010-231201.log

    The last Lines in the Logfile:
    Code:
    [...]
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20100724231430
    ** Retrieving server config key zimbraSSLCertificate...failed.
    ** Retrieving server config key zimbraSSLPrivateKey...failed.
    ** Generating a server csr for download self -keysize 1024
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20100724231539
    ** Creating server cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Signing cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    Sat Jul 24 23:16:13 2010 done.
    Sat Jul 24 23:16:13 2010 Installing mailboxd SSL certificates...
    Sat Jul 24 23:16:13 2010 /opt/zimbra/mailboxd/etc/keystore didn't exist.
    Sat Jul 24 23:16:13 2010 *** Running as root user: /opt/zimbra/bin/zmcertmgr deploycrt self
    ** Saving server config key zimbraSSLCertificate...failed.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Installing mta certificate and key...done.
    ** Installing slapd certificate and key...done.
    ** Installing proxy certificate and key...done.
    ** Creating pkcs12 file /opt/zimbra/ssl/zimbra/jetty.pkcs12...done.
    ** Creating keystore file /opt/zimbra/mailboxd/etc/keystore...done.
    ** Installing CA to /opt/zimbra/conf/ca...done.
    Sat Jul 24 23:17:24 2010 done.
    Sat Jul 24 23:17:24 2010 checking isEnabled zimbra-ldap
    Sat Jul 24 23:17:24 2010 zimbra-ldap is enabled
    Sat Jul 24 23:17:24 2010 Initializing ldap...
    Sat Jul 24 23:17:24 2010 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: timeout at /opt/zimbra/libexec/zmldapinit line 136.
    Sat Jul 24 23:38:59 2010 failed. (28160)
    Sat Jul 24 23:38:59 2010
    
    ERROR
    Sat Jul 24 23:38:59 2010
    Configuration failed
    
    Sat Jul 24 23:38:59 2010 Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    Sat Jul 24 23:38:59 2010 complete the configuration.
    Sat Jul 24 23:38:59 2010
    Errors have been logged to /tmp/zmsetup.07242010-231201.log
    /opt/zimbra/libexec/zmldapinit line 136 is:
    Code:
    my $ldap = Net::LDAP->new("$ldap_master_url")  or  die "$@";
    What is wrong?

  2. #2
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    That indicates that LDAP failed to start. You need to figure out why.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. LDAP Replica Installation
    By Eri in forum Installation
    Replies: 0
    Last Post: 04-14-2009, 05:48 AM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  3. Installation Problem - Possibly LDAP
    By geroshea in forum Installation
    Replies: 5
    Last Post: 03-16-2007, 04:47 AM
  4. Installation Failed
    By freit5 in forum Installation
    Replies: 2
    Last Post: 08-17-2006, 11:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •