Results 1 to 5 of 5

Thread: Zimbra only accepting mail for "mail.ourdomain.com"

  1. #1
    cbraxton is offline New Member
    Join Date
    Apr 2010
    Posts
    4
    Rep Power
    5

    Default Zimbra only accepting mail for "mail.ourdomain.com"

    We're working with our first installation of Zimbra open source edition (Release 6.0.7_GA_2473.UBUNTU8_64 UBUNTU8_64 FOSS edition). The Zimbra server is behind a NAT router using port forwarding, so the internal IP address is not the same as the public IP.

    The first problem we encountered was delivery of messages was failing, and the logs showed final delivery being made to the domain rather than the local machine. Reading through the forums we found the Split DNS configuration needed and resolved that issue.

    Now messages are delivered, but only if they are addressed in the form "user@mail.ourdomain.com" rather than "user@ourdomain.com." If we were just using postfix it's a simple matter to set "mydestination" to the desired domain(s), but I'm not sure how to configure this in Zimbra.

    In the Administration Console, under the "General" tab the default domain is set to "ourdomain.com." What else needs to be configured for this to work?

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,499
    Rep Power
    56

    Default

    Quote Originally Posted by cbraxton View Post
    We're working with our first installation of Zimbra open source edition (Release 6.0.7_GA_2473.UBUNTU8_64 UBUNTU8_64 FOSS edition). The Zimbra server is behind a NAT router using port forwarding, so the internal IP address is not the same as the public IP.

    The first problem we encountered was delivery of messages was failing, and the logs showed final delivery being made to the domain rather than the local machine. Reading through the forums we found the Split DNS configuration needed and resolved that issue.

    Now messages are delivered, but only if they are addressed in the form "user@mail.ourdomain.com" rather than "user@ourdomain.com." If we were just using postfix it's a simple matter to set "mydestination" to the desired domain(s), but I'm not sure how to configure this in Zimbra.

    In the Administration Console, under the "General" tab the default domain is set to "ourdomain.com." What else needs to be configured for this to work?
    What do you mean by '.... only if they are addressed in the form "user@mail.ourdomain.com"', are you saying that no other mail is delivered? What are the exact error messages you are seeing in the log files? Go back to the Split DNS article in the wiki and check your configuration in the 'Verify...' section then post the information here, can you also confirm that your external DNS records are correct for yourdomain.com?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    cbraxton is offline New Member
    Join Date
    Apr 2010
    Posts
    4
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    What do you mean by '.... only if they are addressed in the form "user@mail.ourdomain.com"', are you saying that no other mail is delivered? What are the exact error messages you are seeing in the log files?
    Thank you for your assistance. Yes, no mail is delivered if the address form "user@ourdomain.com" is used. The specific error message is:

    Code:
    450 4.2.0 Mailbox is not on this server (in reply to RCPT TO command))
    This error does not occur if the message is addressed as "user@mail.ourdomain.com."

    dig ourdomain.com mx:
    Code:
    ; <<>> DiG 9.4.2-P2.1 <<>> ourdomain.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64930
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;ourdomain.com.             IN      MX
    
    ;; ANSWER SECTION:
    ourdomain.com.      2592000 IN      MX      10 mail.ourdomain.com.
    
    ;; AUTHORITY SECTION:
    ourdomain.com.      2592000 IN      NS      ns.ourdomain.com.
    
    ;; ADDITIONAL SECTION:
    mail.ourdomain.com. 2592000 IN      A       192.168.20.233
    ns.ourdomain.com.   2592000 IN      A       192.168.20.233
    
    ;; Query time: 12 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue Jul 20 11:24:05 2010
    ;; MSG SIZE  rcvd: 105
    dig ourdomain.com

    Code:
    ; <<>> DiG 9.4.2-P2.1 <<>> ourdomain.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49275
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;ourdomain.com.         IN      ANY
    
    ;; ANSWER SECTION:
    ourdomain.com.  2592000 IN      SOA     ourdomain.com. hostmaster.ourdomain.com. 10118 43200 3600 3600000 2592000
    ourdomain.com.  2592000 IN      NS      ns.ourdomain.com.
    ourdomain.com.  2592000 IN      MX      10 mail.ourdomain.com.
    ourdomain.com.  2592000 IN      A       192.168.20.233
    
    ;; ADDITIONAL SECTION:
    ns.ourdomain.com.       2592000 IN      A       192.168.20.233
    mail.ourdomain.com.     2592000 IN      A       192.168.20.233
    
    ;; Query time: 23 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Tue Jul 20 11:26:41 2010
    ;; MSG SIZE  rcvd: 168
    host `hostname`
    Code:
    mail.ourdomain.com has address 192.168.20.233
    /etc/hosts
    Code:
    127.0.0.1       localhost
    192.168.20.233  mail mail.ourdomain.com ourdomain.com
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    We are testing by initiating an SMTP session to the Zimbra server from the local network. The intent is not to transfer the external DNS until local delivery is known to work.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,499
    Rep Power
    56

    Default

    Your hosts file is incorrect, it should look like this:
    Code:
    127.0.0.1       localhost.localdomain localhost
    192.168.20.233  mail.ourdomain.com mail
    Fix that and restart Zimbra and see what happens, any errors and if so what is it?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    cbraxton is offline New Member
    Join Date
    Apr 2010
    Posts
    4
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    Your hosts file is incorrect, it should look like this:
    Code:
    127.0.0.1       localhost.localdomain localhost
    192.168.20.233  mail.ourdomain.com mail
    Fix that and restart Zimbra and see what happens, any errors and if so what is it?
    I fixed the hosts file and it is now working, though it is unclear if that is what the problem was -- while I was working through the DNS issues someone else decided to just reinstall Zimbra. In any event, for the moment it does appear to be working, so we'll go ahead and add the necessary user accounts then modify the external DNS...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Cannot receive incoming mail but can send.
    By windependence in forum Administrators
    Replies: 2
    Last Post: 03-23-2010, 02:43 AM
  2. [SOLVED] Postfix unavailable - queue down
    By pmona in forum Administrators
    Replies: 20
    Last Post: 01-21-2010, 10:03 PM
  3. postfix relay=none status=bounced for local mails
    By vdd in forum Administrators
    Replies: 1
    Last Post: 08-06-2009, 08:05 AM
  4. Replies: 30
    Last Post: 01-13-2009, 08:00 AM
  5. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •