Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Ubuntu 10.04 and Zimbra 6.0.7 NE

  1. #11
    billiton is offline Junior Member
    Join Date
    Jul 2010
    Posts
    6
    Rep Power
    5

    Default You need to downgrade perl

    The temporary workaround is to downgrade perl to 5.08 from hardy. To accomplish this you need to add hardy deb lines to your sources.list and manually force a downgrade. Then use dpkg to set the package status for the downgraded packgages to "hold". If you dont know how to, use google.

    After all is done you should have something along these lines:
    Code:
    ~$ dpkg -l |grep perl
    ii  libio-string-perl                 1.08-2                          Emulate IO::File interface for in-core strin
    hi  liblocale-gettext-perl            1.05-1                          Using libc functions for internationalizatio
    hi  libnet-libidn-perl                0.07-1                          Perl bindings for GNU Libidn
    ii  libnet-snmp-perl                  5.2.0-3                         Script SNMP connections
    hi  libnet-ssleay-perl                1.30-1                          Perl module for Secure Sockets Layer (SSL)
    hi  libperl5.8                        5.8.8-7etch6                    Shared Perl library
    hi  libsocket6-perl                   0.19-1                          Perl extensions for IPv6
    hi  libterm-readkey-perl              2.30-3                          A perl module for simple terminal control
    hi  libtext-charwidth-perl            0.04-4                          get display widths of characters on the term
    hi  libtext-iconv-perl                1.4-3                           converts between character sets in Perl
    ii  libtext-wrapi18n-perl             0.06-7                          internationalized substitute of Text::Wrap
    ii  libtimedate-perl                  1.1900-1                        Time and date functions for Perl
    hi  perl                              5.8.8-7etch6                    Larry Wall's Practical Extraction and Report
    hi  perl-base                         5.8.8-7etch6                    The Pathologically Eclectic Rubbish Lister
    hi  perl-modules                      5.8.8-7etch6                    Core Perl modules
    Then, start the zimbra install and it should complete without errors.

  2. #12
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by billiton View Post
    The temporary workaround is to downgrade perl to 5.08 from hardy. To accomplish this you need to add hardy deb lines to your sources.list and manually force a downgrade. Then use dpkg to set the package status for the downgraded packgages to "hold".
    It is not advisable to do this, as I've mentioned several times this will invalidate your support for NE versions.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #13
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    Did you even read the instructions on the page you linked to!!??

    Visit the download page for Zimbra Open Source Edition and copy the link to the current version of the software for Debian 5 (Lenny) to your clipboard.
    You have to use the Debian 5 Zimbra package, NOT Ubuntu 8.04

    I followed the same instructions on a clean install of 10.04 with exact precision and now I am running 6.0.7 on Ubuntu 10.04 x64 with no issues. I can't imagine how it would be different for the Network Edition of Zimbra. No perl downgrading necessary.

    I only had to address a couple things that was not covered in the instructions:

    An important one below-
    sudo aptitude install libperl5.10

    And because I was importing live mailboxes. ...Fixing my briefcase URL's to point to https Luckily that's my own Forum thread, and I already knew how to fix it.

    My suggestion:
    1. Re-install Ubuntu 10.04 as I'm sure it's been mucked with too much by now.
    2. aptitude update
    3. aptitude safe-upgrade
    4. Follow the linode instructions to a T and add the command I ran above to your instructions.
    5. Make sure if your Ubuntu 10.04 server is 64 bit you get the 64 bit Debian 5 package of ZCS NE.
    (When they release an official Ubuntu 10.04 NE package in the near future you will probably just be able to upgrade from this existing install)
    6. Have fun!
    Last edited by tikal; 07-17-2010 at 04:07 PM.

  4. #14
    jason.rgd is offline Intermediate Member
    Join Date
    Jul 2010
    Posts
    19
    Rep Power
    5

    Default

    thanks a ton!! will try it out...

  5. #15
    n4bbq is offline Senior Member
    Join Date
    Oct 2008
    Location
    Dahlonega, Ga
    Posts
    52
    Rep Power
    6

    Default

    Just for kicks, do this.

    Edit /etc/lsb-release

    Change it from :
    Code:
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=10.04
    DISTRIB_CODENAME=lucid
    DISTRIB_DESCRIPTION="Ubuntu 10.04 LTS"
    To :
    Code:
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=8.04
    DISTRIB_CODENAME=hardy
    DISTRIB_DESCRIPTION="Ubuntu 8.04.4 LTS"
    Now try to run the zimbra installer again.

    If that doesn't work, be sure to change it back to the original and sit tight for a release.

  6. #16
    jason.rgd is offline Intermediate Member
    Join Date
    Jul 2010
    Posts
    19
    Rep Power
    5

    Default

    well what works is force installation ... it works well without any errors ... but I need to know how to fix the dns issues... Adding the MX records using bind... Trying to learn that out last few days...

  7. #17
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by jason.rgd View Post
    well what works is force installation ... it works well without any errors ... but I need to know how to fix the dns issues... Adding the MX records using bind... Trying to learn that out last few days...
    Details are all over the forums and wiki if you search, you need a Split DNS if you're behind a NAT router.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 08-18-2011, 10:15 PM
  2. [SOLVED] Moving Zimbra to a new server
    By krolen in forum Administrators
    Replies: 109
    Last Post: 02-05-2009, 11:38 AM
  3. Upgrade to ZCS 5.10
    By blozancic in forum Installation
    Replies: 0
    Last Post: 10-21-2008, 08:03 AM
  4. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  5. Replies: 8
    Last Post: 02-27-2007, 04:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •