Results 1 to 6 of 6

Thread: [SOLVED] deferred mail & load average

  1. #1
    thecuriouspenguin is offline New Member
    Join Date
    May 2010
    Posts
    3
    Rep Power
    5

    Default [SOLVED] deferred mail & load average

    Hi,

    I am currently trying to get Zimbra up and running. The problem I have is that zimbra is trying to relay mail to the root domain's ip.

    How do I configure zimbra to send mail to itself?

    cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.100.2 example.com mail

    the firewall(pfsense) is configured to forward the public 2.2.2.2 address to 192.168.100.2

    The dns record are as follow

    host example.com
    example.com has address 1.1.1.1
    example.com mail is handled by 10 mail.example.com.

    host -t a mail.example.com
    mail.example.com has address 2.2.2.2

    Zimbra's ip address is 2.2.2.2 however all the received mail are being forwarded to 1.1.1.1 as a result all the received mail ended up in the deferred queue.

    I search the forum but did not find a solution.

    Also, the load average is around 0.56 0.69 0.75 with only a couple test email. Is this normal? The server is a dual core xeon 2.13ghz with 3gb of memory and a 300gb hd running debian lenny.

    thanks,

    John

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Your hosts file is incorrect as it doesn't have a FQDN for the mail server, the correct format is in the Quick Start Installation Guide. You'll also need a Split DNS set-up as you're behind a NAT router. Both of those topics are all over the forums, if you search you'll find details on how to diagnose the correct set-up for both of them.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    thecuriouspenguin is offline New Member
    Join Date
    May 2010
    Posts
    3
    Rep Power
    5

    Default

    I reinstalled and corrected the hosts file to reflect the correct FQDN. Setting up split dns allowed me to removed the extra port forwarding rule for port 7025.

    thanks,

    John

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Quote Originally Posted by thecuriouspenguin View Post
    I reinstalled and corrected the hosts file to reflect the correct FQDN. Setting up split dns allowed me to removed the extra port forwarding rule for port 7025.
    Glad you've fixed it. If everything is working OK could you mark this thread as Solved (it's in the Thread Tools drop down at the top of the page)?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    thecuriouspenguin is offline New Member
    Join Date
    May 2010
    Posts
    3
    Rep Power
    5

    Default

    thanks phoenix,

    I followed the split-dns link and modified the instruction slightly for debian. . don't know if it's correct but the split-dns to be working.

    I installed bind and modified /etc/bind/name.conf.option and added my isp's name server to the forwarders

    modified /etc/bind/named.conf.local and added the zone information for the mail server.

    created /var/cache/bind/db.mail.server.com and pasted the instruction from the split-dns link.

    anyway, I don't know if I configured bind correctly bu split dns seems to be working without error messages in the syslog.

    thanks again,

    John

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Quote Originally Posted by thecuriouspenguin View Post
    anyway, I don't know if I configured bind correctly bu split dns seems to be working without error messages in the syslog.

    thanks again,
    You're welcome and thanks for updating the wiki. If the following commands (run on the Zimbra server) return your LAN IP (and your hosts file is correct, which it now is) then the Split DNS is OK:

    Code:
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname` <- use that exact command with backticks not single quotes
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clients stopped receiving emails
    By egadinc in forum Administrators
    Replies: 16
    Last Post: 12-14-2009, 03:38 PM
  2. Migration Assistance
    By dwill in forum Administrators
    Replies: 10
    Last Post: 12-02-2008, 08:20 AM
  3. [SOLVED] Zimbra don't work - zmmailboxd
    By dmalherbe in forum Administrators
    Replies: 10
    Last Post: 11-20-2008, 10:05 AM
  4. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 12:41 AM
  5. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •