Results 1 to 5 of 5

Thread: How do I set Admin password?

  1. #1
    sjames is offline Junior Member
    Join Date
    Jul 2006
    Posts
    5
    Rep Power
    9

    Default How do I set Admin password?

    Hi,

    I have read through the docs at http://www.zimbra.com/community/documentation.html and during install on my Centos 4.3 box I was never asked to set an admin password.

    So I can't login to the web admin page. I have tried to set the password using the command 'zmprov'; however I still can't login.

    Here is what I did

    zmprov sp admin@domain.name password
    ERROR: account.NO_SUCH_ACCOUNT (no such account: admin@domain.name)
    [zimbra@lilac ~]$ zmprov sp admin password
    ERROR: account.NO_SUCH_ACCOUNT (no such account: admin)
    [zimbra@lilac ~]$ zmprov ca admin password
    ERROR: service.INVALID_REQUEST (invalid request: must be valid email address: admin)
    [zimbra@lilac ~]$ zmprov ca admin@domain.name password
    fd604ef1-87ty-49b3-23uo-2a90ad63e71d

    The when I try to log into the admin I get the message "User does not have administrator rights".
    By the way the user can log into the front end.

    I can't think how to add or modify the admin user if this does not work.

    Any suggestions?

    Steve

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Well, I suppose it could be a number of things.

    The most likely in my mind is that you arn't logging in with the FQDN

    Try:
    admin@hostname.domain.com

  3. #3
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    11

    Default zimbraIsAdminAccount TRUE

    Quote Originally Posted by sjames
    [zimbra@lilac ~]$ zmprov ca admin@domain.name password
    fd604ef1-87ty-49b3-23uo-2a90ad63e71d

    The when I try to log into the admin I get the message "User does not have administrator rights".
    The name "admin" isn't magic. If you don't specify that the account you're creating is an admin account, it's not an admin account.

    Try adding " zimbraIsAdminAccount TRUE" to the end of your zmprov ca command and it should work.

    (As for the install interview questions, I'm afraid you'll have to wait for marmac or KevinH to help you...)
    Bugzilla - Wiki - Downloads - Before posting... Search!

  4. #4
    sjames is offline Junior Member
    Join Date
    Jul 2006
    Posts
    5
    Rep Power
    9

    Default

    Thanks; I would try that extra part of the command line but I have messed up my Zimbra install.

    I messed it up while trying to X + enter as instructed on page 17 of the "quick_start.pdf" - it screwed up my reinstall. I guess if the menu on page 18 does not display then X + enter does not apply.

    Now I am getting the
    Setting defaults...Can't call method "answer" on an undefined value at /opt/zimbra/libexec/zmsetup.pl line 460
    as discussed here Installation Fails on Setting Defaults

    I never had this problem before, however my DNS did have an error; will try again later when DNS has updated.

    By the way where is that "zimbraIsAdminAccount TRUE" mentioned in the documentation?

    Regards Steve

  5. #5
    sjames is offline Junior Member
    Join Date
    Jul 2006
    Posts
    5
    Rep Power
    9

    Default

    Update:

    Setting a dns MX record with an A name as opposed to a Cname fixed the "line 460" error.

    The script "zmsetup.pl" then went on to install and even displayed the menu where I could enter the admin password. (I may have passed over this on the 1st install or maybe it never appeared; I can't honestly say which )

    Now I can send an email, but so far not receive any( they are in the deferred queue) ; will reexamine my configurations.

    Very nice though.

    Regards
    Steve

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 04:21 PM
  2. Change admin password
    By tgx in forum Installation
    Replies: 1
    Last Post: 01-11-2007, 07:26 PM
  3. Zimbra Admin Account Password Recovery
    By nberlanga in forum Administrators
    Replies: 8
    Last Post: 11-28-2006, 03:52 PM
  4. Forgot admin password
    By dunkirk in forum Installation
    Replies: 3
    Last Post: 11-04-2006, 09:52 AM
  5. change admin password
    By jakebriems in forum Installation
    Replies: 1
    Last Post: 03-31-2006, 06:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •