Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: mta/smtp issues after install

  1. #1
    kmcital is offline New Member
    Join Date
    Jul 2006
    Posts
    4
    Rep Power
    8

    Default mta/smtp issues after install

    Installer complained about port conflicts for 80 and 25, I've since disabled Apache web server and made sure sendmail is not running.

    Now I have the following behavior:
    - telnet localhost 25 SUCCESS
    - telnet mailhost.example.com 25 FAILS
    - telnet mailhost.example.com 7025 SUCCESS
    - sometimes I get connection refused when sending mail
    - sometimes I get rejected, user unknown in local recipient tables

    No mail is getting delivered for either internal or external recipients.

    I did a zmmtactl start and all looked fine with postfix startup.

    Any ideas?

  2. #2
    kmcital is offline New Member
    Join Date
    Jul 2006
    Posts
    4
    Rep Power
    8

    Default more info

    telnet localhost 25
    Code:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 mailhost.example.com ESMTP Postfix
    HELO mail.abc.com
    250 mailhost.example.com
    mail from:kcital@abc.com
    250 Ok
    rcpt to:test@mailhost.example.com
    550 : Recipient address rejected: User unknown in local recipient table
    I noticed that /var/log/zimbra.log is empty - I thought postfix log is redirected to there.

    Result from zmcontrol status:
    Code:
    Host mailhost.example.com
            antispam                Running
            antivirus               Running
            ldap                    Running
            logger                  Running
            mailbox                 Running
            mta                     Stopped
                    postfix is not running
            snmp                    Running
            spell                   Stopped
                    zmapachectl is not running
    So I started it:
    Code:
    zimbra@mailhost:~/bin> zmmtactl start
    getService: sasl
    getService: webxml
    getService: perdition
    DO: /opt/zimbra/postfix/sbin/postconf -e content_filter='smtp-amavis:[127.0.0.1]:10024'
    DO: /opt/zimbra/postfix/sbin/postconf -e myhostname='mailhost.instatservices.com'
    DO: /opt/zimbra/postfix/sbin/postconf -e recipient_delimiter=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_sasl_auth_enable='no'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_auth_only='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_use_tls='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e disable_dns_lookups='no'
    DO: /opt/zimbra/postfix/sbin/postconf -e message_size_limit='10240000'
    DO: /opt/zimbra/postfix/sbin/postconf -e relayhost='mail.instatservices.com:25'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_recipient_restrictions='reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, permit'
    DO: /opt/zimbra/postfix/sbin/postconf -e alias_maps='hash:/etc/aliases'
    DO: /opt/zimbra/postfix/sbin/postconf -e broken_sasl_auth_clients='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e command_directory='/opt/zimbra/postfix-2.2.9/sbin'
    DO: /opt/zimbra/postfix/sbin/postconf -e daemon_directory='/opt/zimbra/postfix-2.2.9/libexec'
    DO: /opt/zimbra/postfix/sbin/postconf -e header_checks='pcre:/opt/zimbra/conf/postfix_header_checks'
    DO: /opt/zimbra/postfix/sbin/postconf -e mailq_path='/opt/zimbra/postfix-2.2.9/sbin/mailq'
    DO: /opt/zimbra/postfix/sbin/postconf -e manpage_directory='/opt/zimbra/postfix-2.2.9/man'
    DO: /opt/zimbra/postfix/sbin/postconf -e newaliases_path='/opt/zimbra/postfix-2.2.9/sbin/newaliases'
    DO: /opt/zimbra/postfix/sbin/postconf -e queue_directory='/opt/zimbra/postfix-2.2.9/spool'
    DO: /opt/zimbra/postfix/sbin/postconf -e sender_canonical_maps='ldap:/opt/zimbra/conf/ldap-scm.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e sendmail_path='/opt/zimbra/postfix-2.2.9/sbin/sendmail'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_client_restrictions='reject_unauth_pipelining'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_data_restrictions='reject_unauth_pipelining'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_helo_required='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_cert_file='/opt/zimbra/conf/smtpd.crt'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_key_file='/opt/zimbra/conf/smtpd.key'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_loglevel='3'
    DO: /opt/zimbra/postfix/sbin/postconf -e transport_maps='ldap:/opt/zimbra/conf/ldap-transport.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e version='2.2.9'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_alias_domains='ldap://opt/zimbra/conf/ldap-vad.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_alias_maps='ldap:/opt/zimbra/conf/ldap-vam.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_mailbox_domains='ldap:/opt/zimbra/conf/ldap-vmd.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_mailbox_maps='ldap:/opt/zimbra/conf/ldap-vmm.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_transport='error'
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.2.9/conf/main.cf
    postfix/postfix-script: starting the Postfix mail system
    Then I try again:
    Code:
    zimbra@mailhost:~/bin> telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 mailhost.instatservices.com ESMTP Postfix
    HELO abc.com
    250 mailhost.instatservices.com
    MAIL from:a@abc.com
    250 Ok
    rcpt to: test@mailhost.instatservices.com
    550 : Recipient address rejected: User unknown in local recipient table
    QUIT
    221 Bye
    Connection closed by foreign host.
    zimbra@mailhost:~/bin> telnet mailhost.instatservices.com 25
    Trying 192.168.3.6...
    telnet: connect to address 192.168.3.6: Connection refused
    Not sure where to go from here. OH, and I notice that zmcontrol status reports the same as above again: mta stopped and postfix not running.

    TIA for any help.
    Last edited by kmcital; 07-15-2006 at 06:22 AM.

  3. #3
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    what is the output of "ps aux | grep postfix"? also what are the file permissions on the log ("ls -la /var/log/zimbra.log")?

  4. #4
    kmcital is offline New Member
    Join Date
    Jul 2006
    Posts
    4
    Rep Power
    8

    Default

    what is the output of "ps aux | grep postfix"?
    Code:
    root     20196  0.0  0.5   5416  1724 ?        Ss   Jul15   0:16 /usr/lib/postfix/master
    postfix  20198  0.0  0.5   5416  1744 ?        S    Jul15   0:03 qmgr -l -t fifo -u
    postfix   2785  0.0  0.5   5380  1700 ?        S    15:13   0:00 pickup -l -t fifo -u
    postfix  14805  0.0  0.6   5392  1988 ?        S    16:30   0:00 trivial-rewrite -n rewrite -t unix -u
    root     15219  0.0  0.2   1852   644 pts/0    S+   16:32   0:00 grep postfix
    also what are the file permissions on the log?
    -rw-r--r-- 1 root root 0 Jul 14 02:06 /var/log/zimbra.log

  5. #5
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    a non-zimbra postfix is already running:

    > root 20196 0.0 0.5 5416 1724 ? Ss Jul15 0:16 /usr/lib/postfix/master
    disable that and run "chown zimbra:zimbra /var/log/zimbra.log" as root and you should be ready to go

  6. #6
    mlissner is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Berkeley, CA
    Posts
    24
    Rep Power
    7

    Default

    Quote Originally Posted by bobby View Post
    a non-zimbra postfix is already running:



    disable that and run "chown zimbra:zimbra /var/log/zimbra.log" as root and you should be ready to go
    I had this same problem, and I killed off postfix this time. How do I make it so root doesn't start it again in the future? Also, any theories on why postfix might suddenly decide that it should be starting itself up randomly?

    I've had Zimbra installed for about 8 months, with no problems of this sort...then today, this.

  7. #7
    mlissner is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Berkeley, CA
    Posts
    24
    Rep Power
    7

    Default

    This is a bit of an old thread, but I'm still living with this problem. I have Drupal and Zimbra on the same server, and they both require postfix. What happens when I reboot is that postfix is started for Drupal, and then Zimbra can't have it.

    My solution thus far has been to kill the process started by Drupal, and to restart Zimbra. This allows Zimbra to send mail, but not Drupal, which is not a particularly good solution.

    Does anybody know how I can set it up so that they both have access to postfix, and can thus send mail?

  8. #8
    Jesster's Avatar
    Jesster is offline Trained Alumni
    Join Date
    Nov 2007
    Location
    Santa Barbara, CA.
    Posts
    109
    Rep Power
    7

    Default

    Quote Originally Posted by mlissner View Post
    Does anybody know how I can set it up so that they both have access to postfix, and can thus send mail?
    Generally speaking you shouldn't run other services on your zimbra server, with that said, you _might_ be OK manually modifying the main.cf Postfix file for BOTH Drupal and Zimbra postfix instances. You could change the interface that Drupal uses to localhost, and zimbra use your ethernet IP. Just remember that Zimbra upgrades tend to wipe out manual configuration changes.

    Drupal configuration then points to 'localhost' for the mail server.

    This is not something I've ever tried, YMMV.

    -Jessie

  9. #9
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Is it Drupal that is starting Postfix at boot or the init scripts ? If on RHEL/CentOS just run
    Code:
    chkconfig postfix off
    , and then point Drupal to use localhost as the SMTP server as Jesster has said.

  10. #10
    mlissner is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Berkeley, CA
    Posts
    24
    Rep Power
    7

    Default

    Hmmm....I am running Ubuntu, so that command to check if it is the init scripts or not doesn't work. I believe though that it is actually the init scripts that are starting it. Is there an Ubuntu way to check?

    Assuming that it is the init scripts, I'm not sure how to point drupal (or is it the init scripts?) at localhost, or what exactly that means.

    I would be very grateful if somebody could help me with this last mile.

    (As an aside, I should also mention that I had drupal and zimbra on different servers for a while, but combined them because I couldn't rationalize running two servers when one was enough. That was in fact when this problem began.)

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. interface conflict issues with debian install.
    By thequestion in forum Installation
    Replies: 5
    Last Post: 03-16-2007, 06:53 AM
  2. Replies: 16
    Last Post: 11-29-2006, 10:36 AM
  3. A couple of install issues -- MX and domain
    By Storm16 in forum Installation
    Replies: 2
    Last Post: 10-31-2006, 11:31 AM
  4. two servers, DNS issues, install fails at LDAP
    By marqpdx in forum Installation
    Replies: 6
    Last Post: 08-02-2006, 06:15 PM
  5. Install issues with FC4 and one error
    By ketank in forum Installation
    Replies: 7
    Last Post: 03-02-2006, 11:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •