Results 1 to 7 of 7

Thread: [SOLVED] Can't send emails through PHP

  1. #1
    josebarros is offline Member
    Join Date
    Mar 2009
    Location
    Portugal
    Posts
    14
    Rep Power
    6

    Default [SOLVED] Can't send emails through PHP

    Hello.

    I've recently updated Zimbra to 6.0.3 and can't actually send mails through PHP, using mail function.

    I'm not sure if it worked in previous version...

    I'm running it on a RHEL 4 with Plesk installed.
    I've installed zimbra with different ports, and everything is running smoothly except this issue.

    I've tried to change the simlink as adviced, without result...

    Running phpinfo() I got "/opt/zimbra/postfix/sbin/sendmail" for sendmail_path...

    Can someone help me?
    Thank you

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    It would help if you were to provide any error messages from your logfiles ? Have you checked the Apache logs and /var/log/zimbra.log ?

  3. #3
    josebarros is offline Member
    Join Date
    Mar 2009
    Location
    Portugal
    Posts
    14
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    It would help if you were to provide any error messages from your logfiles ? Have you checked the Apache logs and /var/log/zimbra.log ?

    From the apache error_log I've got this:

    sendmail: fatal: setrlimit: Permission denied
    sendmail: fatal: setrlimit: Permission denied
    sendmail: fatal: setrlimit: Permission denied
    sendmail: fatal: setrlimit: Permission denied
    sendmail: fatal: setrlimit: Permission denied
    sendmail: fatal: setrlimit: Permission denied

    The /var/log/zimbra.log has this last lines:
    Jan 5 12:27:12 arturai imapd: Connection, ip=[127.0.0.1]
    Jan 5 12:27:12 arturai imapd: 1262694432.695271 LOGOUT, ip=[127.0.0.1], rcvd=12, sent=308, maildir=/etc/rc.d/init.d
    Jan 5 12:27:12 arturai imapd-ssl: 1262694432.736596 LOGOUT, ip=[127.0.0.1], rcvd=12, sent=310, maildir=/etc/rc.d/init.d
    Jan 5 12:28:00 arturai zmmailboxdmgr[3521]: status requested
    Jan 5 12:28:00 arturai zmmailboxdmgr[3521]: status OK
    Jan 5 12:28:01 arturai zmmailboxdmgr[3553]: status requested
    Jan 5 12:28:01 arturai zmmailboxdmgr[3553]: status OK
    Jan 5 12:28:06 arturai zmmailboxdmgr[3899]: status requested
    Jan 5 12:28:06 arturai zmmailboxdmgr[3899]: status OK
    Jan 5 12:29:03 arturai postfix/anvil[18487]: statistics: max connection rate 1/60s for (smtp:79.48.16.93) at Jan 5 12:25:01
    Jan 5 12:29:03 arturai postfix/anvil[18487]: statistics: max connection count 1 for (smtp:79.48.16.93) at Jan 5 12:25:01
    Jan 5 12:29:03 arturai postfix/anvil[18487]: statistics: max cache size 3 at Jan 5 12:25:20
    Jan 5 12:29:29 arturai zmmailboxdmgr[4954]: status requested
    Jan 5 12:29:29 arturai zmmailboxdmgr[4954]: status OK
    Jan 5 12:29:29 arturai zmmailboxdmgr[4986]: status requested
    Jan 5 12:29:29 arturai zmmailboxdmgr[4986]: status OK
    Jan 5 12:30:02 arturai zimbramon[5055]: 5055:info: 2010-01-05 12:30:02, QUEUE: 0 0
    Does this helps?

    Thank you for your response.

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    How have you configured PHP to sendmail then ?

  5. #5
    josebarros is offline Member
    Join Date
    Mar 2009
    Location
    Portugal
    Posts
    14
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    How have you configured PHP to sendmail then ?
    I've manage to solve it

    Everything was correct, thing was related to SELinux.
    It seems that SELinux is messing with postfix, só I edited the

    "/etc/selinux/config"
    file with

    SELINUX= line to SELINUX=disabled
    Found @ Postfix 0512: Re: fatal: setrlimit: Permission denied

    Thanks uxbod anyway

    Hope this helps someone too

  6. #6
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Excellent; that is detailed in the Installation guide

  7. #7
    josebarros is offline Member
    Join Date
    Mar 2009
    Location
    Portugal
    Posts
    14
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    Excellent; that is detailed in the Installation guide
    ehehe

    Jumped that part :P

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Still Cannot Send Emails to Yahoo
    By dfriestedt in forum Administrators
    Replies: 14
    Last Post: 03-25-2009, 01:02 PM
  2. March 6 EDU Summit @ Yahoo UK
    By mmorse in forum Zimbra in Education
    Replies: 0
    Last Post: 02-25-2009, 12:22 PM
  3. Zimbra @ Educause - Orlando
    By justcdl123 in forum Zimbra in Education
    Replies: 0
    Last Post: 08-19-2008, 12:15 PM
  4. Replies: 1
    Last Post: 02-20-2008, 10:19 AM
  5. Can't send email from php
    By tanasea in forum Installation
    Replies: 2
    Last Post: 08-01-2006, 08:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •