Results 1 to 3 of 3

Thread: Email not sending or receiving after update to 6.0.3 NE CentOS5

  1. #1
    Goonsniper is offline Active Member
    Join Date
    Oct 2008
    Location
    Vancouver
    Posts
    38
    Rep Power
    6

    Default Email not sending or receiving after update to 6.0.3 NE CentOS5

    Hi

    Just upgraded from 5.0.18 -> 6.0.3 and now when sending email the web client I get an error about the server acting slow and eventually fails. The following shows up in /opt/zimbra/log/mailbox.log

    com.zimbra.common.service.ServiceException: system failure: Unable to send message
    ExceptionId:btpool0-49:https://10.12.5.10:443/service/soap/...b9a7104339c925
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java: 247)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:453)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:280)
    at com.zimbra.cs.service.mail.SendMsg.doSendMessage(S endMsg.java:187)
    at com.zimbra.cs.service.mail.SendMsg.handle(SendMsg. java:150)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:418)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:272)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:156)
    at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:291)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:212)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:181)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:502)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1157)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:148)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1148)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:379)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:765)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:418)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:230)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:230)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.DebugHandler.handle(Debu gHandler.java:77)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.Server.handle(Server.java:324)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:525)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:882)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:755)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:212)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:387)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:409)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451)
    Caused by: com.zimbra.cs.mailbox.MailSender$SafeMessagingExce ption: Exception reading response; chained exception is:
    java.net.SocketTimeoutException: Read timed out
    at com.sun.mail.smtp.SMTPTransport.readServerResponse (SMTPTransport.java:1764)
    at com.sun.mail.smtp.SMTPTransport.close(SMTPTranspor t.java:823)
    at javax.mail.Transport.send0(Transport.java:193)
    at javax.mail.Transport.send(Transport.java:142)
    at com.zimbra.cs.mailbox.MailSender.sendMessage(MailS ender.java:612)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:376)
    ... 36 more
    2009-11-28 16:50:05,852 INFO [btpool0-49:https://127.0.0.1:7071/service /admin/soap/AuthRequest] [ip=127.0.0.1;] soap - AuthRequest
    2009-11-28 16:50:06,019 INFO [btpool0-49:https://127.0.0.1:7071/service/admin...erversRequest] [name=zimbra;ip=127.0.0.1;] soap - GetAllServersRequest

    I've disabled the firewall, tried fixperms, server is 99% idle etc.

    Thanks

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Post the output of the following commands (run on the zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname`  <-- use the exact command with backticks not single quotes
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Goonsniper is offline Active Member
    Join Date
    Oct 2008
    Location
    Vancouver
    Posts
    38
    Rep Power
    6

    Default

    Zimbra support found the issue quickly. I had done some custom postfix work in an early release of 5.x that worked through all the versions of 5.x that I used... but was a show stopper in 6.0.3.

    I don't need that custom config any longer so we removed it and I'm up and running.

    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Moving Zimbra to a new server
    By krolen in forum Administrators
    Replies: 109
    Last Post: 02-05-2009, 11:38 AM
  2. Whis Job is sending this Email
    By Nextasy in forum Administrators
    Replies: 4
    Last Post: 12-14-2007, 01:11 PM
  3. Sending but not receiving
    By pbwebguy in forum Administrators
    Replies: 11
    Last Post: 06-22-2006, 12:58 AM
  4. Problem sending and Receiving mail
    By geroshea in forum Installation
    Replies: 3
    Last Post: 03-06-2006, 10:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •