Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: error during rebuild on ZimbraBuild

  1. #1
    jamesjr555 is offline Active Member
    Join Date
    May 2006
    Posts
    28
    Rep Power
    9

    Unhappy error during rebuild on ZimbraBuild

    hello all,

    initially i installed zimbra and then uninstalled it using ./install -u.
    then i tried to rebuilt by using make command in ZimbraBuild.
    during this process i am facing the following error :
    ..
    .
    + /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
    + /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
    Processing files: zimbra-mta-3.5.0_M1_279.FC4-20060615165028
    Checking for unpackaged file(s): /usr/lib/rpm/check-files /home/zimbra/ZimbraBuild/mtabuild
    error: Installed (but unpackaged) file(s) found:
    /opt/zimbra/clamav-0.88/clamav-0.88


    RPM build errors:
    Installed (but unpackaged) file(s) found:
    /opt/zimbra/clamav-0.88/clamav-0.88
    make: *** [mta] Error 1


    plz kindly help me in resolving this problem,

    thanx

    james jr

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Looks like your missing the clamav source. Did you get all the 3rd party sources?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    jamesjr555 is offline Active Member
    Join Date
    May 2006
    Posts
    28
    Rep Power
    9

    Unhappy rebuild resolved; but while installing ldap problems

    thanks for ur reply to all,

    now the problem of build in ZimbraBuild is resolved
    but now i am trying to install zimbra by using /zcs/ as ./install.sh
    during this i got an error as shown below :
    .
    .
    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes] yes
    Save config in file: [/opt/zimbra/config.4106]
    Saving config in /opt/zimbra/config.4106...Done
    The system will be modified - continue? [No] yes
    Operations logged to /tmp/zmsetup.log.4106
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...FAILED (256)


    ERROR



    Configuration failed

    my os is FC4,
    and my ip is 203.193.129.103 and is MX-record configured,

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.

    plz help me in resloving this issuse.

    waiting for ur reply

    thanx

    jamesjr

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    Are you absolutely sure that your /etc/hosts file & DNS are set-up correctly? What errors are in the install log?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    jamesjr555 is offline Active Member
    Join Date
    May 2006
    Posts
    28
    Rep Power
    9

    Unhappy

    thanks
    my hosts file contains these things
    ]# /etc/hosts
    /etc/hosts: line 3: 127.0.0.1: command not found
    /etc/hosts: line 4: 203.193.129.103: command not found
    ]#

    and the ip is correctly DNS configured.

    and the install.log file contains :

    Preparing packages for installation...
    zimbra-core-3.5.0_M1_279.FC4-20060617211246
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    cp: cannot stat `/opt/zimbra/bin/zimbra': No such file or directory
    chmod: cannot access `/etc/init.d/zimbra': No such file or directory
    error reading information on service zimbra: No such file or directory
    error reading information on service zimbra: No such file or directory
    mkdir: cannot create directory `/opt/zimbra/.ssh': File exists
    Loading classes to share ... done.
    Rewriting and unlinking classes ... done.
    Calculating hash values for String objects .. done.
    Calculating fingerprints ... done.
    Removing unshareable information ... done.
    Moving most read-only objects to shared space at 0x90b70000 ... done.
    Moving common symbols to shared space at 0x90eeabc0 ... done.
    Moving remaining symbols to shared space at 0x91016008 ... done.
    Moving string char arrays to shared space at 0x91016a98 ... done.
    Moving additional symbols to shared space at 0x91098390 ... done.
    Read-only space ends at 0x910ec408, 5751816 bytes.
    Moving read-write objects to shared space at 0x91370000 ... done.
    Moving String objects to shared space at 0x918f3a10 ... done.
    Read-write space ends at 0x91933a30, 6044208 bytes.
    Updating references to shared objects ... done.

    Preparing packages for installation...
    zimbra-ldap-3.5.0_M1_279.FC4-20060617211246
    Preparing packages for installation...
    zimbra-logger-3.5.0_M1_279.FC4-20060617211246
    Preparing packages for installation...
    zimbra-mta-3.5.0_M1_279.FC4-20060617211246
    umount2: No such file or directory
    umount: /opt/zimbra/amavisd/tmp: not found
    mv: cannot stat `/opt/zimbra/amavisd': No such file or directory
    chown: changing ownership of `/opt/zimbra/jdk1.5.0_06/jre/javaws/javaws': No such file or directory
    chown: cannot access `/opt/zimbra/perdition-1.17': No such file or directory
    Preparing packages for installation...
    zimbra-snmp-3.5.0_M1_279.FC4-20060617211246
    Preparing packages for installation...
    zimbra-store-3.5.0_M1_279.FC4-20060617211246
    Preparing packages for installation...
    zimbra-apache-3.5.0_M1_279.FC4-20060617211246
    Preparing packages for installation...
    zimbra-spell-3.5.0_M1_279.FC4-20060617211246
    ..

    and my zmsetup.log file contains :

    ** Creating CA private key

    Generating a 1024 bit RSA private key
    ..++++++
    .........++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/ca/ca.key'
    -----
    ** Creating CA cert

    Signature ok
    subject=/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite
    Getting Private key
    unable to write 'random state'
    ** Importing CA

    Certificate was added to keystore
    ** Creating keystore

    ** Creating server cert request

    Generating a 1024 bit RSA private key
    ..............++++++
    .................................................. .................................++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/server/server.key'
    -----
    ** Signing cert request

    Using configuration from /opt/zimbra/ssl/ssl/zmssl.cnf
    Check that the request matches the signature
    Signature ok
    Certificate Details:
    Serial Number: 2 (0x2)
    Validity
    Not Before: Jun 17 18:09:55 2006 GMT
    Not After : Jun 17 18:09:55 2007 GMT
    Subject:
    countryName = US
    stateOrProvinceName = N/A
    organizationName = Zimbra Collaboration Suite
    commonName = nitwzim.no-ip.info
    X509v3 extensions:
    X509v3 Basic Constraints:
    CA:FALSE
    Netscape Comment:
    OpenSSL Generated Certificate
    X509v3 Subject Key Identifier:
    7E:F9:5A:52:F9:3A:A3F:15:59:5F:C2:87:26:433:7B:78:C7:F6
    X509v3 Authority Key Identifier:
    DirName:/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite
    serial6:7B:68:7E:4E:9E:E2:BC

    X509v3 Key Usage:
    Digital Signature, Non Repudiation, Key Encipherment
    Certificate is to be certified until Jun 17 18:09:55 2007 GMT (365 days)

    Write out database with 1 new entries
    Data Base Updated
    unable to write 'random state'
    Signature ok
    subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=nitwzim.no-ip.info
    Getting CA Private Key
    unable to write 'random state'
    Unrecognized database type (bdb)
    ERROR - failed to start slapd


    plz help me in resolving this.

    thanx

    jamesjr

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    I don't quite understand what's wrong with your hosts file, it should look like this:
    Code:
    127.0.0.1 localhost.localdomain localhost
    192.168.0.100 mailhost.xyz.com mailhost
    Obviously you should have a correct IP & FQDN for your server in that file.

    I still suspect that your DNS is not set-up correctly. Do the following commands return the correct info?
    Code:
    nslookup mail.exampledomain.com
    Code:
    # nslookup
    >set type=MX
    >exampledomain.com.
    Is your DNS hosted on your LAN or on a public DNS server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    jamesjr555 is offline Active Member
    Join Date
    May 2006
    Posts
    28
    Rep Power
    9

    Unhappy

    thanks

    the observations that i got is :

    # nslookup mail.nitwzim.no-ip.info
    Server: 165.21.83.88
    Address: 165.21.83.88#53

    ** server can't find mail.nitwzim.no-ip.info: NXDOMAIN

    #

    and

    # nslookup
    > set type=MX
    > nitwzim.no-ip.info
    Server: 165.21.83.88
    Address: 165.21.83.88#53

    Non-authoritative answer:
    nitwzim.no-ip.info mail exchanger = 15 nitwzim.no-ip.info.
    nitwzim.no-ip.info mail exchanger = 20 nitwzim.no-ip.info.
    nitwzim.no-ip.info mail exchanger = 25 nitwzim.no-ip.info.
    nitwzim.no-ip.info mail exchanger = 5 nitwzim.no-ip.info.
    nitwzim.no-ip.info mail exchanger = 10 nitwzim.no-ip.info.

    Authoritative answers can be found from:
    nitwzim.no-ip.info internet address = 203.193.129.103
    nitwzim.no-ip.info internet address = 203.193.129.103
    nitwzim.no-ip.info internet address = 203.193.129.103
    nitwzim.no-ip.info internet address = 203.193.129.103
    nitwzim.no-ip.info internet address = 203.193.129.103
    >


    and have public ip address.

    plz consider this and suggest me in resolving the problems.

    thanx

    jamesjr

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    Is the Zimbra server on a public IP address or is it behind a NAT router? If it is behind a router then you need a split DNS which is described here
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    jamesjr555 is offline Active Member
    Join Date
    May 2006
    Posts
    28
    Rep Power
    9

    Unhappy

    thanx

    my is a public ip address only.

    then what can i do now

    plz suggest me the needed things.

    thanx

    james jr

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    Do you have a firewall or SElinux installed? This "nitwzim.no-ip.info" does not point to an address that is reachable? Where is your Zimbra server located? Is it on a LAN? Is it the only PC on your public IP?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mysql data store rebuild
    By ashelley in forum Administrators
    Replies: 3
    Last Post: 03-23-2010, 03:39 PM
  2. Replies: 3
    Last Post: 08-01-2007, 03:07 PM
  3. trying to rebuild the server/permissions
    By dataforcecrm in forum Administrators
    Replies: 1
    Last Post: 07-21-2007, 10:01 PM
  4. got error during make in ZimbraBuild.
    By jamesjr555 in forum Developers
    Replies: 1
    Last Post: 09-18-2006, 12:04 AM
  5. make shows me error in ZimbraBuild
    By jamesjr555 in forum Installation
    Replies: 1
    Last Post: 06-26-2006, 12:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •