Results 1 to 2 of 2

Thread: ZCS 6 (amavisd 2.6.3+ and DSPAM)

  1. #1
    Timothy Brush is offline Starter Member
    Join Date
    Sep 2009
    Posts
    1
    Rep Power
    5

    Default ZCS 6 (amavisd 2.6.3+ and DSPAM)

    I was trying to help a client upgrade their installation from 5.x to 6.x but ran into problems getting DSPAM working. After some digging, I found that Amavisd >2.6.3 changed how it handles anti-spam scanners. They've added an array of anti-spam scanners and Amavis::SpamControl::ExtProg module.

    I've added the following to the amavisd.conf.in below the
    %%uncomment LOCAL:amavis_dspam_enabled%%$dspam = '/opt/zimbra/dspam/bin/dspam'; line.

    --- New configuration information ---
    @spam_scanners = (
    ['SpamAssassin', 'Amavis::SpamControl::SpamAssassin' ],

    %%uncomment LOCAL:amavis_dspam_enabled%% ['DSPAM', 'Amavis::SpamControl::ExtProg', $dspam,
    %%uncomment LOCAL:amavis_dspam_enabled%% [ qw(--stdout --classify --deliver=innocent,spam --mode=tum
    %%uncomment LOCAL:amavis_dspam_enabled%% --tokenizer=chained,noise --user), $daemon_user ],
    %%uncomment LOCAL:amavis_dspam_enabled%% # use option --feature instead of --tokenizer with dspam < 3.8.0
    %%uncomment LOCAL:amavis_dspam_enabled%% mail_body_size_limit => 64000, score_factor => 1,
    %%uncomment LOCAL:amavis_dspam_enabled%% ],
    );

    --- End of configuration information ---

    I hope this helps others that may face the same problem.

    Regards,
    Tim

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Thanks for the update. Can you file a report in bugzilla for this problem (include fix), please search to see if it's already been filed.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Enabling DSPAM
    By osiris in forum Administrators
    Replies: 80
    Last Post: 09-20-2012, 04:10 PM
  2. zmtrainsa + dspam = broken on 5.0.16GA network edition
    By shankwc in forum Administrators
    Replies: 1
    Last Post: 09-01-2011, 01:31 PM
  3. dspam broke after 4.5.7 upgrade?
    By Krishopper in forum Administrators
    Replies: 9
    Last Post: 09-24-2007, 08:07 AM
  4. Configuring and using DSPAM
    By JoshuaPrismon in forum Administrators
    Replies: 55
    Last Post: 03-02-2007, 09:08 AM
  5. Rewrote zmtrainsa for DSPAM
    By unilogic in forum Developers
    Replies: 18
    Last Post: 01-12-2006, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •