Results 1 to 6 of 6

Thread: ZCS 6.0 upgrade problem on DEB5

  1. #1
    nickgallis is offline Junior Member
    Join Date
    Aug 2009
    Posts
    8
    Rep Power
    5

    Default ZCS 6.0 upgrade problem on DEB5

    I try to upgrade from RC1 to GA on my deb 5 server but I give this error

    ./install.sh

    Operations logged to /tmp/install.log.13352
    Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-6.0.0_RC1_1684.DEBIAN4.0
    zimbra-logger...FOUND zimbra-logger-6.0.0_RC1_1684.DEBIAN4.0
    zimbra-mta...FOUND zimbra-mta-6.0.0_RC1_1684.DEBIAN4.0
    zimbra-snmp...FOUND zimbra-snmp-6.0.0_RC1_1684.DEBIAN4.0
    zimbra-store...FOUND zimbra-store-6.0.0_RC1_1684.DEBIAN4.0
    zimbra-apache...FOUND zimbra-apache-6.0.0_RC1_1684.DEBIAN4.0
    zimbra-spell...FOUND zimbra-spell-6.0.0_RC1_1684.DEBIAN4.0
    zimbra-convertd...NOT FOUND
    zimbra-memcached...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-cluster...NOT FOUND
    zimbra-core...FOUND zimbra-core-6.0.0_RC1_1684.DEBIAN4.0
    ZCS upgrade from 6.0.0 to 6.0.0 will be performed.

    Saving existing configuration file to /opt/zimbra/.saveconfig


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/zimbra..._eula_2.1.html


    Press Return to continue

    Checking for prerequisites...
    FOUND: NPTL
    FOUND: sudo-1.6.9p17-2
    FOUND: libidn11-1.8+20080606-1
    FOUND: libpcre3-7.6-2.1
    FOUND: libgmp3c2-2:4.2.2+dfsg-3
    FOUND: libexpat1-2.0.1-4
    FOUND: libstdc++6-4.3.2-1.1
    MISSING: libstdc++5
    Checking for suggested prerequisites...
    FOUND: perl-5.10.0
    FOUND: sysstat

    ###ERROR###

    One or more prerequisite packages are missing.
    Please install them before running this installer.

    Installation cancelled.

    log file tell me

    COMMAND: zmlocalconfig -s | sed -e "s/ = \(.*\)/=\'\1\'/" > /opt/zimbra/.saveconfig/config.save

    Where I can see what pack are missing???

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,476
    Rep Power
    56

    Default

    Quote Originally Posted by nickgallis View Post
    Where I can see what pack are missing???
    It tells you in the log output:

    Code:
    MISSING: libstdc++5
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    I'll note that installing DEBIAN4.0 on DEBIAN5 was never supported, and that "upgrading" a DEBIAN4.0 build on a DEBIAN5 server to a DEBIAN5 build is not supported. You many run into any number of problems.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  4. #4
    nickgallis is offline Junior Member
    Join Date
    Aug 2009
    Posts
    8
    Rep Power
    5

    Default

    ok solve installing libc++ tks sorry I can't read the error

  5. #5
    Hivos's Avatar
    Hivos is offline Advanced Member
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    5

    Default

    Just a warning: I tried upgrading from Debian 4 to Debian 5 with Zimbra 5.0.13 on a testing server once. It won't work because Debian 5 perl libraries are incompatible and therefore zmcontrol does not work.

  6. #6
    nickgallis is offline Junior Member
    Join Date
    Aug 2009
    Posts
    8
    Rep Power
    5

    Default

    Quote Originally Posted by Hivos View Post
    Just a warning: I tried upgrading from Debian 4 to Debian 5 with Zimbra 5.0.13 on a testing server once. It won't work because Debian 5 perl libraries are incompatible and therefore zmcontrol does not work.
    if you want user debian 5 you must install zcs 6 and before remove old version I make it and all work fine..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ZCS 6.0 RHEL 5 Failed to install
    By yyovkov in forum Installation
    Replies: 0
    Last Post: 09-03-2009, 03:42 AM
  2. [SOLVED] Upgrade Problem
    By iiibill in forum Installation
    Replies: 8
    Last Post: 07-13-2009, 10:01 PM
  3. Replies: 2
    Last Post: 04-24-2009, 04:52 PM
  4. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 03:46 PM
  5. Odd GA upgrade problem
    By drewage in forum Installation
    Replies: 2
    Last Post: 02-08-2006, 10:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •