Results 1 to 2 of 2

Thread: ldap initialization failed

  1. #1
    physikal is offline Loyal Member
    Join Date
    Apr 2009
    Posts
    90
    Rep Power
    6

    Default ldap initialization failed

    This is my current setup on an Amazon EC2 system, running CentOS 5.3.

    Error log:

    Code:
    ** Creating CA private key /opt/zimbra/ssl/zimbra/ca/ca.key...done.
    ** Creating CA cert /opt/zimbra/ssl/zimbra/ca/ca.pem...done.
    Tue Sep  1 17:24:42 2009 done.
    Tue Sep  1 17:24:42 2009 Deploying CA to /opt/zimbra/conf/ca ...
    Tue Sep  1 17:24:42 2009 *** Running as root user: /opt/zimbra/bin/zmcertmgr deployca -localonly
    ** Importing CA /opt/zimbra/ssl/zimbra/ca/ca.pem into CACERTS...done.
    ** Copying CA to /opt/zimbra/conf/ca...done.
    Tue Sep  1 17:24:43 2009 done.
    Tue Sep  1 17:24:43 2009 Creating SSL certificate...
    Tue Sep  1 17:24:43 2009 *** Running as root user: /opt/zimbra/bin/zmcertmgr createcrt self
    ** Creating /opt/zimbra/conf/zmssl.cnf...done
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20090901172444
    ** Retrieving server config key zimbraSSLCertificate...failed.
    ** Retrieving server config key zimbraSSLPrivateKey...failed.
    ** Generating a server csr for download self
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20090901172547
    ** Creating server cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Signing cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    Tue Sep  1 17:26:18 2009 done.
    Tue Sep  1 17:26:19 2009 Installing mailboxd SSL certificates...
    Tue Sep  1 17:26:19 2009 *** Running as root user: /opt/zimbra/bin/zmcertmgr deploycrt self
    ** Saving server config key zimbraSSLCertificate...failed.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Installing mta certificate and key...done.
    ** Installing slapd certificate and key...done.
    ** Installing proxy certificate and key...done.
    ** Creating pkcs12 file /opt/zimbra/ssl/zimbra/jetty.pkcs12...done.
    ** Creating keystore file /opt/zimbra/mailboxd/etc/keystore...done.
    ** Installing CA to /opt/zimbra/conf/ca...done.
    Tue Sep  1 17:27:23 2009 done.
    Tue Sep  1 17:27:23 2009 checking isEnabled zimbra-ldap
    Tue Sep  1 17:27:23 2009 zimbra-ldap is enabled
    Tue Sep  1 17:27:23 2009 Initializing ldap...
    Tue Sep  1 17:27:23 2009 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: timeout at /opt/zimbra/libexec/zmldapinit line 160.
    Tue Sep  1 17:30:16 2009 failed. (28160)
    Tue Sep  1 17:30:16 2009
    
    ERROR
    
    Tue Sep  1 17:30:16 2009
    
    Configuration failed
    /etc/resolv.conf

    Code:
    ; generated by /sbin/dhclient-script
    search compute-1.internal
    nameserver 172.16.0.23

    /etc/hosts
    Code:
    174.129.4.202 alt1.mail.domain.net alt1.mail
    174.129.4.202 mail.domain.net        mail
    127.0.0.1       localhost.localdomain   localhost
    I'm thinking its because my DNS is jacked and I need to install Split DNS, but I am uncertain. Any help would be greatly appreciated. Thanks!

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,499
    Rep Power
    56

    Default

    The usual reason for this error is a DNS problem and if you're behind a NAT router (or firewall) you'll need a Split DNS. The hosts file is also incorrect, it should only contain the following:

    Code:
    127.0.0.1       localhost.localdomain   localhost
    174.129.4.202   mail.domain.net        mail
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help!!! Moving ZCS does not work!
    By ASebestian in forum Migration
    Replies: 7
    Last Post: 02-12-2009, 06:06 PM
  2. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 10:38 AM
  3. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 11:29 AM
  4. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 09:23 PM
  5. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •