Results 1 to 4 of 4

Thread: [SOLVED] zimbra user exists with incorrect shell

  1. #1
    vasa is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    16
    Rep Power
    5

    Default [SOLVED] zimbra user exists with incorrect shell

    Hi,

    Successfully built Zimbra. I understand now ,under i386 folder I have my package to be installed. when run install.sh getting following error.

    WARNING: ZCS is currently only supported on Ubuntu Server 6.06 and 8.04 LTS.
    You are attempting to install on Ubuntu 9.04 which may not work.
    Support will not be provided if you choose to continue.


    Do you wish to continue? [N] y

    Operations logged to /tmp/install.log.6770
    Checking for existing installation...
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-convertd...NOT FOUND
    zimbra-cluster...NOT FOUND
    zimbra-core...NOT FOUND
    Error - zimbra user exists with incorrect shell: sh
    Exiting

    Should I be running install from i386 folder so that it finds above mentioned packages? Should I be running install as zimbra user? Also please point me to the detailed instructions after building from source.

    Thanks in advance.

    Vasa

  2. #2
    Dirk's Avatar
    Dirk is offline Moderator
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Hi, could I just ask the obvious first question, which is, given that the error message clearly states that you should use Ubuntu 6 or 8, why is it that you are using 9 ?

  3. #3
    vasa is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    16
    Rep Power
    5

    Default

    Hi Dirk,

    I agree its a obvious question, for which I would say I am trying Zimbra on latest ubuntu which is my req .
    (I read that it works fine with newer ubuntu but only thing we need to make it beleive that it is either 6.06 or 8.)
    In my case I could make it believe that its UBUNTU 6.06.Still I am getting following error..
    Operations logged to /tmp/install.log.5130
    Checking for existing installation...
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-convertd...NOT FOUND
    zimbra-cluster...NOT FOUND
    zimbra-core...NOT FOUND
    Error - zimbra user exists with incorrect shell: sh
    Exiting

    Please let know


    Should I be running install from i386 folder so that it finds above mentioned packages? Should I be running install as zimbra user? Also please point me to the detailed install instructions after building from source.

    Thanks in advance.

    Vasa

  4. #4
    vasa is offline Intermediate Member
    Join Date
    Jul 2009
    Posts
    16
    Rep Power
    5

    Default

    Make sure zimbra user is using bash shell by modifying /etc/passwd/

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. postfix relay=none status=bounced for local mails
    By vdd in forum Administrators
    Replies: 1
    Last Post: 08-06-2009, 08:05 AM
  2. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  3. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 11:13 AM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •