Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: No incoming mail from outside

  1. #11
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    It would appear when you perform the dig that the MX is not being returned. Would you please post named.conf and the zonefile.

  2. #12
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default Public IP...

    How is the outside world resolving to your public IP so they can send mail to it?

  3. #13
    borngunners is offline Advanced Member
    Join Date
    Jun 2009
    Posts
    195
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    It would appear when you perform the dig that the MX is not being returned. Would you please post named.conf and the zonefile.
    ************************************************** **********************************
    named.conf
    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local

    include "/etc/bind/named.conf.options";

    // prime the server with knowledge of the root servers
    zone "." {
    type hint;
    file "/etc/bind/db.root";
    };

    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912

    zone "localhost" {
    type master;
    file "/etc/bind/db.local";
    };

    zone "127.in-addr.arpa" {
    type master;
    file "/etc/bind/db.127";
    };

    zone "0.in-addr.arpa" {
    type master;
    file "/etc/bind/db.0";
    };

    zone "255.in-addr.arpa" {
    type master;
    file "/etc/bind/db.255";
    };

    include "/etc/bind/named.conf.local";

    ************************************************** *********************
    named.conf.local
    //
    // Do any local configuration here
    //

    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";

    zone "test.zimbra.com" {
    type master;
    file "/etc/bind/db.test.zimbra.com";
    };

    ************************************************** *********************************************
    named.conf.options

    options {
    directory "/var/cache/bind";

    // If there is a firewall between you and nameservers you want
    // to talk to, you might need to uncomment the query-source
    // directive below. Previous versions of BIND always asked
    // questions using port 53, but BIND 8.1 and later use an unprivileged
    // port by default.

    query-source address * port 53;

    // If your ISP provided one or more IP addresses for stable
    // nameservers, you probably want to use them as forwarders.
    // Uncomment the following block, and insert the addresses replacing
    // the all-0's placeholder.

    forwarders {

    128.x.x.x; 128.x.xx.x; //stable nameserver ip addresses
    };

    auth-nxdomain no; # conform to RFC1035
    listen-on-v6 { any; };
    };
    ************************************************** ***************************************
    Zone file
    ;BIND data file for test.zimbra.com
    ;
    $TTL 604800
    @ IN SOA mail.test.zimbra.com. admin.mail.test.zimbra.com. (
    070725 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL
    ;
    IN NS 192.168.xxx.xx //private ip
    IN A 192.168.xxx.xx //private ip
    mail IN MX 10 mail.test.zimbra.com.


    Note* I am not using the exact identity of my mail server. I am just using mail.test.zimbra.com, but it is something else and listed exactly as how mail.test.zimbra.com looks.

    Thanks
    Last edited by borngunners; 07-27-2009 at 09:13 AM.

  4. #14
    borngunners is offline Advanced Member
    Join Date
    Jun 2009
    Posts
    195
    Rep Power
    6

    Default

    Quote Originally Posted by Bill Brock View Post
    How is the outside world resolving to your public IP so they can send mail to it?
    Bill.
    What do you mean? I suppose through my ISP Name servers.

  5. #15
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default I'm assuming...

    that your new zimbra machine is sitting behind a firewall that has been ported to forward mail traffic to it from the outside world. This firewall has a public IP. Somewhere there has to be a DNS server with an MX and A record pointing to the public IP if the outside world is going to send you mail.

  6. #16
    borngunners is offline Advanced Member
    Join Date
    Jun 2009
    Posts
    195
    Rep Power
    6

    Default

    Quote Originally Posted by Bill Brock View Post
    that your new zimbra machine is sitting behind a firewall that has been ported to forward mail traffic to it from the outside world. This firewall has a public IP. Somewhere there has to be a DNS server with an MX and A record pointing to the public IP if the outside world is going to send you mail.
    on the public end, I have a windows 2003 domain server that is configured with the MX record and A record of the zimbra server fqdn and public IP.

  7. #17
    Mistoffeles is offline Senior Member
    Join Date
    Oct 2007
    Posts
    70
    Rep Power
    7

    Default

    ok, in simple language rather than indirect language as you have been given so far:

    A public IP is on a public server, i.e.: not your server, the Linux one or the Windows 2003 domain controller.

    The zone records are on your Domain Registrar's name servers. Some allow you to configure them yourself, others make you contact them with your information and then do the configuration for you.

    Public emails from the internet will never reach your server without those public (i.e.: anyone in the universe can access them) DNS records. As it is, if your Windows 2003 DC is correctly configured, you should get emails from computers in the domain controlled by it, but you will not get any email sent from the internet to any user at test.zimbra.com, because zimbra.com belongs to Yahoo/Zimbra. You can't use anything ending with zimbra.com, it's not your domain, and I seriously doubt Yahoo is going to sell it to you.
    - Misty

  8. #18
    borngunners is offline Advanced Member
    Join Date
    Jun 2009
    Posts
    195
    Rep Power
    6

    Default

    To Mistoffeles.
    I am not using test.zimbra.com as my zimbra mail server. I was just using it to explain my problem instead of using the actual fqdn. Now I have a cisco ASA5505 firewall setup with a static nat route. This is where the public address is being resolved for the public to access my zimbra mail server using either the ip address or fqdn. When I went home, I was able to access my zimbra webmail fine and I even used it to send email to the outside world successfully. When the outside world send email to my zimbra mail, it does not go through and it does not bounce back. It just disappeared.

    I hope this explains the issue that I am having...

  9. #19
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    If you have external A & MX records pointing to your public IP (and valid internal DNS A & MX pointing to your LAN IP) then I'd suggest you check the settings on your Cisco device as this is likely to be a configuration problem with the firewall.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #20
    borngunners is offline Advanced Member
    Join Date
    Jun 2009
    Posts
    195
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    If you have external A & MX records pointing to your public IP (and valid internal DNS A & MX pointing to your LAN IP) then I'd suggest you check the settings on your Cisco device as this is likely to be a configuration problem with the firewall.
    That was what i thought, but I have all the necessary ports forwarded to the public ip. I went as far as just opening the server to all ip. I am still in doubt as to whether the firewall might be responsible for this or the zimbra configuration with the MTA, etc.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Replies: 30
    Last Post: 01-13-2009, 08:00 AM
  3. Migration Assistance
    By dwill in forum Administrators
    Replies: 10
    Last Post: 12-02-2008, 08:20 AM
  4. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  5. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •