Results 1 to 3 of 3

Thread: White list a domain whitch haven't a MX record

  1. #1
    janvanbruggen is offline Starter Member
    Join Date
    Jul 2008
    Location
    Holten, The Netherlands
    Posts
    2
    Rep Power
    7

    Default White list a domain whitch haven't a MX record

    Hi,

    I am working with Zimbra quite a while now and I am very pleased to use it.
    I have the following question and I hope that someone push me in to the right direction.
    I am running an older version 4.5.11 is the highest I can install on the machine right now, I am runnen Fedore Core 5.
    We see the following happening and I am not shure how to go on with this.
    After we had a lot of SPAM emails send directly to us I changed the settings with in Zimbra that the domains should be checked based on reverse DNS.
    After doing this the stream of SPAM email dropped down. But one problem came up. One of the customers sends emails within the form server1.example.com but all is coming from server mail.example.com this domain has no MX record eigther. I tried to setup an white list but this didn't help.
    Next step was trying to change the access file in /opt/zimbra/postfix/conf
    I put in this file all the domain names where the email could came from then I run post map on this file

    mail.example.coml OK
    server1.example.com OK
    server2.example.coml OK
    192.168.2.180 OK
    mailplesk.cybercenter.example.com OK

    I have tried to change the main.cf but this reset to the default after a restart with zmcontrol.

    Here is a snip of the log file changed the real addresses:

    Jul 17 08:16:43 mailsrv postfix/smtpd[2521]: connect from mail.example.com[192.168.2.180]
    Jul 17 08:16:43 mailsrv postfix/smtpd[2521]: setting up TLS connection from mail.example.com[192.168.2.180]
    Jul 17 08:16:43 mailsrv postfix/smtpd[2521]: TLS connection established from mail.example.com[192.168.2.180]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Jul 17 08:16:43 mailsrv postfix/smtpd[2521]: NOQUEUE: reject: RCPT from mail.example.com[192.168.2.180]: 450 : Sender address rejected: Domain not found; from= to= proto=ESMTP helo=
    Jul 17 08:16:43 mailsrv postfix/smtpd[2521]: disconnect from mail.example.com[192.168.2.180]

    Hope that someone can help me with this.

    With kind regards,

    Jan van Bruggen

  2. #2
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default After running into same issue...

    most mail admins have been happy to bring their mail servers into RFC compliancey. However, I have been known to setup a bogus zone file on my DNS server so the one or two servers that aren't correct will resolve and the mail will come through.

  3. #3
    janvanbruggen is offline Starter Member
    Join Date
    Jul 2008
    Location
    Holten, The Netherlands
    Posts
    2
    Rep Power
    7

    Default

    Hi Bill,

    Oke so what you say is add an entry in to the name server with the MX record from that domain. Oke I can try to set this up, we don't have a DNS server onsite so I have to set one active on this server.
    BTW is there a way to set the postfix commands in to the main.cf without resetting the lines added?

    Cheers,

    Jan van Bruggen

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Sudden problem synching with gmail
    By bouchardpie in forum Error Reports
    Replies: 8
    Last Post: 09-09-2010, 09:50 AM
  2. Replies: 7
    Last Post: 04-27-2009, 02:49 AM
  3. Problem syncing all folders
    By mark_the_chain in forum Error Reports
    Replies: 0
    Last Post: 11-23-2008, 04:59 PM
  4. Replies: 20
    Last Post: 03-18-2008, 05:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •