Results 1 to 6 of 6

Thread: [SOLVED] search error 5.0.18

  1. #1
    Centro is offline Senior Member
    Join Date
    May 2009
    Location
    Schrobenhausen - Germany
    Posts
    54
    Rep Power
    6

    Default [SOLVED] search error 5.0.18

    Hi,

    im not sure to write in the right forum, please gentel.

    We, a group of studys, use at our server Zimbra 5.0.18 Community Edition.
    I installed it, and it runs very well. Now, we changed the Server and i take all data and restore it at the new system. I used rsync to do this.

    All is okey, i changed the IP for the mta in the adminpanel and all was ok.

    I have 2000 mails in my box and i would search for a keyword like a name or some else. I did it often in the past, it works good. Now i tried it and its not working.
    normaly there is a list of mails where the searchobject is in. Now, there is only a clear window without any mails.

    I tried to search with a * and the end, then i got a error message.
    I dont see the reason at this message.

    Can somebody tell me what i can do ?
    I make a reboot, i stop/start the services manual... nothing !

    Thx for a answere

    Greetz Centro

  2. #2
    Rich Graves is offline Outstanding Member
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    718
    Rep Power
    9

    Default

    zmprov reindexmailbox centro@domain

    Wait approximately 30 minutes and search again.

    If that doesn't work, provide more details on the move. Are the old and new servers running different operating systems?

  3. #3
    Centro is offline Senior Member
    Join Date
    May 2009
    Location
    Schrobenhausen - Germany
    Posts
    54
    Rep Power
    6

    Default

    Hi,

    thanks for fast reply.

    I wrote your command into the shell as user zimbra but there are a wrong syntax i think ?!

    The exact error at Zimbra Web:
    Code:
    method:	SearchRequest
    msg:	system failure: Caught IOException opening index
    code:	service.FAILURE
    detail:	soap:Receiver
    trace:	btpool0-12:1247755882092:894a95c434ee3c5d
    request:	
    
    Body: {
      SearchRequest: {
        _jsns: "urn:zimbraMail",
        fetch: 1,
        html: 1,
        limit: 100,
        locale: {
          _content: "de"
         },
        offset: 0,
        query: "Felix*",
        sortBy: "dateDesc",
        types: "message",
        tz: {
          id: "(GMT+01.00) Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna"
         }
       }
     },
    Header: {
      context: {
        _jsns: "urn:zimbra",
        account: {
          _content: "ottomitschke@mitschke.cc",
          by: "name"
         },
        authToken: "(removed)",
        format: {
          type: "js"
         },
        notify: {
          seq: 8
         },
        sessionId: {
          _content: 118,
          id: 118
         },
        userAgent: {
          name: "ZimbraWebClient - FF3.0 (Win)",
          version: "5.0.13_GA_2791.DEBIAN4.0"
         }
       }
     }
    The old as the new System is running on Debian ETCH 32 bit.

    The Output with your command:
    Code:
    zimbra@xchange:/root$ zmprov reIndexMailbox centro@domain
    usage:  reIndexMailbox(rim) {name@domain|id} {action} [{reindex-by} {value1} [value2...]]
    
    zmprov [args] [cmd] [cmd-args ...]
    
      -h/--help                             display usage
      -f/--file                             use file as input stream
      -s/--server   {host}[:{port}]         server hostname and optional port
      -l/--ldap                             provision via LDAP instead of SOAP
      -L/--logpropertyfile                  log4j property file, valid only with -l
      -a/--account  {name}                  account name to auth as
      -p/--password {pass}                  password for account
      -P/--passfile {file}                  read password from file
      -z/--zadmin                           use zimbra admin name/password from localconfig for admin/password
      -y/--authtoken {authtoken}            use auth token string(has to be in JSON format) from command line
      -Y/--authtokenfile {authtoken file}   use auth token string(has to be in JSON format) from command line
      -v/--verbose                          verbose mode (dumps full exception stack trace)
      -d/--debug                            debug mode (dumps SOAP messages)
    
     zmprov is used for provisioning. Try:
    
         zmprov help account         help on account-related commands
         zmprov help calendar        help on calendar resource-related commands
         zmprov help commands        help on all commands
         zmprov help config          help on config-related commands
         zmprov help cos             help on COS-related commands
         zmprov help domain          help on domain-related commands
         zmprov help list            help on distribution list-related commands
         zmprov help misc            help on misc commands
         zmprov help mailbox         help on mailbox-related commands
         zmprov help notebook        help on notebook-related commands
         zmprov help search          help on search-related commands
         zmprov help server          help on server-related commands
         zmprov help freebusy        help on free/busy-related commands
    
    zimbra@xchange:/root$
    I wrote "centro@domain" for example, sure i wrote the real address at the command

    Greetz Centro

  4. #4
    Rich Graves is offline Outstanding Member
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    718
    Rep Power
    9

    Default

    Correction:
    zmprov rim centro@domain start
    Reindex Mailbox from Command Line?

    Though the error you received suggests that it could be a permissions problem. Are /opt/zimbra/index and all of its subdirectories owned by user zimbra?

  5. #5
    Centro is offline Senior Member
    Join Date
    May 2009
    Location
    Schrobenhausen - Germany
    Posts
    54
    Rep Power
    6

    Default

    Thx a lot!

    with the small word "start" it will work!

    Greetz Centro

  6. #6
    Centro is offline Senior Member
    Join Date
    May 2009
    Location
    Schrobenhausen - Germany
    Posts
    54
    Rep Power
    6

    Default

    OK, i wait now near to 20 minutes and YES! it works!

    Thanks a lot!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why is Zimbra so buggy?
    By edwin.arneson in forum Users
    Replies: 50
    Last Post: 11-14-2011, 09:38 AM
  2. Searching in the trash
    By p24t in forum Administrators
    Replies: 4
    Last Post: 07-02-2009, 11:09 AM
  3. search vs. searchConv
    By DarthJader in forum Developers
    Replies: 0
    Last Post: 05-30-2008, 02:26 PM
  4. Can not access admin console after 5.0.2 upgrade
    By wolrah in forum Administrators
    Replies: 22
    Last Post: 02-28-2008, 09:34 PM
  5. Search within search
    By zocs in forum Users
    Replies: 0
    Last Post: 12-24-2007, 02:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •