Results 1 to 3 of 3

Thread: [SOLVED] OpenSUSE MTA SSL bug in 5.0.18

  1. #1
    mik179 is offline Starter Member
    Join Date
    Jul 2007
    Posts
    2
    Rep Power
    8

    Default [SOLVED] OpenSUSE MTA SSL bug in 5.0.18

    I just upgraded my 5.0.16 to 5.0.18 on OpenSuSE 10.2.
    Everything worked fine except I was not able to utilize MTA to send e-mails with SSL authentication.
    After spending 3 hours I found that /opt/zimbra/postfix/libexec/master was linked against /opt/zimbra/cyrus-sasl-2.1.22.3z/lib/libsasl2.so.2 which is inorrect. Should be /opt/zimbra/cyrus-sasl-2.1.23.3z/lib/libsasl2.so.2.
    The way to solve the problem which indicate itself as "warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied" in /var/log/messages was to delete old cyrus-sasl-2.1.22.3z directory and to create link cyrus-sasl-2.1.22.3z => cyrus-sasl-2.1.23.3z

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Please file a report in bugzilla, search first to see if it's already been reported.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Bug 39292 – postfix master linked incorrectly against older libsasl > Bug 21782 – MTA not running, dyld failure (From the dupe would assume a new openSUSE build is forthcoming so everyone doesn't have to do this workaround.)

    Update: New build available openSUSE_10.2.20090709094925.tgz
    Last edited by mmorse; 07-09-2009 at 12:27 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. [SOLVED] Multiserver Install & Commercial SSL
    By Meaulnes in forum Installation
    Replies: 1
    Last Post: 05-07-2009, 01:33 PM
  3. 5.0.6 is out!
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 05-23-2008, 01:16 PM
  4. Replies: 0
    Last Post: 01-15-2008, 01:33 PM
  5. Replies: 1
    Last Post: 01-02-2008, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •