Results 1 to 8 of 8

Thread: Accepting mail for @foo.com not only @mail.foo.com

  1. #1
    gdev is offline New Member
    Join Date
    Jul 2009
    Posts
    3
    Rep Power
    6

    Default Accepting mail for @foo.com not only @mail.foo.com

    Sorry if I'm posing an already-asked question. I couldn't find a relevant post in the forums.

    We created our standalone Zimbra server as mail.foo.com, so all accounts created under it default to account@mail.foo.com. However, of course we want the accounts to be account@foo.com. The MX is set up to route all mail to this server's IP address. Tried creating a virtual server in Zimbra, but no luck. When we try to save an account @foo.com Zimbra returns "The specified domain does not exist".

    FWIW, the contents of /etc/hosts:
    -----------------------------------------
    127.0.0.1 localhost.localdomain localhost
    www.xxx.yyy.zzz mail.foo.com mail
    www.xxx.yyy.zzz foo.com
    -----------------------------------------
    (Where www.xxx.yyy.zzz is the masked IP of the server.)

    I imagine it's something silly, and will greatly appreciate any and all advice.
    Last edited by gdev; 07-02-2009 at 08:36 AM. Reason: Added hosts file

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    You could just rename the domain, I'm assuming you don't want two domains or a domain called mail.foo.com? Have a look at the format of the command on this page: Zmprov - Zimbra :: Wiki
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    rustyc is offline Junior Member
    Join Date
    Jun 2009
    Location
    Vancouver
    Posts
    7
    Rep Power
    6

    Default

    You just need to add the domain on the admin console, Configurations -> Domains -> New. In the install process there's a setting for the domain to be created, the default is the hostname of the machine.

  4. #4
    Dirk's Avatar
    Dirk is offline Moderator
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    In the zimbra admin console, add a new domain called foo.com
    You can set this to be the default domain, so a user can login with username, rather than username@foo.com

  5. #5
    gdev is offline New Member
    Join Date
    Jul 2009
    Posts
    3
    Rep Power
    6

    Default Thanks!

    I _knew_ we were missing something obvious! Many thanks to all of the respondents.

  6. #6
    adeelarifbhatti is offline Advanced Member
    Join Date
    Feb 2009
    Posts
    188
    Rep Power
    6

    Lightbulb

    First thing first, while configuring the zimbra it will take the hostname.domain as domain name i.e. hostname was mail.foo.com and domainname should be foo.com but zimbra default configuration was to be configure with the mail.foo.com.
    Second why the entry www.xxx.yyy.zzz foo.com is required in the /etc/hosts.
    Entry should be some thing like "www.xxx.yyy.zzz mail.foo.com mail "

    Various options to make things work for you.
    Create domain foo.com as told by other guys and make the MX for foo.com, create all the account you require under foo.com. Data can be migrated from old account to the new one.

    Another option can be to rerun the configuration script, don't really know the exact location.
    How come to can have the error when you did """Tried creating a virtual server in Zimbra, but no luck. When we try to save an account @foo.com Zimbra returns "The specified domain does not exist""".
    Did you mean to host the domain foo.com when you tried virtual host?

    Regards
    Adeel

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Quote Originally Posted by gdev View Post
    FWIW, the contents of /etc/hosts:
    127.0.0.1 localhost.localdomain localhost
    www.xxx.yyy.zzz mail.foo.com mail
    [url]www.xxx.yyy.zzz foo.com
    That's incorrect, your hosts file should only contain the following:
    Code:
    127.0.0.1 localhost.localdomain localhost
    x.x.x.x mail.foo.com mail
    where x.x.x.x is the IP address of your Zimbra server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    adeelarifbhatti is offline Advanced Member
    Join Date
    Feb 2009
    Posts
    188
    Rep Power
    6

    Thumbs up

    Reconfiguration script = /opt/zimbra/libexec/zmsetup.pl

    Regards
    Adeel

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Replies: 30
    Last Post: 01-13-2009, 08:00 AM
  3. Migration Assistance
    By dwill in forum Administrators
    Replies: 10
    Last Post: 12-02-2008, 08:20 AM
  4. Problem with Postfix and MTA
    By ZMilton in forum Administrators
    Replies: 16
    Last Post: 04-16-2008, 06:47 AM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •