Results 1 to 4 of 4

Thread: [SOLVED] Zimbra & Funambol Trouble

  1. #1
    profondorosso is offline Junior Member
    Join Date
    Jun 2009
    Location
    Italy
    Posts
    7
    Rep Power
    6

    Default [SOLVED] Zimbra & Funambol Trouble

    hi,
    I have installed a Zimbra 5.0.14 FOSS on UBUNTU 8.04 LTS and .... it' amazing !!
    Now I try to install on the same server Funambol 7.1 with connector ZimbraConnector_0.5.02.s4j.

    But ... doesn't work.

    the log file of Funambol Outlook plug-in says:
    ...................
    SYNCHRONIZATION COMPLETED WITH ERRORS
    -------------------------------------
    Last error message = ""
    Last error code = 401

    Tasks:
    ------
    Sync failed: Access denied, check userName and Password (code = 401)
    ......................

    the userName and Password i correct and the URL is correct too.


    On the ds-server.log on /opt/Funambol/log/ds_server:
    .....................

    [2009-06-28 21:42:00,995] [funambol.transport.http] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [] [] [] Handling incoming request
    [2009-06-28 21:42:00,996] [funambol.transport.http] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [] [] [] Request URL: http://pippo.net:8080/funambol/ds
    [2009-06-28 21:42:00,996] [funambol.transport.http] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [] [] [] Requested sessionId: null
    [2009-06-28 21:42:01,564] [funambol.handler] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [] roby/fol-TkItUk1BU0lOSTpybWFzaW5p logged i
    n.
    [2009-06-28 21:42:01,642] [funambol.zimbra] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [] LOAD ZimbraConnector 0.5.02
    [2009-06-28 21:42:01,703] [funambol.transport.http] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [] Request processed.
    [2009-06-28 21:42:18,082] [funambol.transport.http] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [] Handling incoming request
    [2009-06-28 21:42:18,083] [funambol.transport.http] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [] Request URL: www.pippo.net
    8080/funambol/ds
    [2009-06-28 21:42:18,083] [funambol.transport.http] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [] Requested sessionId: CDDF0151EFE8DF
    EFACFBD3489D96EC4E
    [2009-06-28 21:42:18,194] [funambol.engine] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [] Starting synchronization ...
    [2009-06-28 21:42:18,524] [funambol.zimbra] [ERROR] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [stask] I/O Error
    java.io.FileNotFoundException: http://pippo.net:8080/service/soap/
    at sun.net.http://www.protocol.http.HttpURLConn...Stream(Unknown Source)
    at ru.korusconsulting.connector.base.ZimbraPort.sendR equest(ZimbraPort.java:622)
    at ru.korusconsulting.connector.base.ZimbraPort.reque stAutorization(ZimbraPort.java:140)
    at ru.korusconsulting.connector.funambol.ZimbraSyncSo urce.commonSync(ZimbraSyncSource.java:121)
    at ru.korusconsulting.connector.funambol.CalendarSync Source.commonSync(CalendarSyncSource.java:63)
    at ru.korusconsulting.connector.funambol.ZimbraSyncSo urce.beginSync(ZimbraSyncSource.java:102)
    at ru.korusconsulting.connector.funambol.CalendarSync Source.beginSync(CalendarSyncSource.java:45)
    at com.funambol.server.engine.Sync4jEngine.sync(Sync4 jEngine.java:602)
    at com.funambol.server.session.SyncSessionHandler.pro cessModifications(SyncSessionHandler.java:1674)
    at com.funambol.server.session.SyncSessionHandler.pro cessSyncMessage(SyncSessionHandler.java:1527)
    at com.funambol.server.session.SyncSessionHandler.pro cessInitSyncMapMessage(SyncSessionHandler.java:984 )
    at com.funambol.server.session.SyncSessionHandler.pro cessMessage(SyncSessionHandler.java:517)
    at com.funambol.server.engine.SyncAdapter.processInpu tMessage(SyncAdapter.java:533)
    at com.funambol.server.engine.SyncAdapter.processXMLM essage(SyncAdapter.java:254)
    at com.funambol.transport.http.server.LocalSyncHolder .processXMLMessage(LocalSyncHolder.java:97)
    at com.funambol.transport.http.server.Sync4jServlet.d oPost(Sync4jServlet.java:399)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:710)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:803)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:290)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:206)
    at com.funambol.transport.http.server.LogContextFilte r.doFilter(LogContextFilter.java:115)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:235)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:206)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:233)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:175)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:128)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:102)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:109)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:286)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:844)
    at org.apache.coyote.http11.Http11Protocol$Http11Conn ectionHandler.process(Http11Protocol.java:583)
    at org.apache.tomcat.util.net.JIoEndpoint$Worker.run( JIoEndpoint.java:447)
    at java.lang.Thread.run(Unknown Source)
    [2009-06-28 21:42:18,539] [funambol.engine.source] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [stask] stask: 0 new items added, 0 exi
    sting items updated, 0 items deleted.
    [2009-06-28 21:42:18,539] [funambol.engine] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [] fol-TkItUk1BU0lOSTpybWFzaW5p/roby: synchron
    ization completed
    [2009-06-28 21:42:18,546] [funambol.transport.http] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [] Request processed.
    [2009-06-28 21:42:18,546] [funambol.transport.http] [INFO] [CDDF0151EFE8DFEFACFBD3489D96EC4E] [fol-TkItUk1BU0lOSTpybWFzaW5p] [roby] [] Closing session CDDF0151EFE8DFEFACF
    BD3489D96EC4E
    .........................
    someone has a suggestion?
    --------------------------------------------------------------------------
    Release 6.0.1_GA_1816.UBUNTU8 UBUNTU8 FOSS edition

  2. #2
    nprodromou is offline Starter Member
    Join Date
    Nov 2008
    Posts
    1
    Rep Power
    6

    Default

    This thread appears as solved, but has no solution. I'm having the exact same problem. Profondorosso, any chance you could post your solution?

    Thanks

  3. #3
    profondorosso is offline Junior Member
    Join Date
    Jun 2009
    Location
    Italy
    Posts
    7
    Rep Power
    6

    Default

    in my installation was a wrong setting of ZimbraConnector in funambol server

    I use an https zimbra zerver and the URL of "cal", "scal", "task", "stask", ecc. must be "https://[hostname]/service/soap/" in place of "http://[hostname]:8080/service/soap/"

    then I have copied the "certs" from zimbra to funambol

    sudo cp [zimbra]/java/jre/lib/security/cacerts [funambol]/ds-server/lib/security

    that is ... in my installation

    I hope this can halp you

    :-)

    Bye
    R
    Last edited by profondorosso; 10-02-2009 at 01:22 AM.
    --------------------------------------------------------------------------
    Release 6.0.1_GA_1816.UBUNTU8 UBUNTU8 FOSS edition

  4. #4
    pbarreira is offline Starter Member
    Join Date
    Jun 2010
    Posts
    1
    Rep Power
    5

    Default

    Does your server knows www.pippo.net if not you have to put it with the right ip into the dns server, or else in the hosts file of the Funambol server.

    I add the same problem and that was the problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  3. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 03:23 PM
  4. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 02:00 AM
  5. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •