Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Zimbra won't work after a reboot

  1. #11
    Remidoubi is offline Intermediate Member
    Join Date
    May 2009
    Posts
    15
    Rep Power
    6

    Default

    and it still can't work :s:s.

    Code:
    zmcontrol stop
    Host machinevirt0.mydomain.ma
    	Stopping stats...Done
    	Stopping mta...Done
    	Stopping spell...Done
    	Stopping snmp...Done
    	Stopping archiving...Done
    	Stopping antivirus...Done
    	Stopping antispam...Done
    	Stopping imapproxy...Done
    	Stopping mailbox...Done
    	Stopping logger...Done
    	Stopping ldap...Done
    [zimbra@machinevirt0 root]$ zmcontrol start
    Host machinevirt0.mydomain.ma
    	Starting ldap...Done.
    	Starting logger...Done.
    	Starting mailbox...Done.
    	Starting antispam...Done.
    	Starting antivirus...Done.
    	Starting snmp...Done.
    	Starting spell...Done.
    	Starting mta...Done.
    	Starting stats...Done.
    [zimbra@machinevirt0 root]$ zmcontrol status
    Host machinevirt0.mydomain.ma
    	antispam                Running
    	antivirus               Running
    	ldap                    Running
    	logger                  Running
    	mailbox                 Stopped
    		zmmailboxdctl is not running.
    	mta                     Running
    	snmp                    Running
    	spell                   Running
    	stats                   Running

  2. #12
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Please post all the requested information again including any errors in /opt/zimbra/log/* and /var/log/zimbra.log.

  3. #13
    Remidoubi is offline Intermediate Member
    Join Date
    May 2009
    Posts
    15
    Rep Power
    6

    Default

    /

    Code:
    stale pid 9355 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
    May 12 15:33:07 machinevirt0 zmmailboxdmgr[23627]: assuming no other instance is running
    May 12 15:33:07 machinevirt0 zmmailboxdmgr[23627]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    May 12 15:33:07 machinevirt0 zmmailboxdmgr[23627]: assuming no other instance is running
    May 12 15:33:07 machinevirt0 zmmailboxdmgr[23627]: no manager process is running
    May 12 15:34:02 machinevirt0 zmmailboxdmgr[23874]: status requested
    May 12 15:34:02 machinevirt0 zmmailboxdmgr[23874]: stale pid 9355 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
    May 12 15:34:02 machinevirt0 zmmailboxdmgr[23874]: assuming no other instance is running
    May 12 15:34:02 machinevirt0 zmmailboxdmgr[23874]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    May 12 15:34:02 machinevirt0 zmmailboxdmgr[23874]: assuming no other instance is running
    May 12 15:34:02 machinevirt0 zmmailboxdmgr[23874]: no manager process is running
    May 12 15:34:03 machinevirt0 zimbramon[23686]: 23686:info: 2009-05-12 15:34:01, STATUS: machinevirt0.mydomain.ma: antispam: Running 
    May 12 15:34:03 machinevirt0 zimbramon[23686]: 23686:info: 2009-05-12 15:34:01, STATUS: machinevirt0.mydomain.ma: antivirus: Running 
    May 12 15:34:03 machinevirt0 zimbramon[23686]: 23686:info: 2009-05-12 15:34:01, STATUS: machinevirt0.mydomain.ma: ldap: Running 
    May 12 15:34:03 machinevirt0 zimbramon[23686]: 23686:info: 2009-05-12 15:34:01, STATUS: machinevirt0.mydomain.ma: logger: Running 
    May 12 15:34:03 machinevirt0 zimbramon[23686]: 23686:info: 2009-05-12 15:34:01, STATUS: machinevirt0.mydomain.ma: mailbox: Stopped 
    May 12 15:34:03 machinevirt0 zimbramon[23686]: 23686:info: 2009-05-12 15:34:01, STATUS: machinevirt0.mydomain.ma: mta: Running 
    May 12 15:34:03 machinevirt0 zimbramon[23686]: 23686:info: 2009-05-12 15:34:01, STATUS: machinevirt0.mydomain.ma: snmp: Running 
    May 12 15:34:03 machinevirt0 zimbramon[23686]: 23686:info: 2009-05-12 15:34:01, STATUS: machinevirt0.mydomain.ma: spell: Running 
    May 12 15:34:03 machinevirt0 zimbramon[23686]: 23686:info: 2009-05-12 15:34:01, STATUS: machinevirt0.mydomain.ma: stats: Running
    Code:
    $ ls /opt/zimbra/log
    amavisd.pid           freshclam.pid           logswatch.pid           stacktrace.21667  wbxml.log               zmmailboxd.out
    audit.log             httpd_access.log        mailbox.log             startup.log       xmppAudit               zmmtaconfig.log
    audit.log.2009-05-11  httpd_error.log         mailbox.log.2009-05-11  swatch.pid        zmloggerinit.log        zmmtaconfig.pid
    clamd.log             httpd.pid               myslow.log              sync.log          zmlogswatch.out         zmmyinit.log
    clamd.pid             logger_myslow.log       mysql_error.log         syncstate.log     zmmailboxd_java.pid     zmsetup.05112009-154352.log
    freshclam.log         logger_mysql_error.log  spamtrain.log           synctrace.log     zmmailboxd_manager.pid  zmswatch.out
    file /opt/zimbra/log/zmmailboxd.pid does not exist !!!, do i have to create one

  4. #14
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    No. Please post the following again now you have made the hosts change
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes

  5. #15
    Remidoubi is offline Intermediate Member
    Join Date
    May 2009
    Posts
    15
    Rep Power
    6

    Default

    cat /etc/hosts
    Code:
    $ cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1		localhost.localdomain localhost
    172.16.1.127		machinevirt0.mydomain.ma
    cat /etc/resolv.conf
    Code:
    cat /etc/resolv.conf
    ; generated by /sbin/dhclient-script
    search mydomain.ma
    nameserver 172.16.1.125
    dig yourdomain mx
    Code:
    dig mydomain.ma
    
    ; <<>> DiG 9.3.4-P1 <<>> mydomain.ma
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32333
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mydomain.ma.			IN	A
    
    ;; AUTHORITY SECTION:
    mydomain.ma.		3600	IN	SOA	localhost. root.localhost. 2 10800 3600 604800 3600
    
    ;; Query time: 14 msec
    ;; SERVER: 172.16.1.125#53(172.16.1.125)
    ;; WHEN: Tue May 12 15:54:04 2009
    ;; MSG SIZE  rcvd: 77
    dig yourdomain any
    Code:
    $ dig mydomain.ma any
    
    ; <<>> DiG 9.3.4-P1 <<>> mydomain.ma any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19368
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;mydomain.ma.			IN	ANY
    
    ;; ANSWER SECTION:
    mydomain.ma.		43200	IN	SOA	localhost. root.localhost. 2 10800 3600 604800 3600
    mydomain.ma.		3600	IN	NS	localhost.
    
    ;; ADDITIONAL SECTION:
    localhost.		86400	IN	A	127.0.0.1
    localhost.		86400	IN	AAAA	::1
    
    ;; Query time: 1 msec
    ;; SERVER: 172.16.1.125#53(172.16.1.125)
    ;; WHEN: Tue May 12 15:54:44 2009
    ;; MSG SIZE  rcvd: 135
    host `hostname`
    Code:
    $ host `hostname`
    machinevirt0.mydomain.ma has address 172.16.1.127
    thanks a lot.

    Karim

  6. #16
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    you need to define a MX record for your domain pointing to your ZCS server.

  7. #17
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    You also need an A record that points your Zimbra server LAN IP not to 'localhsot 127.0.0.1'. Your hosts file also needs fixing, this

    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1		localhost.localdomain localhost
    172.16.1.127		machinevirt0.mydomain.ma
    should look like this:
    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1		localhost.localdomain localhost
    172.16.1.127		machinevirt0.mydomain.ma machinevirt0
    How much RAM is allocated to this VM and which version of VMware are you using?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #18
    Remidoubi is offline Intermediate Member
    Join Date
    May 2009
    Posts
    15
    Rep Power
    6

    Default

    Hi phoenix ,sorry for responding too late.
    i'm not using VMware, i'm using Xen and zimbra is running in a VM with 1GO, i can allocate more if necessary.

    i don't think that zimbra would have a problem while running on a DomU, because i did get access a to the admin pages the first time.

    i'm going to fix /etc/hosts and let u know.

    Thanks

  9. #19
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    The RAM you have is a minimum for test, for production use I'd recommend at least 1.5GB and you'll find Zimbra will run smoother with that amount.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #20
    neilmc is offline Active Member
    Join Date
    Nov 2005
    Posts
    44
    Rep Power
    9

    Default

    I had a real Doh! moment with the LDAP error on our production server tonight. I was checking DNS and the hosts file then got to /var/log/zimbra.log and found

    Code:
    May 17 20:12:03 mail exim[4160]: write failed on panic log: length=122 result=-1 errno=28 (No space left on device)
    sure enough:

    Code:
    df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sda2              93G   90G     0 100% /
    /dev/sda1              99M   16M   79M  17% /boot
    tmpfs                1014M     0 1014M   0% /dev/shm
    Can't expect miracles with no drive space left..........

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 01-20-2009, 01:06 PM
  2. Upgrade to ZCS 5.10
    By blozancic in forum Installation
    Replies: 0
    Last Post: 10-21-2008, 08:03 AM
  3. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  4. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •