Results 1 to 4 of 4

Thread: [SOLVED] Installing on OS X 10.4 Server - missing libutil library

  1. #1
    jvargas92 is offline Intermediate Member
    Join Date
    Jan 2007
    Location
    New York
    Posts
    18
    Rep Power
    8

    Default [SOLVED] Installing on OS X 10.4 Server - missing libutil library

    Has anyone run across this problem? We are upgrading from 5.0.15 to 5.0.16 on our OS X 10.4.11 server and the zmsetup.pl script is unable to start LDAP because it says that it cannot find the libutil. Anyone have any experience / suggestions on this?

    Much obliged...
    Jeffrey Vargas
    Technology Director
    Time Out New York
    http://www.timeout.com/newyork/
    http://www.timeout.com/newyork/kids/
    http://www.timeout.com/chicago/



    ZCS NE 5.0.15 | Mac OS X Server (10.4.11) | 2x2.66GHz Intel Xeon/8GB RAM

  2. #2
    ewilen's Avatar
    ewilen is offline Moderator
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    I was able to find this suggestive snippet through some creative googling:

    in Max OS X 10.4 and earlier, there is no symbolic link for libutil, whose functionality is also provided by libSystem
    Also see The System Library: libSystem (Mac OS X for Unix Geeks)
    Interestingly enough, there is no symbolic link for libutil, whose functionality is also provided by libSystem. (libutil is a library that provides functions related to login, logout, terminal assignment, and logging.) So, if a link fails because of -lutil, you should try taking it out to see if it solves the problem.
    A slightly different version of the same text: O'Reilly - Safari Books Online - 9780596520625 - Mac OS X For Unix Geeks, 4th Edition

    I hope you can solve your problem. Please post if you find a solution.
    Last edited by ewilen; 05-03-2009 at 02:31 PM.

  3. #3
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,265
    Rep Power
    10

    Default

    Can you please be more specific with the error reported? I don't see that library listed in the OSX 10.4 otool -L output:

    Code:
    build24:/opt/zimbra/openldap-2.3.43.8z/libexec build$ otool -L slapd
    slapd:
            /opt/zimbra/openldap-2.3.43.8z/lib/libldap_r-2.3.0.dylib (compatibility version 3.0.0, current version 3.31.0)
            /opt/zimbra/openldap-2.3.43.8z/lib/liblber-2.3.0.dylib (compatibility version 3.0.0, current version 3.31.0)
            /opt/zimbra/sleepycat-4.2.52.6/lib/libdb-4.2.dylib (compatibility version 0.0.0, current version 0.0.0)
            /System/Library/Perl/lib/5.8/libperl.dylib (compatibility version 5.8.0, current version 5.8.6)
            /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 88.3.10)
            /opt/zimbra/cyrus-sasl-2.1.22.3z/lib/libsasl2.2.dylib (compatibility version 3.0.0, current version 3.22.0)
            /usr/lib/libpam.1.dylib (compatibility version 1.0.0, current version 1.0.0)
            /opt/zimbra/openssl-0.9.8k/lib/libssl.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)
            /opt/zimbra/openssl-0.9.8k/lib/libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8)
            /usr/lib/libresolv.9.dylib (compatibility version 1.0.0, current version 369.8.0)
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  4. #4
    nufan is offline Senior Member
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    curious if this is a wide spread problem or not. I am running 5.0.15 on a 10.4 server here myself, was going to be upgrading to 5.0.16 sometime, but might hold off if this is a known problem. Were you able to find a workaround?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Replies: 8
    Last Post: 08-07-2008, 05:18 AM
  3. Installation Problem - Possibly LDAP
    By geroshea in forum Installation
    Replies: 5
    Last Post: 03-16-2007, 04:47 AM
  4. Replies: 18
    Last Post: 03-20-2006, 02:22 PM
  5. OS X Server 10.4 + Zimbra sans LDAP/MySQL
    By abetam in forum Zimbra in Education
    Replies: 1
    Last Post: 02-16-2006, 09:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •