Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 36

Thread: Upgrade to Zimbra 6 Beta from 5.xx issues

  1. #21
    linxunet is offline Intermediate Member
    Join Date
    Apr 2009
    Location
    Newport, South Wales, UK
    Posts
    23
    Rep Power
    6

    Default

    The only way around this for me, was to export all our users data (some 6Gb) via the Zimbra Desltop or via the Zimbra Web Interface, completely remove all evidence of any previous Zimbra installation, Install Zimbra 6GA and then import all the users data again via either the Zimbra Desktop or Zimbra Web Interfase.

    BEFORE you do any of the above, please ensure that you have a complete backup of your Zimbra Installation.

    The above was the ONLY solution that worked for us.

    Kind regards

    Kerry

  2. #22
    linxunet is offline Intermediate Member
    Join Date
    Apr 2009
    Location
    Newport, South Wales, UK
    Posts
    23
    Rep Power
    6

    Default

    There is a log file in the /tmp directory that the installation looks to, it uses this file to keep track of what current version has been installed and refuses the application to continue to install older versions over newer ones.

    I hade to delete all the zimbra files in the /tmp directory before I could reinstall my 5.18GA version over the freashly installed 6GA version.

    As I had already created a complete 5.18GA backup, I was able to delete all files and directories relating to all my failling 6GA zimbra installation, restored by old 5.18GA copy, then ran the 5.18GA version ./install.sh script and performed an upgrade to 5.18GA which fix's any possible file anomolies.

    Once this was working again, I then exported all the users data via the Zimbra Desktop and Zimbra Web Interface, deleted all the Zimbra 5.18GA files and folders (including the ones in the /tmp folder), Installed Zimbra 6GA and imported all the users data again via the Zimbra Desktop and Zimbra Web Interface. PLEASE ENSURE THAT YOU RECREATED ALL THE USERS ACCOUNTS FIRST VIA THE ZIMBRA ADMIN INTERFACE.

    We are now up and running, not something that I would want to do again.

    It has left me wondering why the Global Disclaimer become so destructive to future Zimbra updates and what other possible thirdparty modifications would also prevent such future updates from taking place.

    I would like to suggest to the Zimbra team that they take on board this issue and have another look at incorporating a global Disclaimer into Zimbra.

    Kind regards

    Kerry

  3. #23
    alvaroarb's Avatar
    alvaroarb is offline Partner (VAR/HSP)
    Join Date
    Sep 2009
    Location
    Bogota - Colombia
    Posts
    8
    Rep Power
    5

    Default

    Hi, and thanks for the answer, well i got it half-done now, i copied the /opt/zimbra directory and managed to reinstall 5.0.18, did not start correctly with the original myswql database but ldap was fien, so i decided to give a shot to version 6, ran the update process, and while it was installing packages modified the /opt/zimbra/data/ldap/ldap.bak file to remove the Signature entries (a few lines luckily) and install went out without issues apparently, finished, started servers, zmprov -l gaa had all accounts correctly, mysql database is runing just fine ... but now i have no web access or admin web access, nor pop or imap ports listening (mailboxdctl is not running) ... appreciate your advise, but loosing mails, calendar and contacts data is not an option for me.
    Zimbra.log shows this
    Sep 12 22:37:48 zimbra zmmailboxdmgr[24523]: status requested
    Sep 12 22:37:48 zimbra zmmailboxdmgr[24523]: stale pid 19095 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
    Sep 12 22:37:48 zimbra zmmailboxdmgr[24523]: assuming no other instance is running
    Sep 12 22:37:48 zimbra zmmailboxdmgr[24523]: did not find a number in /opt/zimbra/log/zmmailboxd.pid
    Sep 12 22:37:48 zimbra zmmailboxdmgr[24523]: assuming no other instance is running
    Sep 12 22:37:48 zimbra zmmailboxdmgr[24523]: no manager process is running

    and /opt/zimbra/log/zmmailboxd.out doesn't seem to point clearly to an error, so i'm kinda stuck here

  4. #24
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    You need to check in /opt/zimbra/log/mailbox.log.

  5. #25
    alvaroarb's Avatar
    alvaroarb is offline Partner (VAR/HSP)
    Join Date
    Sep 2009
    Location
    Bogota - Colombia
    Posts
    8
    Rep Power
    5

    Default

    OK, the problem seems to have something to do with ssl certificates ... wondering if this procedure Recreating a Self-Signed SSL Certificate - Zimbra :: Wiki will work on 6

  6. #26
    alvaroarb's Avatar
    alvaroarb is offline Partner (VAR/HSP)
    Join Date
    Sep 2009
    Location
    Bogota - Colombia
    Posts
    8
    Rep Power
    5

    Default


    Solved !!! it was the certificates, the procedure described in the link i posted before worked, just one minor issue with this so everybody knows, ldap has to be working, it's not stated in the procedure.

    I'm happy again ...
    Thnx guys

  7. #27
    markelwaine is offline New Member
    Join Date
    Jul 2009
    Location
    Cavite, Philippines
    Posts
    4
    Rep Power
    6

    Unhappy Problem after upgrade form 5.18 to 6.0

    JavaScript error encountered in method ZaAccountMemberOfListView.modifyMemberList: add group failed

    JavaScript error encountered in method ZaAccountMemberOfListView.modifyMemberList: add group failed message: B is undefined fileName: https://www.example.com:7071/zimbraA...v=090830143748 lineNumber: 21140 stack: ([object Object],(void 0))@https://www.example.com:7071/zimbraAdmin/js/Admin_all.js.zgz?v=090830143748:21140 ([object Object])@

  8. #28
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Please file a report at Bugzilla Main Page.

  9. #29
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    Quote Originally Posted by alvaroarb View Post
    a) Try install 6 and then migrate SQL and LDAP data

    So, can i do it? if so, would you please point me how exactly? or maybe, if i uninstall 6 and make a fresh 5.0.18 install will it also wipe all data?
    About the only thing you can likely do at this point is hack the zimbra schema file to include the DD attributes, but that's going to be ugly and painful. You'd need to then re-run the 6.0.0 upgrade after carefully fixing your .install_history file so that it thinks the only step so far has been having 6.0.0 installed and no upgrade steps taken.

    Unfortunately, we've never had any response back from the author of this extension, so there has been no progress on an update step for 5.0.x to 6.0.x for folks running it.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  10. #30
    alvaroarb's Avatar
    alvaroarb is offline Partner (VAR/HSP)
    Join Date
    Sep 2009
    Location
    Bogota - Colombia
    Posts
    8
    Rep Power
    5

    Default

    Hi quanah
    Thank for your interest, i've already solved my problem as you can see from my last posts. But i also kindly suggest the zimbra team to include a way to specify per-domain disclosures as it is a much-neded missing feature of this great product. Kudos to all of you

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Moving Zimbra to a new server
    By krolen in forum Administrators
    Replies: 109
    Last Post: 02-05-2009, 11:38 AM
  2. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  3. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  4. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •