Results 1 to 9 of 9

Thread: [SOLVED] cannot receive outside mail with split DNS setup

  1. #1
    jant0y is offline Intermediate Member
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default [SOLVED] cannot receive outside mail with split DNS setup

    hello guys,

    i am very new to setting up mail server.. actually this is my first one
    so i really don't have any knowledge about this stuff.

    my problem is that i am not able to receive mail from other mail servers
    i am able to send outside mails. i can also send/receive local mails (w/in zimbra)
    i am using the split DNS setup since i cannot get a public ip address for this server (not allowed)

    what could be wrong with my setup?

    result from cat /etc/hosts
    Code:
    [zimbra@mailhost ~]$ cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain   localhost
    192.36.253.120  mailhost.alliance.com.ph        mailhost
    [zimbra@mailhost ~]$
    result from cat /etc/resolv.conf
    Code:
    [zimbra@mailhost ~]$ cat /etc/resolv.conf
    ; generated by /sbin/dhclient-script
    search mail.alliance.com.ph
    nameserver 192.36.253.120
    [zimbra@mailhost ~]$
    result from dig mailhost.alliance.com.ph mx
    Code:
    ; <<>> DiG 9.3.3rc2 <<>> mailhost.alliance.com.ph mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55999
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;mailhost.alliance.com.ph.      IN      MX
    
    ;; ANSWER SECTION:
    mailhost.alliance.com.ph. 3600  IN      MX      10 mailhost.alliance.com.ph.
    
    ;; AUTHORITY SECTION:
    mailhost.alliance.com.ph. 3600  IN      NS      192.36.253.120.mailhost.alliance.com.ph.
    
    ;; ADDITIONAL SECTION:
    mailhost.alliance.com.ph. 3600  IN      A       192.36.253.120
    
    ;; Query time: 2 msec
    ;; SERVER: 192.36.253.120#53(192.36.253.120)
    ;; WHEN: Wed Apr 15 16:03:59 2009
    ;; MSG SIZE  rcvd: 103
    
    [zimbra@mailhost ~]$
    result from dig mailhost.alliance.com.ph any
    Code:
    ; <<>> DiG 9.3.3rc2 <<>> mailhost.alliance.com.ph any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64398
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mailhost.alliance.com.ph.      IN      ANY
    
    ;; ANSWER SECTION:
    mailhost.alliance.com.ph. 3600  IN      SOA     mailhost.alliance.com.ph. admin.mailhost.alliance.com.ph. 2 10800 3600 604800 3600
    mailhost.alliance.com.ph. 3600  IN      NS      192.36.253.120.mailhost.alliance.com.ph.
    mailhost.alliance.com.ph. 3600  IN      A       192.36.253.120
    mailhost.alliance.com.ph. 3600  IN      MX      10 mailhost.alliance.com.ph.
    
    ;; Query time: 2 msec
    ;; SERVER: 192.36.253.120#53(192.36.253.120)
    ;; WHEN: Wed Apr 15 16:05:08 2009
    ;; MSG SIZE  rcvd: 145
    
    [zimbra@mailhost ~]$
    what is wrong with it? pls help.

    sorry for the mispost in the zimbra desktop section

    thanks,
    jantoy

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Welcome to the forums

    Have you updated your external DNS MX records as they are actually pointing at Lotus Notes servers ?

  3. #3
    jant0y is offline Intermediate Member
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default

    hi uxbod,

    thanks for the welcome and thanks for the fast reply

    i changed the search value in /etc/resolv.conf from mail.alliance.com.ph to mailhost.alliance.com.ph

    is that what u meant?

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    ; <<>> DiG 9.5.0-P2 <<>> alliance.com.ph mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26909
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;alliance.com.ph.		IN	MX
    
    ;; ANSWER SECTION:
    alliance.com.ph.	2274	IN	MX	5 mail3.alliance.com.ph.
    alliance.com.ph.	2274	IN	MX	10 mail2.alliance.com.ph.
    alliance.com.ph.	2274	IN	MX	0 mail.alliance.com.ph.
    
    ;; ADDITIONAL SECTION:
    mail.alliance.com.ph.	2312	IN	A	203.177.158.147
    That server when you telnet to port 25 says its a Lotus Notes server.

  5. #5
    jant0y is offline Intermediate Member
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default

    ic.. i'm using mailhost.alliance.com.ph
    not alliance.com.ph

    will that result in conflict?

  6. #6
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    I am making the assumption you wish to receive email for the domain alliance.com.ph ? If so, then the external MX record is not pointing to your ZCS server.

  7. #7
    jant0y is offline Intermediate Member
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default

    the domain of ZCS is mailhost.alliance.com.ph
    so, what i have to do is make the mx record in the external dns point to the zcs domain, am i right?
    i'll ask the admin if that can be done tomorrow.
    i'll just give an update by then

  8. #8
    Dirk's Avatar
    Dirk is offline Moderator
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Yes, the MX record for mailhost.alliance.com.ph should point to your publix IP which will likely hit your router, so you set the router to sent port 25 traffic to the zimbra server and that's how mail is delivered to you.

  9. #9
    jant0y is offline Intermediate Member
    Join Date
    Apr 2009
    Location
    Philippines
    Posts
    15
    Rep Power
    6

    Default

    i have spoken with the sys admin, unfortunately, we don't have an extra public ip address available.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Migration Assistance
    By dwill in forum Administrators
    Replies: 10
    Last Post: 12-02-2008, 08:20 AM
  3. [SOLVED] Zimbra don't work - zmmailboxd
    By dmalherbe in forum Administrators
    Replies: 10
    Last Post: 11-20-2008, 10:05 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 03:34 PM
  5. Mail not getting to mail boxes
    By ehults in forum Installation
    Replies: 5
    Last Post: 10-31-2005, 09:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •