Results 1 to 3 of 3

Thread: Prompted for zimbra password during upgrade (failed)

  1. #1
    CarolBooth is offline Starter Member
    Join Date
    Apr 2009
    Posts
    2
    Rep Power
    6

    Default Prompted for zimbra password during upgrade (failed)

    We're running Ubuntu Linux 8.04.1 and Zimbra 5.10 has been running fine. When we attempted to upgrade to 5.15, no problems until the prompt to change the system when we were prompted for zimbra password. The upgrade failed at this point (we had to terminate the process) and now zimbra will not restart - it looks like this:

    sudo su zimbra
    zmcontrol restart
    starting ldap...[sudo] password for zimbra:

    We are now without email. Any advice gratefully received!

    Carol

    I just tried editing sudoers file like this post: [SOLVED] upgrade to 5.0.1 from 5.0 OSS issue with sudoers file
    The file had only one non-comment line, which mentioned root. I added a line:
    %zimbra ALL=NOPASSWD:/opt/zimbra/openldap-2.3.39.6z/libexec/slapd

    trying to restart zimbra produced the same result:

    Starting ldap...[sudo] password for zimbra:
    [sudo] password for zimbra:
    [sudo] password for zimbra:
    [sudo] password for zimbra:
    [sudo] password for zimbra:
    [sudo] password for zimbra:
    [sudo] password for zimbra:
    [sudo] password for zimbra:
    [sudo] password for zimbra:
    Done.
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Starting ldap...[sudo] password for zimbra:
    Last edited by CarolBooth; 04-02-2009 at 03:35 AM. Reason: more information

  2. #2
    CarolBooth is offline Starter Member
    Join Date
    Apr 2009
    Posts
    2
    Rep Power
    6

    Default back up but not sure what went wrong

    We restored a backup of /opt/zimbra and zimbra then restarted but I don't understand why the upgrade failed. When I look now at /etc/sudoers, it looks as I believe it should (below)

    Can anyone explain what happened? I'm scared to try the upgrade again!

    thanks
    Carol

    /etc/sudoers
    #
    # This file MUST be edited with the 'visudo' command as root.
    #
    # See the man page for details on how to write a sudoers file.
    #

    Defaults env_reset

    # Uncomment to allow members of group sudo to not need a password
    # %sudo ALL=NOPASSWD: ALL

    # Host alias specification

    # User alias specification

    # Cmnd alias specification

    # User privilege specification
    root ALL=(ALL) ALL



    # Members of the admin group may gain root privileges
    %admin ALL=(ALL) ALL
    %zimbra ALL=NOPASSWD:/opt/zimbra/openldap/libexec/slapd
    %zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmslapd
    %zimbra ALL=NOPASSWD:/opt/zimbra/postfix/sbin/postfix, /opt/zimbra/postfix/sbin/postalias, /opt/zimbra/postfix/sbin/qshape.pl, /opt/zimbra/postfix/sbin/postconf,/opt/zimbra/postfix/sbin/postsuper
    %zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmqstat,/opt/zimbra/libexec/zmmtastatus
    %zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmmailboxdmgr
    %zimbra ALL=NOPASSWD:/opt/zimbra/bin/zmcertmgr
    %zimbra ALL=NOPASSWD:/opt/zimbra/nginx/sbin/nginx
    ~

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    You shouldn't need to modify the sudoers file and when you want to start Zimbra you should login as root and do the following:

    Code:
    su - zimbra 
    zmcontrol stop ; zmcontrol start
    It's important to make sure you use 'su -' with a hyphen otherwise the environment doesn't get created correctly. I assume you attempted to run the upgrade as the root user? What erros did you get in the install log?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help!!! Moving ZCS does not work!
    By ASebestian in forum Migration
    Replies: 7
    Last Post: 02-12-2009, 06:06 PM
  2. Problem with Mail Server - Need help!
    By joeleo in forum Installation
    Replies: 2
    Last Post: 03-04-2008, 12:03 PM
  3. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 11:29 AM
  4. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 09:23 PM
  5. Lotus migration
    By babou in forum Migration
    Replies: 15
    Last Post: 03-05-2007, 10:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •