Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Logger stops by itself after 5.0.15 upgrade

  1. #11
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Have you continued with the rest of the article to determine what's showing in the logs and the database?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #12
    nufan is offline Senior Member
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    phoenix sent you a PM

  3. #13
    rs232c is offline Intermediate Member
    Join Date
    Jul 2008
    Posts
    17
    Rep Power
    6

    Default

    I get the same behavior, the logger stops when the log files are switched early in the morning.

    The last lines from zimbra.log.0.gz:
    Mar 24 03:14:03 odmxserve zmmailboxdmgr[75585]: status requested
    Mar 24 03:14:03 odmxserve zmmailboxdmgr[75585]: status OK
    Mar 24 03:14:04 odmxserve zimbramon[75427]: 75427:info: 2009-03-24 03:14:00, STATUS: odmxserve.rdschool.net: antispam: Running
    Mar 24 03:14:04 odmxserve zimbramon[75427]: 75427:info: 2009-03-24 03:14:00, STATUS: odmxserve.rdschool.net: antivirus: Running
    Mar 24 03:14:04 odmxserve zimbramon[75427]: 75427:info: 2009-03-24 03:14:00, STATUS: odmxserve.rdschool.net: archiving: Running
    Mar 24 03:14:04 odmxserve zimbramon[75427]: 75427:info: 2009-03-24 03:14:00, STATUS: odmxserve.rdschool.net: ldap: Running
    Mar 24 03:14:04 odmxserve zimbramon[75427]: 75427:info: 2009-03-24 03:14:00, STATUS: odmxserve.rdschool.net: logger: Running
    Mar 24 03:14:04 odmxserve zimbramon[75427]: 75427:info: 2009-03-24 03:14:00, STATUS: odmxserve.rdschool.net: mailbox: Running
    Mar 24 03:14:04 odmxserve zimbramon[75427]: 75427:info: 2009-03-24 03:14:00, STATUS: odmxserve.rdschool.net: mta: Running
    Mar 24 03:14:04 odmxserve zimbramon[75427]: 75427:info: 2009-03-24 03:14:00, STATUS: odmxserve.rdschool.net: snmp: Running
    Mar 24 03:14:04 odmxserve zimbramon[75427]: 75427:info: 2009-03-24 03:14:00, STATUS: odmxserve.rdschool.net: spell: Running
    Mar 24 03:14:04 odmxserve zimbramon[75427]: 75427:info: 2009-03-24 03:14:00, STATUS: odmxserve.rdschool.net: stats: Running
    Mar 24 03:14:38 odmxserve zmmailboxdmgr[75901]: status requested
    Mar 24 03:14:38 odmxserve zmmailboxdmgr[75901]: status OK
    Mar 24 03:14:39 odmxserve zmmailboxdmgr[75948]: status requested
    Mar 24 03:14:39 odmxserve zmmailboxdmgr[75948]: status OK

    The first lines from zimbra.log:
    Mar 24 03:15:51 odmxserve zmmailboxdmgr[76595]: status requested
    Mar 24 03:15:51 odmxserve zmmailboxdmgr[76595]: status OK
    Mar 24 03:15:52 odmxserve zmmailboxdmgr[76642]: status requested
    Mar 24 03:15:52 odmxserve zmmailboxdmgr[76642]: status OK
    Mar 24 03:15:52 odmxserve zimbramon[930]: 930:err: Service status change: odmxserve.rdschool.net logger changed from running to stopped

  4. #14
    nufan is offline Senior Member
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    rs nice to see I'm not the only one, did you have a fix for your problem or just the source? Hopefully someone can come to the rescue

  5. #15
    rs232c is offline Intermediate Member
    Join Date
    Jul 2008
    Posts
    17
    Rep Power
    6

    Default

    I'm still working on it: interestingly, the referenced Wiki article says:

    Code:
    How to determine why logger isn't working
    
    Why does the logger service stop? The two main causes are log rotation and a bug in zmlogswatchctl before ZCS 4.5.
    Well that's correct, it's a log rotation problem, but the article doesn't address causes/cures.

  6. #16
    nufan is offline Senior Member
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    I see we are both using 5.0.15 on OSX (you're on 10.5, myself 10.4) so maybe thats the common denominator here. I have a ticket placed that is still open however our time zones don't match up so only receiving/replying to emails one per day.

    Anyway let me know if you discover anything, hopefully we can come up with something. If I get a resolution from my open ticket I'll report back here also.

    I also discovered that with the wiki, they have possible causes but no fixes listed, nice find.

    Thanks

  7. #17
    rs232c is offline Intermediate Member
    Join Date
    Jul 2008
    Posts
    17
    Rep Power
    6

    Default

    Here's a clue, I stopped swatch and logswatch and then restarted them; here are the start results.
    Code:
    odmxserve:log zimbra$ zmswatchctl start
    Starting swatch...done.
    odmxserve:log zimbra$ ps ax | grep swatch
      694 s000  S      0:00.12 /usr/bin/perl /opt/zimbra/libexec/swatch --config-file=/opt/zimbra/conf/swatchrc --use-cpan-file-tail --script-dir=/tmp -t /var/log/\
    zimbra.log
      698 s000  S      0:00.14 /usr/bin/perl /tmp/.swatch_script.694
      701 s000  R+     0:00.00 grep swatch
    odmxserve:log zimbra$ cat /opt/zimbra/log/swatch.pid
    694
    odmxserve:log zimbra$ zmlogswatchctl start
    Starting logswatch...done.
    odmxserve:log zimbra$ ps ax | grep swatch
      694 s000  S      0:00.12 /usr/bin/perl /opt/zimbra/libexec/swatch --config-file=/opt/zimbra/conf/swatchrc --use-cpan-file-tail --script-dir=/tmp -t /var/log/\
    zimbra.log
      698 s000  S      0:00.15 /usr/bin/perl /tmp/.swatch_script.694
      763 s000  S      0:00.10 /usr/bin/perl /opt/zimbra/libexec/logswatch --config-file=/opt/zimbra/conf/logswatchrc --use-cpan-file-tail --pid-file=/opt/zimbra/l\
    og/logswatch.pid --script-dir=/tmp -t /var/log/zimbra.log
      765 s000  S      0:00.13 /usr/bin/perl /tmp/.swatch_script.763
      825 s000  R+     0:00.00 grep swatch
    odmxserve:log zimbra$ cat /opt/zimbra/log/logswatch.pid
    765
    Note that swatch.pid(694) is the pid of the parent process; the child process(698) contains the parent pid(694) as part of the script name.

    However, logswatch.pid(765) is the pid of the CHILD process; the child process(765) contains the parent pid(763) as part of the script name.

    Why does logswatch.pid have the pid of the child, not the parent?

  8. #18
    rs232c is offline Intermediate Member
    Join Date
    Jul 2008
    Posts
    17
    Rep Power
    6

    Default

    The same issue is being discussed in the thread " [SOLVED] kill HUP crashes logger".

  9. #19
    nufan is offline Senior Member
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    FYI the technician assigned to my trouble ticket was able to reproduce and filed bug 36545

    Bug 36545 – logswatch not running after nightly log rotation

  10. #20
    rs232c is offline Intermediate Member
    Join Date
    Jul 2008
    Posts
    17
    Rep Power
    6

    Default

    I posted a patch in the "[SOLVED] kill HUP crashes logger" thread.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 03-23-2009, 08:29 AM
  2. Logger Stops
    By bcurve in forum Administrators
    Replies: 7
    Last Post: 01-13-2009, 07:28 PM
  3. Zimbra logger stops periodically
    By Miklos Kalman in forum Administrators
    Replies: 2
    Last Post: 01-11-2009, 07:37 AM
  4. [SOLVED] 5.0.4 Upgrade Issues - Logger, Shared Spam
    By Cryophallion in forum Administrators
    Replies: 13
    Last Post: 04-21-2008, 12:37 PM
  5. High iowait from logger after upgrade to 4.5.9
    By pi13137 in forum Installation
    Replies: 9
    Last Post: 11-09-2007, 05:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •