Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: post installation error

  1. #1
    ramidotcom is offline Intermediate Member
    Join Date
    Oct 2005
    Posts
    15
    Rep Power
    9

    Default post installation error

    hey all, has anypne run into this error after the installation and the service isbeing started

    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.C ommunicationException tadr0s.com:389)

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Yes is means LDAP is not running. What Linux are you running? Are there any errors in your install log? It's in the /tmp dir.

  3. #3
    ramidotcom is offline Intermediate Member
    Join Date
    Oct 2005
    Posts
    15
    Rep Power
    9

    Default ldap

    im running centos 4 and the install log shows:

    [zimbra@tadr0s tmp]$ view install.log.24441
    Preparing packages for installation...
    zimbra-core-3.0.M1_21.RHEL4-20050920162541_
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    Preparing packages for installation...
    zimbra-ldap-3.0.M1_21.RHEL4-20050920162541_
    Preparing packages for installation...
    zimbra-mta-3.0.M1_21.RHEL4-20050920162541_
    Preparing packages for installation...
    zimbra-snmp-3.0.M1_21.RHEL4-20050920162541_
    Preparing packages for installation...
    zimbra-store-3.0.M1_21.RHEL4-20050920162541_
    COMMAND: /opt/zimbra/libexec/zmmyinit
    * Creating required directories
    * Generating mysql config /opt/zimbra/conf/my.cnf
    * Creating database in /opt/zimbra/db/data
    * Starting mysql server
    * Loading schema /opt/zimbra/db/db.sql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    * Loading version from /opt/zimbra/db/versions-init.sql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    * Setting random password for mysql root user in zimbra local config
    * Setting random password for mysql zimbra user in zimbra local config
    * Changing mysql root user password
    ^G/opt/zimbra/mysql/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)'
    Check that mysqld is running and that the socket: '/opt/zimbra/db/mysql.sock' exists!
    * Changing mysql zimbra user password
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    **** PASSWORD CHANGE FAILED
    COMMAND: zmlocalconfig -e zimbra_server_hostname=tadr0s.com
    COMMAND: zmlocalconfig -e ldap_host=tadr0s.com
    COMMAND: zmlocalconfig -e ldap_port=389
    COMMAND: /opt/zimbra/libexec/zmldapinit
    Started slapd: pid
    ldap_bind: Can't contact LDAP server (-1)
    ldap_bind: Can't contact LDAP server (-1)
    COMMAND: zmprov cs tadr0s.com
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException tadr0s.com:389)
    COMMAND: zmprov cd tadr0s.com

  4. #4
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Did the instal fail and you ran it again? If so you need to run

    install.sh -u
    Then run:
    ps -ef | grep zimbra

    to make sure all the processes are killed.

    Then try a clean run of the install.

  5. #5
    ramidotcom is offline Intermediate Member
    Join Date
    Oct 2005
    Posts
    15
    Rep Power
    9

    Default i already tried that

    i already tried that

  6. #6
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Ok try this:

    Install Error on FC3

  7. #7
    ramidotcom is offline Intermediate Member
    Join Date
    Oct 2005
    Posts
    15
    Rep Power
    9

    Default

    ill try a clean reinstall one moretime, if that doesnt work ill usethat link thnx

  8. #8
    ramidotcom is offline Intermediate Member
    Join Date
    Oct 2005
    Posts
    15
    Rep Power
    9

    Default

    i ran
    /opt/zimbra/openldap/libexec/slapd -4 -u zimbra -h ldap://:7389/ -f /opt/zimbra/conf/slapd.conf all one line and got no errors

    do u think it can be the mysql server
    Last edited by ramidotcom; 10-05-2005 at 09:33 PM.

  9. #9
    ramidotcom is offline Intermediate Member
    Join Date
    Oct 2005
    Posts
    15
    Rep Power
    9

    Default i ran the install againand got

    Preparing packages for installation...
    zimbra-core-3.0.M1_21.RHEL4-20050920162541_
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    Preparing packages for installation...
    zimbra-ldap-3.0.M1_21.RHEL4-20050920162541_
    Preparing packages for installation...
    zimbra-mta-3.0.M1_21.RHEL4-20050920162541_
    Preparing packages for installation...
    zimbra-snmp-3.0.M1_21.RHEL4-20050920162541_
    Preparing packages for installation...
    zimbra-store-3.0.M1_21.RHEL4-20050920162541_
    COMMAND: /opt/zimbra/libexec/zmmyinit
    * Creating required directories
    * Generating mysql config /opt/zimbra/conf/my.cnf
    * Creating database in /opt/zimbra/db/data
    * Starting mysql server
    * Loading schema /opt/zimbra/db/db.sql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    * Loading version from /opt/zimbra/db/versions-init.sql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    * Setting random password for mysql root user in zimbra local config
    * Setting random password for mysql zimbra user in zimbra local config
    * Changing mysql root user password
    ^G/opt/zimbra/mysql/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)'
    Check that mysqld is running and that the socket: '/opt/zimbra/db/mysql.sock' exists!
    * Changing mysql zimbra user password
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    **** PASSWORD CHANGE FAILED
    COMMAND: zmlocalconfig -e zimbra_server_hostname=tadr0s.com
    COMMAND: zmlocalconfig -e ldap_host=tadr0s.com
    COMMAND: zmlocalconfig -e ldap_port=389
    COMMAND: /opt/zimbra/libexec/zmldapinit
    Started slapd: pid
    ldap_bind: Can't contact LDAP server (-1)
    ldap_bind: Can't contact LDAP server (-1)
    COMMAND: zmprov cs tadr0s.com
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException tadr0s.com:389)
    COMMAND: zmprov cd tadr0s.com

  10. #10
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by ramidotcom
    i ran
    /opt/zimbra/openldap/libexec/slapd -4 -u zimbra -h ldap://:7389/ -f /opt/zimbra/conf/slapd.conf all one line and got no errors

    do u think it can be the mysql server
    After this can you run "ps -ef | grep slapd" Assuming you got no error then this should be up and running.

    If not try this command:

    Code:
     /opt/zimbra/openldap/libexec/slapd -d 10 -4 -u zimbra -h ldap://:7389/ -f /opt/zimbra/conf/slapd.conf
    This should print more debug.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Postfix problem
    By jimbo in forum Administrators
    Replies: 46
    Last Post: 07-23-2007, 05:24 AM
  3. Yet another get.DirectContext issue
    By dccpark in forum Installation
    Replies: 5
    Last Post: 03-08-2006, 01:25 PM
  4. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM
  5. Building native libraries on MacOS X
    By ajmas in forum Developers
    Replies: 3
    Last Post: 10-14-2005, 11:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •