Results 1 to 4 of 4

Thread: LDAP high availablity

  1. #1
    Join Date
    Dec 2008
    Posts
    10
    Rep Power
    6

    Default LDAP high availablity

    Hello.

    Could someone help me out with how to configure Zimbra to failover to another Zimbra LDAP instance if LDAP fails?
    I've inherited a Zimbra NE 5.07 server from my predecessor who also installed two other Zimbra services which just run the LDAP service. I've checked those servers and they're both replicating properly. They also show up in the Zimbra web admin.

    The problem is that a few times recently the openldap service on the main server has simply died (which I must say is unique in my experience of openldap). I've not been able to find the cause yet, but the worrying thing is that Zimbra doesn't fail over to one of the slave servers; the whole zimbra server simply stops working because of the (I suppose) large amounts of configuration data it needs to retrieve from ldap.

    The only thing I could find on the wiki that comes close to failover is a manual slave to master promotion, which is no good to me. (http://wiki.zimbra.com/index.php?tit...to_LDAP_Master)

    Looking through the various configs, all the services seem to be configured to just use a single ldap host for lookup (for example, postfix's ldap config could read "server_host = ldap://server1.place.com, ldap://server2.place.com" instead of just "server_host = ldap://server1.place.com".
    So perhaps Zimbra doesn't support failing over like that?

    Any help would be appreciated.

    Regards,

    Brian.

  2. #2
    davecowen5 is offline Intermediate Member
    Join Date
    Oct 2008
    Posts
    20
    Rep Power
    6

    Default

    I've been experiencing the same thing, and I'd love to see an answer to this.

    FYI, check your debug.log to see if the failure is due to a ch_malloc operation of absurd size -- this is what I just ran into this morning. I've put the details into Bug 36403 – OpenLDAP failure - ch_malloc of absurd memory size .

  3. #3
    Join Date
    Dec 2008
    Posts
    10
    Rep Power
    6

    Default

    Cheers for the tip. I'll look out for that. The server's not crashed again since that last problem, so I'll just have to wait.
    Looking around on the internet, some people suggest raising the amount of memory allocated to slapd. I might give that a go.

  4. #4
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,271
    Rep Power
    10

    Default

    First, I'd suggest you look at the high perf tuning wiki. Second, we're looking at Master/Master configurations. See bug#27872. Third, always enable core files if you're getting crashes, so they can be examined. Fourth, it's probably unlikely that Dave's issue is the same as yours.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. LDAP Cannot bind on migration to new server
    By neekster in forum Migration
    Replies: 23
    Last Post: 03-09-2009, 02:08 AM
  2. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 10:38 AM
  3. Replies: 8
    Last Post: 08-07-2008, 05:18 AM
  4. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  5. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •