Results 1 to 3 of 3

Thread: [SOLVED] zmcontrol not working

  1. #1
    alahser is offline Junior Member
    Join Date
    Oct 2008
    Location
    Fountain Hills, Arizona
    Posts
    7
    Rep Power
    6

    Default [SOLVED] zmcontrol not working

    Hi,

    When I type the following command:

    zmcontrol stop

    I get this output:

    Host mail.mydomain.com
    Stopping stats...Terminated

    Yet, if I immediately type:

    zmcontrol status

    I get this output:

    Host mail.mydomain.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running

    I'm trying to upgrade to the latest version (5.0.14). I am on version 5.0.10. I think that the zmcontrol not being about to stop (and start) the zimbra installation is causing problems during the upgrade.

    I also tried to look at the output of

    zmprov gac

    However, this give alot of output. And, I think some entries might be missing, but I'm not sure how that might have happened.

    I did search through the forums, but, I'm not really making any progress. Thanks for your help in advance.

    Andrew

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Try /etc/init.d/zimbra stop, and the ps aux | grep zimbra to ensure all processes have died. If not then kill them off. Then try the upgrade. Just ensure you have a good backup.

  3. #3
    alahser is offline Junior Member
    Join Date
    Oct 2008
    Location
    Fountain Hills, Arizona
    Posts
    7
    Rep Power
    6

    Default

    Ok. I did this. The entire upgrade appeared to be normal, until the very end. Here are the last few lines of output from the upgrade:

    Code:
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    Operations logged to /tmp/zmsetup.03122009-084437.log
    Starting ldap...done.
    Setting defaults...done.
    Upgrading from 5.0.10_GA_2609 to 5.0.14_GA_2850
    Stopping zimbra services
    
    Session terminated, killing shell... ...killed.
    Stop failed - exiting
    UPGRADE FAILED - exiting
    So, I went ahead and did the following:

    Code:
    sudo su - zimbra
    zmcontrol start
    And I got this output:

    Code:
    Host mail.mydomain.com
            Starting logger...Done.
            Starting mailbox...Done.
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting snmp...Done.
            Starting spell...Done.
            Starting mta...Done.
            Starting stats...Done.
    Everything appears to be working normally. I am marking this as solved. However, let me know if there is anything else you would like me to look into.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 11:41 AM
  2. Replies: 4
    Last Post: 11-14-2007, 02:19 PM
  3. Zimlets all not working?
    By jadestorm in forum Administrators
    Replies: 16
    Last Post: 10-28-2007, 07:25 PM
  4. SSL certificate problem(?) Tomcat not working
    By akai in forum Installation
    Replies: 1
    Last Post: 07-02-2007, 02:43 PM
  5. ZIMBRA!!!!! Error zmcontrol status and others
    By orison in forum Installation
    Replies: 8
    Last Post: 02-03-2007, 07:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •