Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: [SOLVED] MX record not found

  1. #11
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    If you do not have a valid RDNS entry for your public IP then your emails may be rejected by some MTAs. Try using your ISP as a smart-relay and then sending out a email. You can also check /var/log/zimbra.log for any error messages aswell.

  2. #12
    ECB
    ECB is offline Active Member
    Join Date
    Jan 2009
    Posts
    45
    Rep Power
    6

    Default

    Indeed, we did not have a valid RDNS record.

    However, after we received an RDNS record we're still having the same issue (this is after formatting the test server and reinstalling Zimbra).

    When we put a server in our DMZ with a public IP we are able to send and receive mail. We need a server in the LAN though...

    The following is an excerpt from /var/log/zimbra.log.
    You can see here what happens when a message from GMail tries to make its way to our server (located behind a NAT):

    Code:
    Mar  5 13:07:03 zimspa postfix/smtpd[22769]: connect from zimspa.net[172.72.30.3]
    Mar  5 13:07:03 zimspa postfix/smtpd[22769]: D4B4210A02D: client=zimspa.net[172.72.30.3]
    Mar  5 13:07:03 zimspa postfix/cleanup[22773]: D4B4210A02D: message-id=<1335364646.01236276423569.JavaMail.root@zimspa>
    Mar  5 13:07:03 zimspa postfix/smtpd[22769]: disconnect from zimspa.net[172.72.30.3]
    Mar  5 13:07:03 zimspa postfix/qmgr[21820]: D4B4210A02D: from=, size=623, nrcpt=1 (queue active)
    Mar  5 13:07:03 zimspa amavis[17195]: (17195-01) ESMTP::10024 /opt/zimbra/data/amavisd/tmp/amavis-20090305T130703-17195:  ->  SIZE=623 Received: from zimspa.net ([127.0.0.1]) by localhost (zimspa.net [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for ; Thu,  5 Mar 2009 13:07:03 -0500 (EST)
    Mar  5 13:07:03 zimspa amavis[17195]: (17195-01) Checking: pLky6batQfWU [172.72.30.3]  -> 
    Mar  5 13:07:03 zimspa clamd[17250]: Reading databases from /opt/zimbra/data/clamav/db 
    Mar  5 13:07:05 zimspa clamd[17250]: Database correctly reloaded (514193 signatures) 
    Mar  5 13:07:06 zimspa postfix/smtpd[22777]: connect from localhost.localdomain[127.0.0.1]
    Mar  5 13:07:06 zimspa postfix/smtpd[22777]: 4CEA310A1FB: client=localhost.localdomain[127.0.0.1]
    Mar  5 13:07:06 zimspa postfix/cleanup[22773]: 4CEA310A1FB: message-id=<1335364646.01236276423569.JavaMail.root@zimspa>
    Mar  5 13:07:06 zimspa postfix/smtpd[22777]: disconnect from localhost.localdomain[127.0.0.1]
    Mar  5 13:07:06 zimspa postfix/qmgr[21820]: 4CEA310A1FB: from=, size=1045, nrcpt=1 (queue active)
    Mar  5 13:07:06 zimspa amavis[17195]: (17195-01) FWD via SMTP:  -> ,BODY=7BIT 250 2.6.0 Ok, id=17195-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 4CEA310A1FB
    Mar  5 13:07:06 zimspa amavis[17195]: (17195-01) Passed CLEAN, [172.72.30.3] [172.72.30.3]  -> , Message-ID: <1335364646.01236276423569.JavaMail.root@zimspa>, mail_id: pLky6batQfWU, Hits: -0.28, size: 623, queued_as: 4CEA310A1FB, 2438 ms
    Mar  5 13:07:06 zimspa postfix/smtp[22774]: D4B4210A02D: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=2.5, delays=0.03/0/0.01/2.4, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 4CEA310A1FB)
    Mar  5 13:07:06 zimspa postfix/qmgr[21820]: D4B4210A02D: removed
    Mar  5 13:07:06 zimspa amavis[17195]: (17195-01) extra modules loaded: /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/LDAP/Extension.pm, Net/SSLeay.pm
    Mar  5 13:07:06 zimspa postfix/smtp[22778]: connect to gmail-smtp-in.l.google.com[64.233.183.114]: Connection refused (port 25)
    Mar  5 13:07:06 zimspa postfix/smtp[22778]: connect to alt1.gmail-smtp-in.l.google.com[72.14.221.27]: Connection refused (port 25)
    Mar  5 13:07:06 zimspa postfix/smtp[22778]: connect to alt2.gmail-smtp-in.l.google.com[74.125.93.114]: Connection refused (port 25)
    Mar  5 13:07:06 zimspa postfix/smtp[22778]: connect to alt3.gmail-smtp-in.l.google.com[209.85.143.27]: Connection refused (port 25)
    Mar  5 13:07:06 zimspa postfix/smtp[22778]: connect to alt4.gmail-smtp-in.l.google.com[209.85.201.114]: Connection refused (port 25)
    Mar  5 13:07:06 zimspa postfix/smtp[22778]: 4CEA310A1FB: to=, relay=none, delay=0.08, delays=0.02/0.01/0.06/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[209.85.201.114]: Connection refused)
    Mar  5 13:07:51 zimspa zmmailboxdmgr[23205]: status requested
    Mar  5 13:07:51 zimspa zmmailboxdmgr[23205]: status OK
    Mar  5 13:07:51 zimspa zmmailboxdmgr[23291]: status requested
    Mar  5 13:07:51 zimspa zmmailboxdmgr[23291]: status OK
    Mar  5 13:08:03 zimspa zmmailboxdmgr[23524]: status requested
    Mar  5 13:08:03 zimspa zmmailboxdmgr[23524]: status OK
    Mar  5 13:08:03 zimspa zimbramon[23333]: 23333:info: 2009-03-05 13:08:01, STATUS: zimspa.net: antispam: Running 
    Mar  5 13:08:03 zimspa zimbramon[23333]: 23333:info: 2009-03-05 13:08:01, STATUS: zimspa.net: antivirus: Running 
    Mar  5 13:08:03 zimspa zimbramon[23333]: 23333:info: 2009-03-05 13:08:01, STATUS: zimspa.net: ldap: Running 
    Mar  5 13:08:03 zimspa zimbramon[23333]: 23333:info: 2009-03-05 13:08:01, STATUS: zimspa.net: logger: Running 
    Mar  5 13:08:03 zimspa zimbramon[23333]: 23333:info: 2009-03-05 13:08:01, STATUS: zimspa.net: mailbox: Running 
    Mar  5 13:08:03 zimspa zimbramon[23333]: 23333:info: 2009-03-05 13:08:01, STATUS: zimspa.net: mta: Running 
    Mar  5 13:08:03 zimspa zimbramon[23333]: 23333:info: 2009-03-05 13:08:01, STATUS: zimspa.net: snmp: Running 
    Mar  5 13:08:03 zimspa zimbramon[23333]: 23333:info: 2009-03-05 13:08:01, STATUS: zimspa.net: spell: Running 
    Mar  5 13:08:03 zimspa zimbramon[23333]: 23333:info: 2009-03-05 13:08:01, STATUS: zimspa.net: stats: Running 
    Mar  5 13:08:58 zimspa zmmailboxdmgr[24073]: status requested
    Mar  5 13:08:58 zimspa zmmailboxdmgr[24073]: status OK
    Mar  5 13:08:59 zimspa zmmailboxdmgr[24159]: status requested
    Mar  5 13:08:59 zimspa zmmailboxdmgr[24159]: status OK
    Last edited by ECB; 03-05-2009 at 09:45 AM.

  3. #13
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,469
    Rep Power
    56

    Default

    According to the log you've posted the problem is a connection FROM your Zimbra server TO gmail is being refused and not an inbound mail problem.

    Although the Split DNS article contains this caveat:

    This should not be used for a multi-node Zimbra installation, and should not be used as the DNS server for any other hosts on your network.
    you still need to have your Zimbra server resolvable by DNS from within your LAN otherwise you will not have mail delivered to you Zimbra server. The reason that statement is in there is because that description for a Split DNS is for a BIND server being installed on the Zimbra server itself and will resolve only the IP of that server for postfix. You will need to set-up a DNS server on the LAN so that you can resolve the IP from behind your NAT device, have you done that?

    Can you run the usual commands on your Zimbra server and post the output here:

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname`  <-- type that exactly as you see it with backticks not single quotes.
    Have you checked if your IP is on any form of blacklist? If you need some instructions for setting up the DNS on your LAN please search the forums for a thread titled "DNS in a nutshell", it's a simple to follow explanation of hat's needed.

    You should also check page 8 in the Multi-Server Installation Guide for DNS requirements.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #14
    ECB
    ECB is offline Active Member
    Join Date
    Jan 2009
    Posts
    45
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    You will need to set-up a DNS server on the LAN so that you can resolve the IP from behind your NAT device, have you done that?
    Is this in addition or instead of the BIND server installed on the Zimbra server?

    Quote Originally Posted by phoenix View Post
    Can you run the usual commands on your Zimbra server and post the output here:
    /etc/hosts:
    Code:
    127.0.0.1	localhost.localdomain
    172.72.30.3	zimspa.net	zimspa
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    /etc/resolv.conf:
    Code:
    nameserver 172.72.30.3
    dig mydomain.com mx:
    Code:
    ; <<>> DiG 9.4.2-P2 <<>> zimspa.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 21068
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;zimspa.com.			IN	MX
    
    ;; AUTHORITY SECTION:
    com.			900	IN	SOA	a.gtld-servers.net. nstld.verisign-grs.com. 1236500998 1800 900 604800 900
    
    ;; Query time: 98 msec
    ;; SERVER: 172.72.30.3#53(172.72.30.3)
    ;; WHEN: Sun Mar  8 06:31:21 2009
    ;; MSG SIZE  rcvd: 101
    dig mydomain any:
    Code:
    ; <<>> DiG 9.4.2-P2 <<>> zimspa.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 60168
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;zimspa.com.			IN	A
    
    ;; AUTHORITY SECTION:
    com.			861	IN	SOA	a.gtld-servers.net. nstld.verisign-grs.com. 1236500998 1800 900 604800 900
    
    ;; Query time: 0 msec
    ;; SERVER: 172.72.30.3#53(172.72.30.3)
    ;; WHEN: Sun Mar  8 06:32:00 2009
    ;; MSG SIZE  rcvd: 101
    host `hostname`:
    Code:
    Host zimspa not found: 3(NXDOMAIN)
    Quote Originally Posted by phoenix View Post
    Have you checked if your IP is on any form of blacklist?
    Yes - it isn't blacklisted.

    Quote Originally Posted by phoenix View Post
    You should also check page 8 in the Multi-Server Installation Guide for DNS requirements.
    Looked at page 8 but couldn't find any mention to DNS, so went back a little to page 6 "DNS Configuration Requirement" (is this what you meant?). Couldn't find anything I haven't already read.

  5. #15
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,469
    Rep Power
    56

    Default

    According to those results you've posted there is no A or MX record for your domain and your /etc/hosts file is incorrect. If you are using the DNS on the Zimbra serevr then fix those records, you don't actually need two DNS servers, you could have added the records to your LAN DNS server. A quick check of your external DNS records hsows the same problem, you are using the domain name as ther server name when you should have a FQDN (Fully Qualified Domain Name) for the server and not just use zimspa.net.

    The hosts file should be as follows:

    Code:
    this line: 
    
    127.0.0.1	localhost.localdomain
    
    should read:
    
    127.0.0.1	localhost.localdomain localhost
    
    in the following line you are using the domain name for your server and it should be the FQDN of the server, so this line:
    
    172.72.30.3	zimspa.net	zimspa
    
    should read (something like):
    
    172.72.30.3	mail.zimspa.net	zimspa
    so you end up with a file like this:

    Code:
    127.0.0.1	localhost.localdomain localhost
    172.72.30.3	mail.zimspa.net	zimspa
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #16
    ECB
    ECB is offline Active Member
    Join Date
    Jan 2009
    Posts
    45
    Rep Power
    6

    Default

    Ok. I have fixed everything you told me to but we are still having the same problem. I have run all the commands that you told me to again and am pasting the results below. Please tell me what we are doing wrong as mail is still being rejected.

    Thanks!

    Code:
    cat /etc/hosts
    
    127.0.0.1	localhost.localdomain localhost
    172.72.30.3	mail.zimspa.net	mail
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    
    cat /etc/resolv.conf
    
    domain zimspa.net
    nameserver 172.72.30.3
    
    
    dig zimspa.net mx
    
    ; <<>> DiG 9.4.2-P2 <<>> zimspa.net mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24011
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;zimspa.net.			IN	MX
    
    ;; ANSWER SECTION:
    zimspa.net.		604800	IN	MX	10 zimspa.net.
    
    ;; AUTHORITY SECTION:
    zimspa.net.		604800	IN	NS	zimspa.net.
    
    ;; ADDITIONAL SECTION:
    zimspa.net.		604800	IN	A	172.72.30.3
    
    ;; Query time: 0 msec
    ;; SERVER: 172.72.30.3#53(172.72.30.3)
    ;; WHEN: Sun Mar  8 10:25:10 2009
    ;; MSG SIZE  rcvd: 74
    
    
    dig zimspa.net any
    
    ; <<>> DiG 9.4.2-P2 <<>> zimspa.net any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2260
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;zimspa.net.			IN	ANY
    
    ;; ANSWER SECTION:
    zimspa.net.		604800	IN	SOA	zimspa.net. admin.zimspa.net. 50320096 28800 3600 604800 38400
    zimspa.net.		604800	IN	NS	zimspa.net.
    zimspa.net.		604800	IN	MX	10 zimspa.net.
    zimspa.net.		604800	IN	A	172.72.30.3
    
    ;; ADDITIONAL SECTION:
    zimspa.net.		604800	IN	A	172.72.30.3
    
    ;; Query time: 0 msec
    ;; SERVER: 172.72.30.3#53(172.72.30.3)
    ;; WHEN: Sun Mar  8 10:25:10 2009
    ;; MSG SIZE  rcvd: 132
    
    
    host `hostname`
    
    mail.zimspa.net has address 172.72.30.3

  7. #17
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,469
    Rep Power
    56

    Default

    Your MX & A records are still incorrect, it should be the FQDN of the server, like this:

    Code:
    zimspa.net.		604800	IN	MX	10 mail.zimspa.net.
    
    mail.zimspa.net.		604800	IN	A	172.72.30.3
    Fix those then restart the server. If you still have errors then look at the log files and see exactly what errors you're getting and why mail is being rejected.

    As I mentioned earlier, your external DNS records have the same problem and you'll need to make the above changes to those records as well.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #18
    ECB
    ECB is offline Active Member
    Join Date
    Jan 2009
    Posts
    45
    Rep Power
    6

    Default

    Success!!!

    It appeared that not only our DNS records were wrong, but we forgot to open port 25 on our firewall!

    Zimbra had DNS service, so it could resolve the remote mail servers, but it couldn't send the mail so it assumed the connection is refused...

    Thanks everyone for your help!

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 01-13-2009, 08:10 AM
  2. Fresh Zimbra installation does not work
    By Datax in forum Installation
    Replies: 4
    Last Post: 08-18-2008, 01:18 PM
  3. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  4. Replies: 2
    Last Post: 10-04-2007, 03:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •