Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: [SOLVED] Attachment "View as HTML" not working only asks to download?

  1. #1
    jisenburg is offline Active Member
    Join Date
    May 2008
    Location
    Illinois
    Posts
    32
    Rep Power
    7

    Smile [SOLVED] Attachment "View as HTML" not working only asks to download?

    Ever since i upgraded to NE from FOSS (since June 08) the View as HTML option for attachments does not work. When I select to view as html it pops up the download save to disk option, etc...

    The only format that works is a txt. Doc, xls, etc.. do not work.

    Anybody have any ideas of where to start looking?

    Thanks for any help!

    JIsenburg

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

  3. #3
    jisenburg is offline Active Member
    Join Date
    May 2008
    Location
    Illinois
    Posts
    32
    Rep Power
    7

    Default

    Thanks for the info. One really easy, perhaps, dumb question I have is...

    Do I need to make sure I install the convertd package while upgrading zimbra for the "view as html" to work in the ZWC?

    Thanks again for putting up with my easy questions.

    JIsenburg

  4. #4
    In_The_Ville is offline Special Member
    Join Date
    Apr 2008
    Location
    Catonsville MD
    Posts
    101
    Rep Power
    7

    Default

    Any idea how to proceed if I run:

    Code:
    /opt/zimbra/convertd/bin/upgrade_v2
    and I get:

    Code:
    /opt/zimbra/convertd/bin/upgrade_v2: No such file or directory

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Quote Originally Posted by In_The_Ville View Post
    Any idea how to proceed if I run:

    Code:
    /opt/zimbra/convertd/bin/upgrade_v2
    That would depend what problem you're having or what you're tryin to achieve.

    The above mentioned bu refers to a conversion from the OS version to NE, is that what's happened to you?

    Quote Originally Posted by In_The_Ville View Post
    and I get:

    Code:
    /opt/zimbra/convertd/bin/upgrade_v2: No such file or directory
    That file is certainly there on my installation:

    Code:
    ls -l /opt/zimbra/convertd/bin/upgrade_v2
    -r-xr-xr-x 1 zimbra zimbra 3187 Jan 26 11:56 /opt/zimbra/convertd/bin/upgrade_v2
    As referenced in the bug report, did you check your version of convertd with:

    Code:
    zmlocalconfig convertd_version
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    In_The_Ville is offline Special Member
    Join Date
    Apr 2008
    Location
    Catonsville MD
    Posts
    101
    Rep Power
    7

    Default

    Sorry, it's Saturday. I'm a little short on details.

    I did covert from FOSS to NE, and I no one can view attachments in HTML.

    Based on the wiki article "Conversion: Unable to instantiate MIME handler", I ran:

    Code:
    zimbra@mail:~$ zmlocalconfig convertd_version
    convertd_version = 1
    and then discovered that I did not have the upgrade_v2 file.

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    I don't understand why that file isn't there, do you have the convertd directory?

    you should see something like the following:

    Code:
    root@chinook ~]# ls -l /opt/zimbra/convertd/
    total 32
    drwxrwxr-x 2 zimbra zimbra 4096 Jan 28 21:35 bin
    drwxr-x--- 2 zimbra zimbra 4096 Aug  1  2008 cnvcache
    drwxrwxr-x 2 zimbra zimbra 4096 Jan 28 21:35 conf
    drwxr-x--- 2 zimbra zimbra 4096 May 16  2008 crash
    drwxr-x--- 2 zimbra zimbra 4096 Oct 17 19:13 inprocessing
    drwxrwxr-x 2 zimbra zimbra 4096 Jan 28 21:35 lib
    drwxr-x--- 2 zimbra zimbra 4096 May 16  2008 suspect
    drwxr-x--- 2 zimbra zimbra 4096 May 16  2008 tmp
    [root@chinook ~]#
    [root@chinook ~]#
    [root@chinook ~]# ls -l /opt/zimbra/convertd/bin
    total 20
    -rwxrwxr-x 1 zimbra zimbra 10057 Jan 26 11:56 converter
    -r-xr-xr-x 1 zimbra zimbra  3533 Jan 26 11:56 downgrade_v1
    -r-xr-xr-x 1 zimbra zimbra  3187 Jan 26 11:56 upgrade_v2
    There is an important update to 5.0.13 (which you've probably seen), I'd suggest an upgrade to that version and see if the directory exists after that.

    When did you actually do the upgrade from OS to NE (which release of Zimbra)?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    In_The_Ville is offline Special Member
    Join Date
    Apr 2008
    Location
    Catonsville MD
    Posts
    101
    Rep Power
    7

    Default

    I think I am missing something:

    Code:
    zimbra@mail:~$ ls -l /opt/zimbra/convertd/
    total 20
    drwxr-x--- 2 zimbra zimbra 4096 Sep 25 14:03 cnvcache
    drwxr-x--- 2 zimbra zimbra 4096 Aug 28 22:45 crash
    drwxr-x--- 2 zimbra zimbra 4096 Feb 14 13:04 inprocessing
    drwxr-x--- 2 zimbra zimbra 4096 May 24  2008 suspect
    drwxr-x--- 2 zimbra zimbra 4096 May 24  2008 tmp
    I did the conversion from FOSS to NE about 10 months ago, and I am doing the upgrade to 5.0.13 tonight. Users have to be off by 8 PM

  9. #9
    In_The_Ville is offline Special Member
    Join Date
    Apr 2008
    Location
    Catonsville MD
    Posts
    101
    Rep Power
    7

    Default

    Ran the upgrade to 5.0.13 and everything works like a charm.

    Thanks for all the help.

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Glad you've got it fixed.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. briefcase - download not working
    By zimbrero in forum Installation
    Replies: 2
    Last Post: 03-13-2009, 12:35 AM
  2. Replies: 8
    Last Post: 09-18-2008, 05:51 PM
  3. cannot download any attachment
    By kowell in forum Developers
    Replies: 2
    Last Post: 06-06-2006, 08:04 AM
  4. Replies: 3
    Last Post: 05-12-2006, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •