Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: initializing ldap...FAILED(256)ERROR

  1. #1
    manjunath is offline Member
    Join Date
    Apr 2006
    Posts
    13
    Rep Power
    9

    Unhappy initializing ldap...FAILED(256)ERROR

    hai everybody,

    the seaquece of steps i have done is :

    i installed FC4,then i updated it using 'yum update'.
    then i disabeld sendmail as : '/etc/init.d/sendmail stop'
    then i disabled firewall as : '/sbin/services iptables stop'
    i also got a ip address from 'no-ip.com' as
    203.193.129.103 zimpro.no-ip.info
    and my network configuration is as follows
    ip 203.193.129.103
    subnetmask 255.255.255.224
    default gateway 203.193.129.103
    primary DNS 165.21.83.88
    and my /etc/host files looks like this :
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    203.193.129.103 zimpro.no-ip.info zimproject

    and

    [root@zimpro ~]# hostname
    zimpro.no-ip.info
    [root@zimpro ~]# domainname
    (none)

    then i started installing zimbra n/w edition as follows :

    [root@zimpro ~]# cd ..
    [root@zimpro /]# cd home/manjunath
    [root@zimpro manjunath]# cd zcs-NETWORK-3.0.1_GA_160.RHEL4.tgz_FILES/zcs
    [root@zimpro zcs]# ./install.sh

    Operations logged to /tmp/install.log.6346
    Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-3.0.1_GA_160
    zimbra-logger...FOUND zimbra-logger-3.0.1_GA_160
    zimbra-mta...FOUND zimbra-mta-3.0.1_GA_160
    zimbra-snmp...FOUND zimbra-snmp-3.0.1_GA_160
    zimbra-store...FOUND zimbra-store-3.0.1_GA_160
    zimbra-apache...FOUND zimbra-apache-3.0.1_GA_160
    zimbra-spell...FOUND zimbra-spell-3.0.1_GA_160
    zimbra-core...FOUND zimbra-core-3.0.1_GA_160

    Saving existing configuration file to /opt/zimbra/.saveconfig


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/zimbra...cense_1.0.html


    Press Return to continue

    Checking for prerequisites...
    NPTL...FOUND
    sudo...FOUND sudo-1.6.8p8-2.4
    libidn...FOUND libidn-0.5.15-1
    curl...FOUND curl-7.13.1-5
    fetchmail...FOUND fetchmail-6.2.5.5-1
    gmp...FOUND gmp-4.1.4-6
    /usr/lib/libstdc++.so.5...FOUND

    Checking for installable packages

    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell


    The Zimbra Collaboration Suite appears already to be installed.
    It can be upgraded with no effect on existing accounts,
    or the current installation can be completely removed prior
    to installation for a clean install.

    Do you wish to upgrade? [Y] n

    *** WARNING - you are about to delete all existing users and mail

    Delete users/mail? [N] y

    Select the packages to install

    Install zimbra-ldap [Y] \


    Install zimbra-logger [Y]

    Install zimbra-mta [Y]

    Install zimbra-snmp [Y]

    Install zimbra-store [Y]

    Install zimbra-spell [Y]

    Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell

    The system will be modified. Continue? [N] y

    Shutting down zimbra mail

    Removing existing packages

    zimbra-ldap...done
    zimbra-logger...done
    zimbra-mta...done
    zimbra-snmp...done
    zimbra-store...done
    zimbra-spell...done
    zimbra-apache...done
    zimbra-core...done

    Removing deployed webapp directories

    Removing /opt/zimbra
    Installing packages

    zimbra-core......zimbra-core-3.0.1_GA_160.RHEL4-20060216140433.i386.rpm...done
    zimbra-ldap......zimbra-ldap-3.0.1_GA_160.RHEL4-20060216140433.i386.rpm...done
    zimbra-logger......zimbra-logger-3.0.1_GA_160.RHEL4-20060216140433.i386.rpm...done
    zimbra-mta......zimbra-mta-3.0.1_GA_160.RHEL4-20060216140433.i386.rpm...done
    zimbra-snmp......zimbra-snmp-3.0.1_GA_160.RHEL4-20060216140433.i386.rpm...done
    zimbra-store......zimbra-store-3.0.1_GA_160.RHEL4-20060216140433.i386.rpm...done
    zimbra-apache......zimbra-apache-3.0.1_GA_160.RHEL4-20060216140433.i386.rpm...done
    zimbra-spell......zimbra-spell-3.0.1_GA_160.RHEL4-20060216140433.i386.rpm...done
    Operations logged to /tmp/zmsetup.log.7762
    Setting defaults...No results returned for MX lookup of zimpro.no-ip.info
    Checked nameservers:
    165.21.83.88


    DNS ERROR resolving MX for zimpro.no-ip.info
    It is suggested that the domain name have an MX record configured in DNS
    Change domain name? [Yes] y
    Create Domain: [zimpro.no-ip.info] .no-ip.info
    Done
    Checking for port conflicts

    Main menu

    1) Hostname: zimpro.no-ip.info
    2) Ldap master host: zimpro.no-ip.info
    3) Ldap port: 389
    4) Ldap password: set
    5) zimbra-ldap: Enabled
    6) zimbra-store: Enabled
    +Create Admin User: yes
    +Admin user to create: admin@.no-ip.info
    ******* +Admin Password UNSET
    +SMTP host: zimpro.no-ip.info
    +Web server HTTP port: 80
    +Web server HTTPS port: 443
    +Web server mode: http
    +IMAP server port: 143
    +IMAP server SSL port: 993
    +POP server port: 110
    +POP server SSL port: 995
    +Use spell check server: yes
    +Spell server URL: http://zimpro.no-ip.info:7780/aspell.php

    7) zimbra-mta: Enabled
    8) zimbra-snmp: Enabled
    9) zimbra-logger: Enabled
    10) zimbra-spell: Enabled
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    Address unconfigured (**) items (? - help) 6


    Store configuration

    1) Status: Enabled
    2) Create Admin User: yes
    3) Admin user to create: admin@.no-ip.info
    ** 4) Admin Password UNSET
    5) SMTP host: zimpro.no-ip.info
    6) Web server HTTP port: 80
    7) Web server HTTPS port: 443
    8) Web server mode: http
    9) IMAP server port: 143
    10) IMAP server SSL port: 993
    11) POP server port: 110
    12) POP server SSL port: 995
    13) Use spell check server: yes
    14) Spell server URL: http://zimpro.no-ip.info:7780/aspell.php

    Select, or 'r' for previous menu [r] 4

    Password for admin@.no-ip.info (min 6 characters): [ON1o6ULW] manju504

    Store configuration

    1) Status: Enabled
    2) Create Admin User: yes
    3) Admin user to create: admin@.no-ip.info
    4) Admin Password set
    5) SMTP host: zimpro.no-ip.info
    6) Web server HTTP port: 80
    7) Web server HTTPS port: 443
    8) Web server mode: http
    9) IMAP server port: 143
    10) IMAP server SSL port: 993
    11) POP server port: 110
    12) POP server SSL port: 995
    13) Use spell check server: yes
    14) Spell server URL: http://zimpro.no-ip.info:7780/aspell.php

    Select, or 'r' for previous menu [r] r

    Main menu

    1) Hostname: zimpro.no-ip.info
    2) Ldap master host: zimpro.no-ip.info
    3) Ldap port: 389
    4) Ldap password: set
    5) zimbra-ldap: Enabled
    6) zimbra-store: Enabled
    7) zimbra-mta: Enabled
    8) zimbra-snmp: Enabled
    9) zimbra-logger: Enabled
    10) zimbra-spell: Enabled
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) x


    Main menu

    1) Hostname: zimpro.no-ip.info
    2) Ldap master host: zimpro.no-ip.info
    3) Ldap port: 389
    4) Ldap password: set
    5) zimbra-ldap: Enabled
    +Create Domain: yes
    +Domain to create: .no-ip.info
    +Enable automated spam training: yes
    +Spam training user: jare1yefi@.no-ip.info
    +Non-spam(Ham) training user: 5z2eiwj5t@.no-ip.info

    6) zimbra-store: Enabled
    +Create Admin User: yes
    +Admin user to create: admin@.no-ip.info
    +Admin Password set
    +SMTP host: zimpro.no-ip.info
    +Web server HTTP port: 80
    +Web server HTTPS port: 443
    +Web server mode: http
    +IMAP server port: 143
    +IMAP server SSL port: 993
    +POP server port: 110
    +POP server SSL port: 995
    +Use spell check server: yes
    +Spell server URL: http://zimpro.no-ip.info:7780/aspell.php

    7) zimbra-mta: Enabled
    +MTA Auth host: zimpro.no-ip.info
    +Enable Spamassassin: yes
    +Enable Clam AV: yes
    +Notification address for AV alerts: admin@.no-ip.info

    8) zimbra-snmp: Enabled
    +Enable SNMP notifications: yes
    +SNMP Trap hostname: zimpro.no-ip.info
    +Enable SMTP notifications: yes
    +SMTP Source email address: admin@.no-ip.info
    +SMTP Destination email address: admin@.no-ip.info

    9) zimbra-logger: Enabled
    10) zimbra-spell: Enabled

    c) Collapse menu
    r) Start servers after configuration yes
    s) Save config to file
    q) Quit

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.7762]
    Saving config in /opt/zimbra/config.7762...Done
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.log.7762
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...FAILED (256)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration[root@zimpro zcs]#

    then my problem is why do i get that 'initializing ldap...FAILED(256) ERROR' ?
    and also i know that my zimbra installation is not commpled. is it correct?

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Have you had a failed install before?

    If so, I would run ./install.sh -u

    and uninstall it totally, and then reinstall.

    Do you know if you have SELinux installed?

  3. #3
    manjunath is offline Member
    Join Date
    Apr 2006
    Posts
    13
    Rep Power
    9

    Unhappy

    thanks

    Have you had a failed install before?

    yes i had a failed install befor.

    and now i unistalled zimbra and reinstalled but i am getting the same error as :

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.7334]
    Saving config in /opt/zimbra/config.7334...Done
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.log.7334
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...FAILED (256)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration[root@zimpro zcs]#

    remember u one thing i have updated my FC4, is there any version confilct for ldap?

    if not, then what is the problem?

  4. #4
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Post

    >then i disabeld sendmail as : '/etc/init.d/sendmail stop'

    [root@zimpro ~]# hostname
    >zimpro.no-ip.info
    it looks like you've left out some steps.

    #keep sendmail from starting after reboot:
    chkconfig sendmail off

    #check dns for hostname:
    host zimpro.no-ip.info

    you probably also won't get very far with a zero-length subdomain:
    >+Domain to create: .no-ip.info

  5. #5
    manjunath is offline Member
    Join Date
    Apr 2006
    Posts
    13
    Rep Power
    9

    Unhappy

    thanks

    [root@zimpro ~]# chkconfig sendmail off
    [root@zimpro ~]# host zimpro.no-ip.info
    zimpro.no-ip.info has address 203.193.129.103


    then what should i do now?

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Try to install again.

    If you want to see if LDAP is running prior to install, you can
    >ps auxww | grep slapd

    or
    >telnet localhost 389

    If both return null values, then you're good.

  7. #7
    manjunath is offline Member
    Join Date
    Apr 2006
    Posts
    13
    Rep Power
    9

    Unhappy

    thanks

    i done as u said, and it repledy me as shown :

    [root@zimpro ~]# ps auxww | grep slapd
    root 2951 0.0 0.0 3760 700 pts/1 S+ 23:46 0:00 grep slapd

    it is not returnign null, so what can i do now?

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    You should kill any zimbra services that are running and then do the uninstall/reinstall again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    manjunath is offline Member
    Join Date
    Apr 2006
    Posts
    13
    Rep Power
    9

    Unhappy

    thanks,

    i will be very thank full if u tell some commands that kills zimbra servies?

  10. #10
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    >i will be very thank full if u tell some commands that kills zimbra servies?

    ps ax | grep zimbra
    man kill

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  3. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 03:39 PM
  4. Replies: 4
    Last Post: 11-15-2006, 12:16 PM
  5. Initializing ldap...FAILED (512)?
    By eger in forum Installation
    Replies: 9
    Last Post: 02-24-2006, 12:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •