Page 4 of 4 FirstFirst ... 234
Results 31 to 40 of 40

Thread: initializing ldap...FAILED(256)ERROR

  1. #31
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    When you say you 'renamed it to....', do you mean you renamed the server itself, did you rename the server name in Zimbra or did you do both? Just changing the name of the server will cause you problems.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #32
    zagman76 is offline Active Member
    Join Date
    Aug 2006
    Posts
    49
    Rep Power
    8

    Default

    Quote Originally Posted by phoenix
    When you say you 'renamed it to....', do you mean you renamed the server itself, did you rename the server name in Zimbra or did you do both? Just changing the name of the server will cause you problems.
    we had renamed the server itself, but un/re-installed zimbra and it was ok. Actually, it seemed to be a DNS issue because once we re-named the Zimbra server to a completely different name, and added the proper DNS entries, it worked just fine!

  3. #33
    tirili is offline New Member
    Join Date
    Oct 2006
    Posts
    4
    Rep Power
    8

    Default LDAP errors continue...

    Hello,

    I have zimbra in a private subnet behind a firewall. How should the DNS settings be ?

    zimbra.internal.dom A 192.168.1.25
    zimbra.external.com A 195.226.126.136
    external.com MX 10 zimbra.external.com

    There is a NAT from zimbra.external.com:25 to zimbra.internal.dom:25

    LDAP fails to start:

    /opt/zimbra/openldap-2.3.21/libexec/slapd -u zimbra -h ldap://zimbra.internal.dom:389 -f /opt/zimbra/conf/slapd.conf -d 127

    slapd startup: initiated.
    backend_startup_one: starting "cn=config"
    config_back_db_open
    config_build_entry: "cn=config"
    config_build_entry: "cn=include{0}"
    config_build_entry: "cn=include{1}"
    config_build_entry: "cn=include{2}"
    config_build_entry: "cn=include{3}"
    config_build_entry: "cn=include{4}"
    config_build_entry: "cn=include{5}"
    config_build_entry: "cn=include{0}"
    config_build_entry: "cn=schema"
    config_build_entry: "cn={0}core"
    config_build_entry: "cn={1}cosine"
    config_build_entry: "cn={2}inetorgperson"
    config_build_entry: "cn={3}amavisd"
    config_build_entry: "cn={4}zimbra"
    config_build_entry: "cn={5}zimbra-ext"
    config_build_entry: "cn={5}zimbra-hsm"
    config_build_entry: "olcDatabase={-1}frontend"
    config_build_entry: "olcDatabase={0}config"
    config_build_entry: "olcDatabase={1}bdb"
    backend_startup_one: starting ""
    bdb_db_open:
    bdb_db_open: dbenv_open(/opt/zimbra/openldap-data)
    bdb(): unable to initialize mutex: Function not implemented
    bdb(): /opt/zimbra/openldap-data/__db.001: unable to initialize environment lock: Function not implemented
    bdb_db_open: Database cannot be opened, err 38. Restore from backup!
    ====> bdb_cache_release_all
    bdb(): DB_ENV->lock_id_free interface requires an environment configured for the locking subsystem
    bdb(): txn_checkpoint interface requires an environment configured for the transaction subsystem
    bdb_db_close: txn_checkpoint failed: Invalid argument (22)
    backend_startup_one: bi_db_open failed! (38)
    slapd shutdown: initiated
    ====> bdb_cache_release_all
    bdb_db_close: alock_close failed
    slapd destroy: freeing system resources.
    slapd stopped.
    connections_destroy: nothing to destroy.

    Any ideas where to look further ?

    Thanks for your reply!

  4. #34
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by tirili
    Hello,

    I have zimbra in a private subnet behind a firewall. How should the DNS settings be ?

    zimbra.internal.dom A 192.168.1.25
    zimbra.external.com A 195.226.126.136
    external.com MX 10 zimbra.external.com

    There is a NAT from zimbra.external.com:25 to zimbra.internal.dom:25

    LDAP fails to start:
    You really should have started a new thread with this, posts tend to get lost in a thread this long.

    Have a look at the thread entitled 'DNS ina nutshell' for the DNS setup and make sure your /etc/hosts file is set correctly, it's detailed in the Quick Start Guide.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #35
    DGS_David is offline Intermediate Member
    Join Date
    Aug 2006
    Location
    Somerset, UK
    Posts
    22
    Rep Power
    8

    Default

    I am just messing with a VMWare instance trying to debug another issue when my install failed on the ldap 256 error. I solved it by adding the /etc/hosts entry which the instal docs do mention but I forgot whilst building the test instance...

    /etc/hosts

    176.0.0.1 localhost.localdomain
    nnn.nnn.nnn.nnn mail.domainname.co.uk

    (where nn.. is your ip as defined by ifconfig)

    where /etc/sysconfig/network reads:

    HOSTNAME=mail.domainname.co.uk

    HTH's someone.
    David.

  6. #36
    xcoi is offline Active Member
    Join Date
    Nov 2007
    Posts
    28
    Rep Power
    7

    Default Initializing ldap...sed: can't read /opt/zimbra/openldap/etc/openldap/slapd.conf: Per

    The same problem!!!

    ------------------------------------
    root@zcs:/usr/src/zcs# ./install.sh

    Operations logged to /tmp/install.log.10692
    Checking for existing installation...
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-core...NOT FOUND


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/collab...cense_1.0.html


    Press Return to continue

    Checking for prerequisites...
    NPTL...FOUND
    sudo...FOUND sudo-1.6.8p12-5ubuntu2
    libidn11...FOUND libidn11-1.0-0
    curl...FOUND curl-7.16.4-2ubuntu1
    fetchmail...FOUND fetchmail-6.3.8-8ubuntu2
    libpcre3...FOUND libpcre3-7.4-0ubuntu0.7.10.2
    libgmp3c2...FOUND libgmp3c2-2:4.2.1+dfsg-5ubuntu4
    libexpat1...FOUND libexpat1-1.95.8-4ubuntu1
    libxml2...FOUND libxml2-2.6.30.dfsg-2ubuntu1.1
    libstdc++6...FOUND libstdc++6-4.2.1-5ubuntu4
    libstdc++5...FOUND libstdc++5-1:3.3.6-15ubuntu2
    openssl...FOUND openssl-0.9.8e-5ubuntu3.2

    Checking for installable packages

    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell


    Select the packages to install

    Install zimbra-ldap [Y]

    Install zimbra-logger [Y]

    Install zimbra-mta [Y]

    Install zimbra-snmp [Y]

    Install zimbra-store [Y]

    Install zimbra-spell [Y]
    Checking required space for zimbra-core
    checking space for zimbra-store

    Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell

    The system will be modified. Continue? [N] y

    Removing /opt/zimbra
    Installing packages

    zimbra-core......zimbra-core_4.5.7_GA_1319.UBUNTU6_i386.deb...done
    zimbra-ldap......zimbra-ldap_4.5.7_GA_1319.UBUNTU6_i386.deb...done
    zimbra-logger......zimbra-logger_4.5.7_GA_1319.UBUNTU6_i386.deb...done
    zimbra-mta......zimbra-mta_4.5.7_GA_1319.UBUNTU6_i386.deb...done
    zimbra-snmp......zimbra-snmp_4.5.7_GA_1319.UBUNTU6_i386.deb...done
    zimbra-store......zimbra-store_4.5.7_GA_1319.UBUNTU6_i386.deb...done
    zimbra-apache......zimbra-apache_4.5.7_GA_1319.UBUNTU6_i386.deb...done
    zimbra-spell......zimbra-spell_4.5.7_GA_1319.UBUNTU6_i386.deb...done
    Operations logged to /tmp/zmsetup.log.12073
    Setting defaults... MX: mail.zcs.com.vn (192.168.3.8)

    Interface: 192.168.3.8
    Interface: 127.0.0.1
    192.168.3.8
    Done
    Checking for port conflicts

    Main menu

    1) Hostname: zcs.com.vn
    2) Ldap master host: zcs.com.vn
    3) Ldap port: 389
    4) Ldap password: set
    5) TimeZone: (GMT-08.00) Pacific Time (US & Canada)
    6) zimbra-ldap: Enabled
    7) zimbra-store: Enabled
    +Create Admin User: yes
    +Admin user to create: admin@zcs.com.vn
    ******* +Admin Password UNSET
    +Enable automated spam training: yes
    +Spam training user: spam.50hw0qn66k@zcs.com.vn
    +Non-spam(Ham) training user: ham.zbwhkuh0@zcs.com.vn
    +Global Documents Account: wiki@zcs.com.vn
    +SMTP host: zcs.com.vn
    +Web server HTTP port: 80
    +Web server HTTPS port: 443
    +Web server mode: http
    +Enable POP/IMAP proxy: no
    +IMAP server port: 143
    +IMAP server SSL port: 993
    +POP server port: 110
    +POP server SSL port: 995
    +Use spell check server: yes
    +Spell server URL: http://zcs.com.vn:7780/aspell.php

    8) zimbra-mta: Enabled
    9) zimbra-snmp: Enabled
    10) zimbra-logger: Enabled
    11) zimbra-spell: Enabled
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    Address unconfigured (**) items (? - help) 7


    Store configuration

    1) Status: Enabled
    2) Create Admin User: yes
    3) Admin user to create: admin@zcs.com.vn
    ** 4) Admin Password UNSET
    5) Enable automated spam training: yes
    6) Spam training user: spam.50hw0qn66k@zcs.com.vn
    7) Non-spam(Ham) training user: ham.zbwhkuh0@zcs.com.vn
    8) Global Documents Account: wiki@zcs.com.vn
    9) SMTP host: zcs.com.vn
    10) Web server HTTP port: 80
    11) Web server HTTPS port: 443
    12) Web server mode: http
    13) Enable POP/IMAP proxy: no
    14) IMAP server port: 143
    15) IMAP server SSL port: 993
    16) POP server port: 110
    17) POP server SSL port: 995
    18) Use spell check server: yes
    19) Spell server URL: http://zcs.com.vn:7780/aspell.php

    Select, or 'r' for previous menu [r] 4

    Password for admin@zcs.com.vn (min 6 characters): [hdQCNh82g] clrscr

    Store configuration

    1) Status: Enabled
    2) Create Admin User: yes
    3) Admin user to create: admin@zcs.com.vn
    4) Admin Password set
    5) Enable automated spam training: yes
    6) Spam training user: spam.50hw0qn66k@zcs.com.vn
    7) Non-spam(Ham) training user: ham.zbwhkuh0@zcs.com.vn
    8) Global Documents Account: wiki@zcs.com.vn
    9) SMTP host: zcs.com.vn
    10) Web server HTTP port: 80
    11) Web server HTTPS port: 443
    12) Web server mode: http
    13) Enable POP/IMAP proxy: no
    14) IMAP server port: 143
    15) IMAP server SSL port: 993
    16) POP server port: 110
    17) POP server SSL port: 995
    18) Use spell check server: yes
    19) Spell server URL: http://zcs.com.vn:7780/aspell.php

    Select, or 'r' for previous menu [r] r

    Main menu

    1) Hostname: zcs.com.vn
    2) Ldap master host: zcs.com.vn
    3) Ldap port: 389
    4) Ldap password: set
    5) TimeZone: (GMT-08.00) Pacific Time (US & Canada)
    6) zimbra-ldap: Enabled
    7) zimbra-store: Enabled
    8) zimbra-mta: Enabled
    9) zimbra-snmp: Enabled
    10) zimbra-logger: Enabled
    11) zimbra-spell: Enabled
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.12073]
    Saving config in /opt/zimbra/config.12073...Done
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.log.12073
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...sed: can't read /opt/zimbra/openldap/etc/openldap/slapd.conf: Permission denied
    Failed to start slapd. Attempting debug start to determine error.
    daemon: bind(7) failed errno=98 (Address already in use)
    slap_open_listener: failed on ldap://zcs.com.vn:389

    FAILED (1)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.

    Errors have been logged to /tmp/zmsetup.log.12073

    ------------------------------------


    Please help me to overcome this problem!

  7. #37
    neverfeedback is offline New Member
    Join Date
    May 2008
    Posts
    4
    Rep Power
    6

    Default

    I using Zimbra Collaboration Suite 5.0 and Vmware. The same that problem. Pls help me

  8. #38
    neverfeedback is offline New Member
    Join Date
    May 2008
    Posts
    4
    Rep Power
    6

    Default Successs.....

    Quote Originally Posted by neverfeedback View Post
    I using Zimbra Collaboration Suite 5.0 and Vmware. The same that problem. Pls help me
    I Found this problem...
    change hots file /etc/host -> localhost localhost.localdomain to 127.0.0.1 localhost.localdomain

    Thanks all.

  9. #39
    raghunr4u is offline Starter Member
    Join Date
    Dec 2008
    Posts
    2
    Rep Power
    6

    Default U have did mistake

    when U have Creating domain name dont give [.domain name] give just domainname
    it will work fine
    regards
    Raghunatha Reddy

  10. #40
    dent_a is offline New Member
    Join Date
    Sep 2008
    Posts
    3
    Rep Power
    6

    Default

    I had this issue with a clean install of the 8.0.4 Community Edition. The problem for me was I had modified name of the "localhost" in the "/etc/hosts" file. Make sure that "127.0.0.1" , "localhost.localdomain" , and "localhost" are in the file on one line. As well as you servers IP, FQDN, and hostname.

Page 4 of 4 FirstFirst ... 234

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  3. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 03:39 PM
  4. Replies: 4
    Last Post: 11-15-2006, 12:16 PM
  5. Initializing ldap...FAILED (512)?
    By eger in forum Installation
    Replies: 9
    Last Post: 02-24-2006, 12:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •