Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: sudo....missing error when installing

  1. #11
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    Can you check the permissions on the /etc/sudoers file with
    Code:
    ls -l /etc/sudoers
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #12
    AndreKuhn is offline Junior Member
    Join Date
    Nov 2006
    Posts
    6
    Rep Power
    8

    Default

    Well, I did (!) set PATH.

    ---> # echo $PATH
    /sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/usr/X11R6
    /bin:/bin:/usr/games:/opt/gnome/bin:/usr/local/bin:/usr/local/sbin:/usr/ccs/bin


    and

    ---> which sudo
    /usr/local/bin/sudo


    Must be something else...
    Last edited by AndreKuhn; 12-06-2006 at 09:50 AM.

  3. #13
    AndreKuhn is offline Junior Member
    Join Date
    Nov 2006
    Posts
    6
    Rep Power
    8

    Default

    I slowly increased permissions on /etc/sudoers. Finally up to:

    ---> ls -l /etc/sudoers
    -rwxrwxrwx 1 root root 608 Dec 6 14:00 /etc/sudoers


    Yet, I receive:

    Checking for prerequisites...
    NPTL...FOUND
    sudo...MISSING


    By the way, regarding the PATH. I set it in profile. A re-login confirmed that it's a persistent setting.

  4. #14
    rsharpe is offline Elite Member & Volunteer
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    9

    Default

    I read through the install script and Zimbra checks for the package by looking at the RPM database or the dpkg database. So if you built it from source you may have to forceably add it to the one of the databases.

  5. #15
    AndreKuhn is offline Junior Member
    Join Date
    Nov 2006
    Posts
    6
    Rep Power
    8

    Default

    Good point. Seems like the install script needs an update.
    Now I ran across several sudo rpm packages. Each of them being older than my manually compiled and installed one, but ok. Now there seems to be a conflict between my now-installed one and the new rpm-formed sudo. I can't install using rpm now:

    ---> rpm -ivh sudo-1.6.8p7-3.i586.rpm
    error: sudo-1.6.8p7-3.i586.rpm: V3 DSA signature: BAD, key ID 9c800aca
    error: sudo-1.6.8p7-3.i586.rpm cannot be installed


    and

    ---> rpm -ihv sudo-1.6.8p7-3.x86_64.rpm
    error: sudo-1.6.8p7-3.x86_64.rpm cannot be installed


    I very welcome your engagement. Thanks a lot...

    And I honestly try to refrain from conniption, so forgive me my: Boy this stuff is complicated...
    Last edited by AndreKuhn; 12-06-2006 at 11:32 AM.

  6. #16
    AndreKuhn is offline Junior Member
    Join Date
    Nov 2006
    Posts
    6
    Rep Power
    8

    Default

    Ok, it works. Many, many thanks to all of you guys!

    I deleted the sudo folders generated by 'make' and re-did rpm. Every prerequisite is positively checked now.

    Huge thank you and 'till next time I encounter zimbra awkwards, means in 6 hours

    Cheers

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Xen Debian Etch libgmp3...MISSING libxml2...MISSING
    By unclecameron in forum Installation
    Replies: 6
    Last Post: 07-29-2008, 12:37 PM
  2. Refusing all the prerequisites in installing Zimbra.
    By rudchris in forum Installation
    Replies: 20
    Last Post: 05-18-2007, 01:31 AM
  3. Missing blobs - from id to file location?
    By stateless in forum Administrators
    Replies: 1
    Last Post: 04-23-2007, 06:15 PM
  4. Traslation SVN tree status
    By meikka in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 02-13-2007, 11:13 AM
  5. Missing Prerequisites on Debian
    By WD_40 in forum Installation
    Replies: 2
    Last Post: 01-16-2007, 09:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •