Page 1 of 5 123 ... LastLast
Results 1 to 10 of 41

Thread: Unable to install

  1. #1
    h3llh0l3 is offline Intermediate Member
    Join Date
    Dec 2008
    Posts
    21
    Rep Power
    6

    Default Unable to install

    Hello all,

    I had earlier installed ZCS on Ubuntu 8.04 LTS with no trouble. I have now install Debian and when I try to install ZCS it gives the following error:
    ERROR: Installation can not proceeed. Please fix your /etc/hosts file
    to contain:



    Where is the ip address of the host,
    is the FULLY QUALIFIED host name, and
    is the (optional) hostname-only portion
    I have checked my /etc/hosts and it seems correct to me. Anyways here is my /etc/hosts:
    cat /etc/hosts
    # The following lines are desirable for IPv6 capable hosts
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    210.211.190.77 virix.co.cc virix
    192.168.1.20 virix.co.cc virix #IP of the machine on LAN
    127.0.0.1 localhost.localdomain localhost
    Am I missing anything?
    Thanks.

  2. #2
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    you can't have two entries for the same hostname. remove the external entry. unless you're actually using ipv6, remove those entries too.

  3. #3
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Welcome to the forums

    I see you have both a public and private IP in your /etc/hosts! If you are behind a firewall and using a private IP you will need to setup a Wiki :: Split DNS architecture. And setup your /etc/hosts as follows
    Code:
    # The following lines are desirable for IPv6 capable hosts
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    127.0.0.1 localhost.localdomain localhost 
    192.168.1.20 virix.co.cc virix #IP of the machine on LAN

  4. #4
    h3llh0l3 is offline Intermediate Member
    Join Date
    Dec 2008
    Posts
    21
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    Welcome to the forums

    I see you have both a public and private IP in your /etc/hosts! If you are behind a firewall and using a private IP you will need to setup a Wiki :: Split DNS architecture. And setup your /etc/hosts as follows
    Code:
    # The following lines are desirable for IPv6 capable hosts
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    127.0.0.1 localhost.localdomain localhost 
    192.168.1.20 virix.co.cc virix #IP of the machine on LAN
    I tried that but still I get the same error when I run the install.sh. And by the way I have had my /etc/hosts the same way as in my first post on my Ubuntu and ZCS installed just fine, with no trouble.

    Thanks.

  5. #5
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Okay lets go through the basic checks then
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.name mx
    dig yourdomain.name any
    host `hostname` <- note backticks and not single quotes

  6. #6
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    try removing the # comment stuff that comes after the hostname
    try removing ipv6 stuff, in particular localhost line - you've got localhost defined twice

  7. #7
    h3llh0l3 is offline Intermediate Member
    Join Date
    Dec 2008
    Posts
    21
    Rep Power
    6

    Default

    Code:
    cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.1.20 virix.co.cc virix
    Code:
    cat /etc/resolv.conf
    nameserver 192.168.1.1
    Code:
    dig virix.co.cc MX
    
    ; <<>> DiG 9.5.0-P2 <<>> virix.co.cc MX
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 48693
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;virix.co.cc.                   IN      MX
    
    ;; ANSWER SECTION:
    virix.co.cc.            86397   IN      MX      5 mx.virix.co.cc.
    
    ;; AUTHORITY SECTION:
    virix.co.cc.            86397   IN      NS      ns3.co.cc.
    
    ;; Query time: 183 msec
    ;; SERVER: 192.168.1.1#53(192.168.1.1)
    ;; WHEN: Wed Dec 10 19:17:10 2008
    ;; MSG SIZE  rcvd: 66
    Code:
    dig virix.co.cc any
    
    ; <<>> DiG 9.5.0-P2 <<>> virix.co.cc any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42002
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;virix.co.cc.                   IN      ANY
    
    ;; ANSWER SECTION:
    virix.co.cc.            86396   IN      MX      5 mx.virix.co.cc.
    virix.co.cc.            86396   IN      A       210.211.190.77
    virix.co.cc.            86396   IN      SOA     ns.virix.co.cc. root.virix.ns.co.cc. 2008121005 28800 7200 604800 3600
    virix.co.cc.            86396   IN      NS      ns3.co.cc.
    
    ;; AUTHORITY SECTION:
    virix.co.cc.            86396   IN      NS      ns3.co.cc.
    
    ;; Query time: 267 msec
    ;; SERVER: 192.168.1.1#53(192.168.1.1)
    ;; WHEN: Wed Dec 10 19:18:02 2008
    ;; MSG SIZE  rcvd: 149
    Code:
    host `hostname`
    ;; connection timed out; no servers could be reached

  8. #8
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Yep so you need to setup the Split DNS as I mentioned above. Your resolv.conf would then contain
    Code:
    nameserver 192.168.1.20

  9. #9
    h3llh0l3 is offline Intermediate Member
    Join Date
    Dec 2008
    Posts
    21
    Rep Power
    6

    Default

    Quote Originally Posted by uxbod View Post
    Yep so you need to setup the Split DNS as I mentioned above. Your resolv.conf would then contain
    Code:
    nameserver 192.168.1.20
    But how it worked fine when I was using Ubuntu? I ask this because my resolv.conf has always been
    Code:
    nameserver 192.168.1.1
    for last 11 months. And I had not setup Split DNS when I installed ZCS on Ubuntu.

    Thanks.

    EDIT: Anyways I am going to setup the split dns now and I will post back if need help.
    Last edited by h3llh0l3; 12-10-2008 at 07:03 AM. Reason: Anyways I am going to setup the split dns now and I will post back if need help.

  10. #10
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    8

    Default Domain name

    Your hosts file and your zone file indicate two different things.

    "virix.co.cc" is showing up in your zone file as the domain. In your hosts file it is the FQDN of your computer.

    Your zone file shows "mx.virix.co.cc" should be the FQDN of your mail server. Your hosts file shows your computer is named virix and your domain is co.cc . Together thay make a FQDN. Your host file shows your domain to be "virix.co.cc". And your mail server to be "mx" (based on your MX record). "mx.virix.co.cc" is showing to be the FQDN based on your MX record.

    What is your actual domain and what is the host name of your server? Together they should be the entry in you hosts file. Your zone file on the other hand should just be the domain name. And the records inside pointing to the FQDN.
    Last edited by Bill Brock; 12-10-2008 at 07:22 AM.

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 02-23-2014, 01:08 PM
  2. Replies: 21
    Last Post: 09-27-2007, 11:49 AM
  3. Unable to install on Ubuntu 7.04 64 bit
    By geekneck in forum Installation
    Replies: 5
    Last Post: 07-16-2007, 07:52 PM
  4. Unable to install on Ubuntu 7.04 64-bit
    By geekneck in forum Installation
    Replies: 3
    Last Post: 07-14-2007, 10:15 AM
  5. Unable to install
    By bernard74 in forum Installation
    Replies: 3
    Last Post: 09-14-2006, 01:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •