Results 1 to 6 of 6

Thread: [SOLVED] upgrade failing because of /etc/hosts?

  1. #1
    Phloyd is offline Active Member
    Join Date
    Sep 2008
    Posts
    31
    Rep Power
    6

    Default [SOLVED] upgrade failing because of /etc/hosts?

    This doesn't make much sense. Here is my /etc/hosts file:


    I have tried removing the comment lines and playing around with the spacing of the individual entries, but I continue to get this message whenever I run the upgrade script:

    ERROR: Installation can not proceeed. Please fix your /etc/hosts file
    to contain:



    Where is the ip address of the host,
    is the FULLY QUALIFIED host name, and
    is the (optional) hostname-only portion

    This message is being thrown due to some perl in the utilfunc.sh script on lines 368-371 that I don't know how to read.
    Last edited by Phloyd; 02-27-2009 at 02:13 PM.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Post the output of the following (run on the zombra server):

    Code:
    host `hostname`  <-- backticks not single quotes
    cat /etc/resolv.conf
    dig qtrailer.com mx
    dig qtrailer.comany
    I assume you're behind a NAT router & have a Split DNS set-up?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Phloyd is offline Active Member
    Join Date
    Sep 2008
    Posts
    31
    Rep Power
    6

    Default

    Not really sure why the questions here. The script is failing due to the localhost entry.
    Last edited by Phloyd; 02-27-2009 at 02:12 PM.

  4. #4
    Phloyd is offline Active Member
    Join Date
    Sep 2008
    Posts
    31
    Rep Power
    6

    Default

    cat /etc/resolv.conf
    Last edited by Phloyd; 02-27-2009 at 02:11 PM.

  5. #5
    Phloyd is offline Active Member
    Join Date
    Sep 2008
    Posts
    31
    Rep Power
    6

    Default

    The error message is poorly written.
    It should state that ALL entries in the /etc/hosts file need to have FQDN's.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by Phloyd View Post
    Not really sure why the questions here. The script is failing due to the localhost entry. Just can't figure out why. Server is running fine, just trying to do a simple upgrade from 5.07 to 5.011. Anyway, here are the answers to your request, but I cannot see how they would be useful to you.
    For the simple reason that I wanted to see which IP you were running the server on, you failed to mention that in your first post, and whether the other required information was correct.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgrade instructions in 5.0.10 too muddy to understand
    By johnshen in forum Installation
    Replies: 4
    Last Post: 12-06-2008, 06:19 AM
  2. Replies: 5
    Last Post: 11-09-2007, 01:59 PM
  3. Replies: 2
    Last Post: 10-04-2007, 03:20 PM
  4. Upgrade 3.0.1->4.0.2 failing
    By bsb in forum Installation
    Replies: 18
    Last Post: 10-10-2006, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •