Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: ATTN: Ubuntu 8.04 Users

  1. #1
    dwill's Avatar
    dwill is offline Special Member
    Join Date
    Aug 2006
    Posts
    122
    Rep Power
    8

    Default ATTN: Ubuntu 8.04 Users

    I've read a few posts now about DNS issues and Ubuntu 8.04 as well as experienced my own problems:

    [SOLVED] 32bit to 64bit migration

    For me the problem appears as a strange "localhost" resolution error
    After three nights of trial and error I believe the problem to be the Multicast DNS discovery service.
    Specifically, the order of precedence in the /etc/nsswitch.conf if MDNS is enabled
    in Ubuntu 6.06 the hosts line is:
    Code:
    hosts:          files dns mdns
    in Ubuntu 8.04 the hosts line is:
    Code:
    hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
    What I have read point to changing the hosts line to match that of Ubuntu 6.06


    does anyone have the ability to test my theory before I spend another 6 hours trying my migration to 8.04 again this evening
    Work
    8.0.3 UBUNTU10_04 UBUNTU10_04 NETWORK

    Home
    8.0.3 UBUNTU10_04 UBUNTU10_04 FOSS

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    It would appear from reading a few search links that what you've found is causing the problem. The simplest fix would be to revert the nsswitch.conf file to the same entries as 6.06, I don't know when that change was made but it does seem to be causing a lot of problems.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,292
    Rep Power
    13

    Default

    Here's a JeOS (based on 8.04 LTS) nsswitch.conf file (server is used for Zimbra OSE in a VM):
    Code:
    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.
    
    passwd:         compat
    group:          compat
    shadow:         compat
    
    hosts:          files dns
    networks:       files
    
    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files
    
    netgroup:       nis
    And here's an Ubuntu 8.04 LTS 64 bits one (server is the VM host):
    Code:
    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.
    
    passwd:         compat
    group:          compat
    shadow:         compat
    
    hosts:          files dns
    networks:       files
    
    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files
    
    netgroup:       nis
    Both servers were setup in the minimal way (no graphical interface, no LAMP, etc).

    The difference with your server seems to be, as you suggested, mDNS/ZeroConf/Bonjour (that is not enabled on my servers as it's not needed).

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Yes, that is what's causing the problem. Changing the nsswitch.conf back to the non-mDNS/ZeroConf/Bonjour settings fixes the problem as per this thread.

    Could somebody file a bug report on this problem, please.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    dwill's Avatar
    dwill is offline Special Member
    Join Date
    Aug 2006
    Posts
    122
    Rep Power
    8

    Default Not sure it's a bona fide bug

    There is a bug report filed against Ubuntu. I think it should just be 'noted' for Ubuntu 8.04 server users. It's not Zimbra's problem, though ti does cause problems for Zimbra

    I'm testing my migration right now - after the above changes.
    Work
    8.0.3 UBUNTU10_04 UBUNTU10_04 NETWORK

    Home
    8.0.3 UBUNTU10_04 UBUNTU10_04 FOSS

  6. #6
    dwmtractor's Avatar
    dwmtractor is offline Moderator
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    9

    Default

    For those who either (a) need an overview of installation on 8.04 or (b) would like to help refine the instructions (which I have NOT validated on 64-bit), have a look at this new wiki on installation in Ubuntu 8.04:

    Ubuntu 8.04 LTS Server (Hardy Heron) Install Guide - Zimbra :: Wiki
    Cheers,

    Dan

  7. #7
    kevindods is offline Advanced Member
    Join Date
    Oct 2005
    Posts
    181
    Rep Power
    9

    Default https/SSL webclient problem on 8.04

    We had some problems with SSL on the web client. Certificate (commercial) worked fine on the admin console but not in the web client login screen. Got standard Firefox errors about unable to connect. Seems also that with 5.0.11 on Hardy the log file locations are different to the old days, so could not find the Tomcat logs!

    Anyhow seems that the standard install didnt configure to allow SSL but thanks to your Hardy wiki entry, minds were cast back to requiring the
    zmtlsctl https
    or
    zmtlsctl mixed
    and that seemed to work fine. Just seemed odd mixed wasnt at least configured as a default during the install.

    Kevin

  8. #8
    dwmtractor's Avatar
    dwmtractor is offline Moderator
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    9

    Default

    Quote Originally Posted by kevindods View Post
    Seems also that with 5.0.11 on Hardy the log file locations are different to the old days, so could not find the Tomcat logs!
    That's because Zimbra uses Jetty instead of Tomcat now.
    Quote Originally Posted by kevindods View Post
    Just seemed odd mixed wasnt at least configured as a default during the install.
    I agree that's odd. You could file an enhancement bug to ask that mixed be the default config if you care enough. It's no dealbreaker for me because I remember it has to be done and I just do it, but it certainly seems to me to be a reasonable suggestion.
    Cheers,

    Dan

  9. #9
    kevindods is offline Advanced Member
    Join Date
    Oct 2005
    Posts
    181
    Rep Power
    9

    Default Duhh

    Jetty - strange how I knew that and didn't connect it before posting - too much mulled wine too early!

    SSL - Mixed mode I think could be a fair default. It may be shown somewhere there is noted a reason why it isn't already so but it's worth suggesting.

    Thanks!

  10. #10
    ScottChapman is offline Special Member
    Join Date
    May 2008
    Posts
    118
    Rep Power
    6

    Default

    I am following the instructions in the Wiki.

    I modified the named.conf.options file and the resolve.conf

    restarted bind9

    But I cannot resolve names. ping google.com doesn't resolve.

    I know I put my router in as the forwarder (which is what all my machines on my home network use), and put the private IP address of my box in as the nameserver (the private IP is the IP my machine is known as on my local network).

    Any ideas?

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Get emails out of zimbra or get it working again?
    By kingfeanor in forum Migration
    Replies: 9
    Last Post: 11-25-2008, 01:02 AM
  2. Replies: 4
    Last Post: 08-26-2008, 12:34 PM
  3. Replies: 4
    Last Post: 08-24-2008, 05:45 AM
  4. [SOLVED] ZCS 5.0.8 on Ubuntu 8.04
    By Dominic in forum Installation
    Replies: 5
    Last Post: 07-31-2008, 09:44 PM
  5. Installing Zimbra on Ubuntu 8.04 server
    By murphyml in forum Installation
    Replies: 8
    Last Post: 06-06-2008, 02:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •