Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 40

Thread: ATTN: Ubuntu 8.04 Users

  1. #21
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Quote Originally Posted by dlader View Post
    Thank you for the reply but I still have the same problem. I can get the proper results for IPs outside of my network, but I get the same error for everything inside my network.
    Post the output of the following commands (run on the Zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com any
    dig yourdomain.mx
    host `hostname`  <-- use single quotes and type the command exactly as you see it
    
    host -v fqdn.yourdomain.com <-- use the fqdn of your Zimbra server
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #22
    dlader is offline Junior Member
    Join Date
    Mar 2009
    Posts
    5
    Rep Power
    6

    Default Soultion Found

    Thank you for your reply. I found a solution but I am not able to guarantee it will work for everyone. I logged into the server with Webmin and used the front end for Bind. From there I saw the records were not entered correctly and entered them there. After a reboot, the system worked fine. I had checked my manual entries many times but that did not seem to work but this did. Maybe it will work for others.

  3. #23
    ScottChapman is offline Special Member
    Join Date
    May 2008
    Posts
    118
    Rep Power
    7

    Default

    Can you be more specific? Iam not familiar with Webmin and the front end for bind.

  4. #24
    dlader is offline Junior Member
    Join Date
    Mar 2009
    Posts
    5
    Rep Power
    6

    Default

    Webmin is a graphical frontend for the server. It is freeware and a google search will get you the current version. Once it is loaded on the server, you will be able to control most server functions from the graphical interface. One of the options will be to control the bind server graphically, which will show you what your bind settings are and allow you to adjust them there.

  5. #25
    btdown is offline Intermediate Member
    Join Date
    Oct 2006
    Posts
    16
    Rep Power
    8

    Default

    Quote Originally Posted by dwill View Post
    I had an issue like that once, and I believe the problem was created because I made DNS changes but did not increment the serial number in the zone file, therefore DNS was not updating as it should to the rest of the world cuz it thought there was no change. What was actually happening was DNS was working of the "old" settings in the public realm, and the new settings when referencing internally.
    Could you please post an example? I do not see any type of 'serial number' in my zone file to increment.

  6. #26
    dwmtractor's Avatar
    dwmtractor is offline Moderator
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    Here is the example file db.mydomain.com from the Hardy Heron install guide. Note the line I've colored in red:
    Code:
    ;
    ; BIND data file for mydomain.com
    ;
    $TTL    604800
    @       IN      SOA     mail.mydomain.com. admin.mydomain.com. (
                             070725         ; Serial
                             604800         ; Refresh
                              86400         ; Retry
                            2419200         ; Expire
                             604800 )       ; Negative Cache TTL
    ;
    @       IN      NS      mail
            IN      MX      10 mail
            IN      A       xxx.xxx.xxx.xxx
    mail    IN      A       xxx.xxx.xxx.xxx
    Cheers,

    Dan

  7. #27
    LiMz is offline Member
    Join Date
    Jul 2009
    Posts
    11
    Rep Power
    6

    Default

    Scot...

    Post Your /etc/named.conf.options
    /etc/named.conf.local
    /etc/db.what.ever
    /etc/resolv.conf

    Put a fake servername and ip where needed
    Shot

  8. #28
    just_me is offline Junior Member
    Join Date
    Jul 2009
    Posts
    8
    Rep Power
    6

    Default

    Hi there, i am totally stuck.
    My config is:

    Open VZ with Ubuntu 8.04; all packages are there; got around the problem, that Open VZ resets the hosts and hostname file.

    /etc/hosts:
    #::1 localhost ip6-localhost ip6-loopback
    #fe00::0 ip6-localnet
    #ff00::0 ip6-mcastprefix
    #ff02::1 ip6-allnodes
    #ff02::2 ip6-allrouters
    #ff02::3 ip6-allhosts
    127.0.0.1 localhost zimbra
    (it has been 127.0.0.1 localhost.localdomain localhost before, but didn't help either)
    # Auto-generated hostname. Please do not remove this comment.
    99.99.99.99 zimbra.myserver.com zimbra mail

    /etc/hostname:
    zimbra

    /etc/resolv.conf:

    nameserver 199.199.199.199

    What i did:
    I checked various combinations of host/hostname, tried also adding:
    search mydomain.com to resolv.conf

    I tried it with different configurations.

    Btw, the virtual server is remote; the reverse DNS setting has been done, whenever i enter the "hostname" command, i get as reply, what i entered in "hostname" file.
    But, if i enter: hostname -a or hostname -f i will get: unknown host

    I browsed almost the whole internet, hours by hours, but have not found any more clue.
    Whatever i do, i will get this unknown host thing. Also, if i start the install script for zimbra, its quite the same.

    DNS entry for domain and mailserver has been done, Webmin has been installed, and is up and running, i can control the server by Webmin and the internet by using the domain i set up in worldwide DNS.
    the root prompt looks like this:
    :~# oot@zimbra, whereas the cursor is sitting on the first "o" of this line, so if i enter any command, it overwrites the "oot@zimbra".

    So i am really confused, any help would be truly appreciated.

    Thank you.
    jm

  9. #29
    iway is offline Partner (VAR/HSP)
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    You should set the hostname to a FQDN, like zimbra.yourdomain.com

  10. #30
    just_me is offline Junior Member
    Join Date
    Jul 2009
    Posts
    8
    Rep Power
    6

    Default

    Thank you very much for your fast reply.
    Quote Originally Posted by iway View Post
    You should set the hostname to a FQDN, like zimbra.yourdomain.com
    In fact, i did, but this didn't help either.Still hostname: Unknown host...
    :-(
    jm
    Last edited by just_me; 08-10-2009 at 10:26 AM.

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Get emails out of zimbra or get it working again?
    By kingfeanor in forum Migration
    Replies: 9
    Last Post: 11-25-2008, 01:02 AM
  2. Replies: 4
    Last Post: 08-26-2008, 12:34 PM
  3. Replies: 4
    Last Post: 08-24-2008, 05:45 AM
  4. [SOLVED] ZCS 5.0.8 on Ubuntu 8.04
    By Dominic in forum Installation
    Replies: 5
    Last Post: 07-31-2008, 09:44 PM
  5. Installing Zimbra on Ubuntu 8.04 server
    By murphyml in forum Installation
    Replies: 8
    Last Post: 06-06-2008, 02:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •