Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Open Zimbra & Ubuntu 8.04LTS - can't receive external emails

  1. #1
    mbossmanh is offline Junior Member
    Join Date
    Nov 2008
    Posts
    8
    Rep Power
    6

    Default Open Zimbra & Ubuntu 8.04LTS - can't receive external emails

    I am testing an installation for personal use and i just don't know what else to do. I have setup bind9 dns on the same server. The server is connected directly to the net (no router firewall). I have my hosting company forwarding to my local computer's ip for dns. I install zimbra fine (no errors) and i can send and receive local emails. I can also send external emails through my isp's smtp. However, i cannot receive any external emails.

    Installation on ubuntu 8.04lts running Bind9 dns
    local hostname: mail.hansenx6.com

    dig a hansenx6.com
    ; <<>> DiG 9.4.2-P2 <<>> a hansenx6.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42739
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hansenx6.com. IN A

    ;; ANSWER SECTION:
    hansenx6.com. 38400 IN A 154.20.107.200

    ;; AUTHORITY SECTION:
    hansenx6.com. 17398 IN NS mail.hansenx6.com.

    ;; ADDITIONAL SECTION:
    mail.hansenx6.com. 17398 IN A 154.20.107.200

    ;; Query time: 23 msec
    ;; SERVER: 75.154.133.68#53(75.154.133.68)
    ;; WHEN: Mon Nov 24 19:52:41 2008
    ;; MSG SIZE rcvd: 81
    dig mx hansenx6.com

    ; <<>> DiG 9.4.2-P2 <<>> mx hansenx6.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47265
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hansenx6.com. IN MX

    ;; ANSWER SECTION:
    hansenx6.com. 10751 IN MX 10 mail.hansenx6.com.

    ;; AUTHORITY SECTION:
    hansenx6.com. 16615 IN NS mail.hansenx6.com.

    ;; ADDITIONAL SECTION:
    mail.hansenx6.com. 16615 IN A 154.20.107.200

    ;; Query time: 24 msec
    ;; SERVER: 75.154.133.68#53(75.154.133.68)
    ;; WHEN: Mon Nov 24 19:53:30 2008
    ;; MSG SIZE rcvd: 81
    nslookup hansenx6.com
    > hansenx6.com
    Server: 75.154.133.68
    Address: 75.154.133.68#53

    Non-authoritative answer:
    Name: hansenx6.com
    Address: 154.20.107.200
    cate /etc/hosts
    127.0.0.1 localhost
    154.20.107.200 mail.hansenx6.com

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    cat /etc/resolv.conf
    search hansenx6.com
    nameserver 75.154.133.68
    nameserver 75.154.133.100
    Unless my local dns is misconfigured (i am a noob) I can't think what else must be wrong. Any help is appreciated.

    Thanks
    Mike

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,499
    Rep Power
    56

    Default

    Your hosts file is incorrect, please check the format in the Quick Start Installation Guideand correct it. When you've done that, what does the following command show when run on the Zimbra server:

    Code:
    host `hostname`  <-- use backticks not single quotes
    Are you behind a firewall or do you have SElinux installed? Is the firewall set to allow the correct ports through?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    mbossmanh is offline Junior Member
    Join Date
    Nov 2008
    Posts
    8
    Rep Power
    6

    Default

    i had a friend do some looking into my problem. He responded as follows:
    I looked at it and see that it's something to do with the postfix config. Here is the actual error

    ehlo caseyservices.com
    250-mail.hansenx6.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    mail from:doug@caseyservices.com
    250 2.1.0 Ok
    rcpt to:michael@hansenx6.com
    250 2.1.5 Ok
    data:
    221 2.7.0 Error: I can break rules, too. Goodbye.
    Connection closed by foreign host.


    You can see a normal smtp chat until 221 2.7.0 Error: I can break rules, too. Goodbye.

    I googled it but most of the suggestions had been done like checking the main.cf file, it's right
    I played around with the dns last night so i have just reverted back to it. I changed the host name as follows:
    cat /etc/hosts
    127.0.0.1 localhost.hansenx6.com localhost
    154.20.107.200 mail.hansenx6.com

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    No firewall installed nor selinux as far as i'm aware.

    host `hostname`
    Host mail.hansenx6.com not found: 3(NXDOMAIN)

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,499
    Rep Power
    56

    Default

    You hosts file is still incorrect, type it exactly as you see it in the Quick Start guide and do NOT add your hostname on the 127.0.0.1 line.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,499
    Rep Power
    56

    Default

    Quote Originally Posted by mbossmanh View Post
    No firewall installed nor selinux as far as i'm aware.
    Can you check and see if iptables is enabled on your system.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    dwill's Avatar
    dwill is offline Special Member
    Join Date
    Aug 2006
    Posts
    122
    Rep Power
    8

    Default ? for Phoenix

    I've spent all morning reading about Ubuntu 8.04 and strange "localhost" DNS errors caused by MDNS -

    See: ATTN: Ubuntu 8.04 Users

    This may be why some 8.04 users are having to modify their hosts file in funky ways to get proper resolution. can someone at Zimbra check this possible solution and let us know
    Work
    8.0.3 UBUNTU10_04 UBUNTU10_04 NETWORK

    Home
    8.0.3 UBUNTU10_04 UBUNTU10_04 FOSS

  7. #7
    mbossmanh is offline Junior Member
    Join Date
    Nov 2008
    Posts
    8
    Rep Power
    6

    Default

    I changed the host file
    cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    154.20.107.200 mail.hansenx6.com

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    I then ran the host `hostname`
    michael@mail:/etc$ host `hostname`
    mail.hansenx6.com has address 154.20.107.200
    I rebooted and tested - still no email.

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,499
    Rep Power
    56

    Default

    One thing you can try is a modification to the nsswitch.conf file. Check this post from dwill and see what the format of the 'hosts' line is in that file. See if it looks like this:

    Code:
    hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
    if it does then modify it to the following:
    Code:
    hosts:          files dns mdns
    and see if that helps. You'll also be doing a test for dwill by doing that.

    If that isn't the answer or doesn't work the please do the following on the Zimbra server:

    Code:
    host `hostname`  <-- backticks not single quotes
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    and post the output here.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,499
    Rep Power
    56

    Default

    I forgot to mention in my last post that your hosts file is still incorrect, you need to modify the following line:

    Code:
    154.20.107.200 mail.hansenx6.com
    to this
    Code:
    154.20.107.200 mail.hansenx6.com mail
    as per the documentation.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    mbossmanh is offline Junior Member
    Join Date
    Nov 2008
    Posts
    8
    Rep Power
    6

    Default

    I'm stupid ... i changed the host as per your reply.

    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.

    passwd: compat
    group: compat
    shadow: compat

    hosts: dns files
    networks: files

    protocols: db files
    services: db files
    ethers: db files
    rpc: db files

    netgroup: nis
    ~
    ~
    ~
    ~
    michael@mail:~$ host `hostname`
    mail.hansenx6.com has address 154.20.107.200
    michael@mail:~$ cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    154.20.107.200 mail.hansenx6.com mail

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    michael@mail:~$ cat /etc/resolv.conf
    search hansenx6.com
    nameserver 75.154.133.68
    nameserver 75.154.133.100
    michael@mail:~$ dig hansenx6.com mx

    ; <<>> DiG 9.4.2-P2 <<>> hansenx6.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 452
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hansenx6.com. IN MX

    ;; ANSWER SECTION:
    hansenx6.com. 29882 IN MX 10 mail.hansenx6.com.

    ;; AUTHORITY SECTION:
    hansenx6.com. 31092 IN NS mail.hansenx6.com.

    ;; ADDITIONAL SECTION:
    mail.hansenx6.com. 31092 IN A 154.20.107.200

    ;; Query time: 9 msec
    ;; SERVER: 75.154.133.68#53(75.154.133.68)
    ;; WHEN: Tue Nov 25 11:27:25 2008
    ;; MSG SIZE rcvd: 81
    michael@mail:~$ dig hansenx6.com any

    ; <<>> DiG 9.4.2-P2 <<>> hansenx6.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9686
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hansenx6.com. IN ANY

    ;; ANSWER SECTION:
    hansenx6.com. 28538 IN MX 10 mail.hansenx6.com.
    hansenx6.com. 34726 IN NS mail.hansenx6.com.

    ;; AUTHORITY SECTION:
    hansenx6.com. 34726 IN NS mail.hansenx6.com.

    ;; ADDITIONAL SECTION:
    mail.hansenx6.com. 34726 IN A 154.20.107.200

    ;; Query time: 8 msec
    ;; SERVER: 75.154.133.68#53(75.154.133.68)
    ;; WHEN: Tue Nov 25 11:27:59 2008
    ;; MSG SIZE rcvd: 95
    Thanks
    Mike

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 03:23 PM
  2. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  3. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. Replies: 8
    Last Post: 02-27-2007, 04:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •