Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: Open Zimbra & Ubuntu 8.04LTS - can't receive external emails

  1. #11
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,497
    Rep Power
    56

    Default

    So you're all OK now and everything is working? If it is you should change the following service in Ubuntu: mDNS/ZeroConf/Bonjour (or whatever it's called), disble or uninstall it as it's that causing the problem of the modified nsswitch.conf file. If you do remove it make sure you check the nsswitch.conf file is still set correctly.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #12
    mbossmanh is offline Junior Member
    Join Date
    Nov 2008
    Posts
    8
    Rep Power
    6

    Default

    So far it still doesn't work. I'm going to give it another 24hours to see if that changes anything (with dns).

    Otherwise, i think i have exhausted all my resources. I was thinking of trying another distribution. Which one can you recommend?

    Thanks,
    Mike

  3. #13
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default nsswitch.comf

    As phoenix stated, for the DNS directive, "files" needs to come before "dns". This tells apps to look at the hosts file first before checking a DNS server.

    Your host.conf file also needs an entry: order hosts, bind

    Some software checks the host.conf and some look at the nsswtich.conf file.

    Either way it is usually best for the hosts file to be queried before DNS.

  4. #14
    bbarrons is offline Special Member
    Join Date
    Jan 2008
    Location
    Michigan
    Posts
    174
    Rep Power
    7

    Default host.conf

    I was just reading thru this thread and trying to resolve check thru my ubuntu 8.04 install to be sure it is correct. my host.conf file has no entry in it at all except for multi off.
    could you post an example of a host.conf that should be correct? when I do host `hostname`
    it says "Host ms2 not found: 3(NXDOMAIN)" yet I have no problems with rec or sending mail.
    thanks
    Bill B

  5. #15
    Bill Brock is offline Outstanding Member
    Join Date
    May 2007
    Location
    Oklahoma
    Posts
    703
    Rep Power
    9

    Default Here is my host.conf file with notations.

    Notice it says that the host.conf and the nsswitch.conf file should be in sync for the resolver order.


    # /etc/host.conf - resolver configuration file
    #
    # Please read the manual page host.conf(5) for more information.
    #
    #
    # The following option is only used by binaries linked against
    # libc4 or libc5. This line should be in sync with the "hosts"
    # option in /etc/nsswitch.conf.
    #
    order hosts, bind
    #
    # The following options are used by the resolver library:
    #
    multi on

  6. #16
    bbarrons is offline Special Member
    Join Date
    Jan 2008
    Location
    Michigan
    Posts
    174
    Rep Power
    7

    Default

    thanks for the reply Bill. I added the line to my host.conf file. I want to be sure I am running as clean as I can. I maintain a server here at home ( my test box) as well as a zimbra server at a small school.

  7. #17
    bbarrons is offline Special Member
    Join Date
    Jan 2008
    Location
    Michigan
    Posts
    174
    Rep Power
    7

    Default still a minor issue

    So, when I run host `hostname`
    I get "Host ms2 not found: 3(NXDOMAIN)"
    but nslookup gives me
    Server: 192.168.1.120
    Address: 192.168.1.120#53

    Name: barronsfamily.net
    Address: 192.168.1.120
    Code:
    dig barronsfamily.net mx gives me 
    
    ; <<>> DiG 9.4.2-P2 <<>> barronsfamily.net mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24661
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;barronsfamily.net.		IN	MX
    
    ;; ANSWER SECTION:
    barronsfamily.net.	604800	IN	MX	10 ms2.barronsfamily.net.
    
    ;; AUTHORITY SECTION:
    barronsfamily.net.	604800	IN	NS	ms2.barronsfamily.net.
    
    ;; ADDITIONAL SECTION:
    ms2.barronsfamily.net.	604800	IN	A	192.168.1.120
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.120#53(192.168.1.120)
    ;; WHEN: Fri Nov 28 12:43:09 2008
    ;; MSG SIZE  rcvd: 85
    any idea what I am missing? where do I start to look? or is it not a big deal.
    thanks
    Bill B
    Last edited by phoenix; 11-28-2008 at 10:48 AM.

  8. #18
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,497
    Rep Power
    56

    Default

    Post the output of your /etc/hosts file:

    Code:
    cat /etc/hosts
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #19
    bbarrons is offline Special Member
    Join Date
    Jan 2008
    Location
    Michigan
    Posts
    174
    Rep Power
    7

    Default here it is

    bbarrons@ms2:~$ cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.1.120 ms2.barronsfamily.net
    bbarrons@ms2:~$
    I have up until today been running this host file with 1 exception.
    this line used to read
    192.168.1.120 ms2.barronsfamily.net ms2
    but I changed it this morning to see if it made a difference

  10. #20
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,497
    Rep Power
    56

    Default

    Yes, it does make a difference as you've just found out.

    It should be in the original format:

    Code:
    192.168.1.120 ms2.barronsfamily.net ms2
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 2 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 03:23 PM
  2. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  3. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. Replies: 8
    Last Post: 02-27-2007, 04:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •