Results 1 to 9 of 9

Thread: zmcontrol start - LDAP error

  1. #1
    sunilp.rao is offline New Member
    Join Date
    Nov 2008
    Posts
    3
    Rep Power
    6

    Default zmcontrol start - LDAP error

    Hi,

    I installed zimbra this morning. All was working fine. Create few user and imported few users from exchange 2003. I ran "service zimbra restart" as root and after that zimbra just won't come up. Later i tried logging as "zimbra" account and tried running zmcontrol start from bin directory, but it throws the following error on the console:

    [zimbra@mailx2 bin]$ ./zmcontrol start
    Host mailx2.gloporeims.com
    Starting ldap...Done.
    FAILED
    Global symbol "$dfilename" requires explicit package name at /opt/zimbra/libexec/zmconfigure line 30.
    Global symbol "$dfilename" requires explicit package name at /opt/zimbra/libexec/zmconfigure line 40.
    Global symbol "$dfilename" requires explicit package name at /opt/zimbra/libexec/zmconfigure line 42.
    Global symbol "$dfilename" requires explicit package name at /opt/zimbra/libexec/zmconfigure line 43.
    Global symbol "$dfilename" requires explicit package name at /opt/zimbra/libexec/zmconfigure line 54.
    Global symbol "$sr" requires explicit package name at /opt/zimbra/libexec/zmconfigure line 60.
    Global symbol "$sr" requires explicit package name at /opt/zimbra/libexec/zmconfigure line 62.
    Execution of /opt/zimbra/libexec/zmconfigure aborted due to compilation errors.
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: /opt/zimbra/openssl-0.9.8g/lib/libssl.so.0.9.8: invalid ELF header
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: /opt/zimbra/openssl-0.9.8g/lib/libssl.so.0.9.8: invalid ELF header
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: /opt/zimbra/openssl-0.9.8g/lib/libssl.so.0.9.8: invalid ELF header
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: /opt/zimbra/openssl-0.9.8g/lib/libssl.so.0.9.8: invalid ELF header
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: /opt/zimbra/openssl-0.9.8g/lib/libssl.so.0.9.8: invalid ELF header
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: /opt/zimbra/openssl-0.9.8g/lib/libssl.so.0.9.8: invalid ELF header
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: /opt/zimbra/openssl-0.9.8g/lib/libssl.so.0.9.8: invalid ELF header
    Failed to start slapd. Attempting debug start to determine error.
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: /opt/zimbra/openssl-0.9.8g/lib/libssl.so.0.9.8: invalid ELF header


    Environment Details:

    Fedora Core 7, Zimbra version - 5.0.10 (Community Edition).

    Any pointers to the solution would be of great help.

    Thanks,
    Sunil

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Welcome to the forums

    Most LDAP start issues are down to DNS settings to lets check them first. Please post
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig gloporeims.com mx
    dig gloporeims.com any
    host `hostname` <- note backticks and not single quotes

  3. #3
    sunilp.rao is offline New Member
    Join Date
    Nov 2008
    Posts
    3
    Rep Power
    6

    Default

    Hosts File:

    [root@mailx2 ~]# cat /etc/hosts
    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1               localhost localhost.localdomain localhost
    192.168.100.11          mailx2.gloporeims.com mailx2
    Resolv.conf:

    [root@mailx2 ~]# cat /etc/resolv.conf
    Code:
    search gloporeims.com
    nameserver 192.168.100.7

    [root@mailx2 ~]# dig gloporeims.com mx
    Code:
    ; <<>> DiG 9.4.2 <<>> gloporeims.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29365
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;gloporeims.com.                        IN      MX
    
    ;; ANSWER SECTION:
    gloporeims.com.         3600    IN      MX      10 mailx.gloporeims.com.
    
    ;; ADDITIONAL SECTION:
    mailx.gloporeims.com.   3600    IN      A       192.168.1.11
    
    ;; Query time: 1 msec
    ;; SERVER: 192.168.100.7#53(192.168.100.7)
    ;; WHEN: Wed Nov 12 17:04:59 2008
    ;; MSG SIZE  rcvd: 70
    [root@mailx2 ~]# dig gloporeims.com any

    Code:
    ; <<>> DiG 9.4.2 <<>> gloporeims.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2696
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 3
    
    ;; QUESTION SECTION:
    ;gloporeims.com.                        IN      ANY
    
    ;; ANSWER SECTION:
    gloporeims.com.         600     IN      A       192.168.100.7
    gloporeims.com.         600     IN      A       192.168.1.7
    gloporeims.com.         3600    IN      NS      exchangeblr1.gloporeims.com.
    gloporeims.com.         3600    IN      NS      exchange.gloporeims.com.
    gloporeims.com.         3600    IN      SOA     exchangeblr1.gloporeims.com. hostmaster. 4674 900 600 86400 3600
    gloporeims.com.         3600    IN      MX      10 mailx.gloporeims.com.
    
    ;; ADDITIONAL SECTION:
    exchangeblr1.gloporeims.com. 3600 IN    A       192.168.100.7
    exchange.gloporeims.com. 3600   IN      A       192.168.1.7
    mailx.gloporeims.com.   3600    IN      A       192.168.1.11
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.100.7#53(192.168.100.7)
    ;; WHEN: Wed Nov 12 17:04:59 2008
    ;; MSG SIZE  rcvd: 230
    [root@mailx2 ~]# host `hostname`
    Code:
    mailx2.gloporeims.com has address 192.168.100.11
    Last edited by phoenix; 11-13-2008 at 12:39 AM.

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    su - zimbra
    zmcontrol -v
    uname -a

  5. #5
    sunilp.rao is offline New Member
    Join Date
    Nov 2008
    Posts
    3
    Rep Power
    6

    Default

    [root@mailx2 ~]# su - zimbra

    [zimbra@mailx2 ~]$ zmcontrol -v


    Release 5.0.10_GA_2638.F7_20081003060853 F7

    [zimbra@mailx2 ~]$ uname -a

    Linux mailx2 2.6.20-2925.9.fc7xen #1 SMP Tue May 22 08:53:03 EDT 2007 i686 i686 i386 GNU/Linux

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    According to the hosts file you've posted above the IP address of your server is different to the DNS A record address.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Bill, the error message is a bit worrying though
    /opt/zimbra/openldap/libexec/slapd: error while loading shared libraries: /opt/zimbra/openssl-0.9.8g/lib/libssl.so.0.9.8: invalid ELF header
    that may be due to how FC7 is playing in a virtual environment as from the uname it would appear that it is running under Xen. What version of Xen is being used ?

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    Quote Originally Posted by sunilp.rao View Post
    I ran "service zimbra restart" as root and after that zimbra just won't come up. Later i tried logging as "zimbra" account and tried running zmcontrol start from bin directory....
    There's also this comment in the original description. You need to run 'zmcontrol start' or 'zmcontrol stop' as the Zimbra user i.e.

    Code:
    su - zimbra
    zmcontrol start
    You should now run 'zmfixperms -v' as the root user then try starting Zimbra again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 12-23-2010, 11:17 AM
  2. Replies: 8
    Last Post: 10-19-2008, 09:52 AM
  3. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  4. Could not start kstartupconfig error!
    By bylong in forum Administrators
    Replies: 3
    Last Post: 09-05-2007, 07:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •