Results 1 to 4 of 4

Thread: [SOLVED] Need Help: SMTP Authentication and Port Modification

  1. #1
    mconder is offline Member
    Join Date
    Oct 2008
    Posts
    11
    Rep Power
    6

    Question [SOLVED] Need Help: SMTP Authentication and Port Modification

    I am trying to authenticate to DynDNS's mailhop server, but I am getting the following in my zimbra.log:

    zimbra@ubuntu-srv:~/conf$ grep -i mailhop /var/log/zimbra.log
    Oct 16 16:08:06 ubuntu-srv postfix/smtp[13875]: 6B958633D: to=, relay=outbound.mailhop.org[63.208.196.178]:2525, delay=1.1, delays=0.15/0.21/0.64/0.07, dsn=5.0.0, status=bounced (host outbound.mailhop.org[63.208.196.178] said: 550 You must authenticate to use MailHop Outbound (in reply to MAIL FROM command))

    I have been trying to configure Zimbra for SMTP authentication all day. Here is my postfix mail.cf

    sender_canonical_maps = proxy:ldap:/opt/zimbra/conf/ldap-scm.cf
    virtual_alias_domains = proxy:ldap:/opt/zimbra/conf/ldap-vad.cf
    lmtp_connection_cache_time_limit = 4s
    recipient_delimiter =
    smtpd_tls_cert_file = /opt/zimbra/conf/smtpd.crt
    smtpd_tls_auth_only = yes
    myhostname = ubuntu-srv.appconnex.com
    virtual_mailbox_domains = proxy:ldap:/opt/zimbra/conf/ldap-vmd.cf
    mydestination = localhost
    mailbox_size_limit = 0
    setgid_group = postdrop
    smtpd_client_restrictions = reject_unauth_pipelining
    queue_run_delay = 300s
    minimal_backoff_time = 300s
    virtual_alias_maps = proxy:ldap:/opt/zimbra/conf/ldap-vam.cf
    transport_maps = proxy:ldap:/opt/zimbra/conf/ldap-transport.cf
    message_size_limit = 10240000
    sendmail_path = /opt/zimbra/postfix/sbin/sendmail
    broken_sasl_auth_clients = yes
    lmtp_connection_cache_destinations =
    alias_maps = hash:/etc/aliases
    manpage_directory = /opt/zimbra/postfix/man
    smtpd_helo_required = yes
    in_flow_delay = 1s
    daemon_directory = /opt/zimbra/postfix/libexec
    maximal_backoff_time = 4000s
    virtual_transport = error
    mynetworks = 127.0.0.0/8 192.168.1.0/24
    smtpd_recipient_restrictions = reject_non_fqdn_recipient, permit_sasl_authentic$
    lmtp_host_lookup = dns
    smtpd_tls_loglevel = 1
    relayhost = outbound.mailhop.org:2525
    disable_dns_lookups = no
    mail_owner = postfix
    virtual_mailbox_maps = proxy:ldap:/opt/zimbra/conf/ldap-vmm.cf
    content_filter = smtp-amavis:[127.0.0.1]:10024
    version = 2.4.7.5z
    mailq_path = /opt/zimbra/postfix/sbin/mailq
    header_checks = pcre:/opt/zimbra/conf/postfix_header_checks
    smtpd_use_tls = yes
    queue_directory = /opt/zimbra/data/postfix/spool
    newaliases_path = /opt/zimbra/postfix/sbin/newaliases
    smtpd_reject_unlisted_recipient = no
    smtpd_data_restrictions = reject_unauth_pipelining
    local_header_rewrite_clients = permit_mynetworks,permit_sasl_authenticated
    smtpd_tls_key_file = /opt/zimbra/conf/smtpd.key
    command_directory = /opt/zimbra/postfix/sbin
    smtpd_sasl_auth_enable = yes
    smtp_sasl_auth_enable=yes
    smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password
    smtp_sasl_security_options=
    smtp_use_tls = yes
    smtp_tls_CAfile = /opt/zimbra/postfix/cert.pem
    smtp_tls_session_cache_database = btree:/var/run/smtp_tls_session_cache
    Here is output for postmap -q ubuntu-srv.appconnex.com /opt/zimbra/conf/relay_password:

    mconder:Artemis1

    So what am I doing wrong here?

    Thanks!
    Last edited by mconder; 10-16-2008 at 04:22 PM.

  2. #2
    mconder is offline Member
    Join Date
    Oct 2008
    Posts
    11
    Rep Power
    6

    Default

    If there is anyone who knows how to get SMTP authentication working, PM me and I'll give you login to my server. It's just a test server, so I don't really care if it gets screwed up. I have a VMWare snapshot anyway. I just want to get this working. Please help!

  3. #3
    dwmtractor's Avatar
    dwmtractor is offline Moderator
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    9

    Default

    I have not tried using DynDNS SMTP, so I can't comment intelligently about your set-up, but this wiki might be helpful to you.
    Cheers,

    Dan

  4. #4
    dwmtractor's Avatar
    dwmtractor is offline Moderator
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    9

    Default

    You might also read this thread:
    [SOLVED] multiple accounts on smtp relay

    I think the user may have been dealing with similar issues to those you encountered already or will encounter. This thread illustrates both what you can and cannot expect from externally-authenticated SMTP.
    Cheers,

    Dan

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. local mail getting marked as spam?
    By bjquinn in forum Administrators
    Replies: 61
    Last Post: 09-07-2010, 09:23 PM
  2. Adding SSL based SMTP authentication
    By Miklos Kalman in forum Installation
    Replies: 15
    Last Post: 02-14-2008, 04:34 PM
  3. SMTP authentication problems continue
    By EdMartin in forum Installation
    Replies: 2
    Last Post: 01-11-2008, 03:23 AM
  4. SMTP sends without user authentication
    By Shrewd in forum Installation
    Replies: 4
    Last Post: 04-19-2007, 05:10 PM
  5. Moving Zimbra Web Client from one port to another.
    By oopstu in forum Administrators
    Replies: 2
    Last Post: 01-20-2007, 02:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •