Results 1 to 6 of 6

Thread: CAN'T Enable cleartext logins for IMAP/POP3!?

  1. #1
    jbuwa is offline Member
    Join Date
    Oct 2008
    Posts
    11
    Rep Power
    6

    Default CAN'T Enable cleartext logins for IMAP/POP3!?

    Ok. I have in global settings enable clear text logins for IMAP and POP3.Under servers I have disabled TLS Authentication only and under IMAP and POP3 the enable clear text login is checked but the box is grayed out and is not checkable or uncheckable. Server and computer in general has been reboot numerous times but still even telneting to the server via port 143 when I try to login with a login username password I get the reply back NO cleartext logins disabled... Can anyone tell me how to get this working?

  2. #2
    b27520 is offline Member
    Join Date
    Jul 2008
    Posts
    12
    Rep Power
    7

    Default Try This

    I went under the general information tab and unchecked use this as a reverse proxy, then I was able to check clear text login.

    I did not install zimbra proxy and it is not running so I am not sure what this is for. Must be part of the new build because I've built several servers and this is the first time I've seen it.

  3. #3
    MGSteve is offline Senior Member
    Join Date
    Oct 2008
    Posts
    56
    Rep Power
    6

    Default

    I've got the same problem and tried the suggestion above, but it doesn't work.

    I have the setting ticked, to allow cleartext logons but it doesn't allow it.

    I've restarted the server but it makes no difference.

    I need this changing as I've got about 20 clients to transfer onto the zimbra box but I can't if they're all going to need to enable secure logins in their clients - something that really they shouldn't have to do.

    Besides which I've got POP3 scripts on the server which do not have an SSL option.

    help!

    I'm running the current version of Zimbra on CentOS 5.1. If you need any more info pls ask.
    Last edited by MGSteve; 12-07-2008 at 05:18 PM.

  4. #4
    MGSteve is offline Senior Member
    Join Date
    Oct 2008
    Posts
    56
    Rep Power
    6

    Default

    Never mind, fixed it myself!

    Ok, what you need to do is ditch the admin website as no matter how many times you tick the 'Enable Clear Text Logins' option, it has no effect.

    Login to your Zimbra box and issue the following commands as the Zimbra user

    ----
    zmprov mcf zimbraImapCleartextLoginEnabled TRUE
    zmprov mcf zimbraPop3CleartextLoginEnabled TRUE
    ----

    Now you need to remove the imap proxy

    (obviously change the mailserver address for your own as appropriate)

    -----
    zmprov ms server.example.com -zimbraServiceEnabled imapproxy
    zmprov -l ms server.example.com zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995 zimbraPop3ProxyBindPort 7110 zimbraPop3SSLProxyBindPort 7995 zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraImapProxyBindPort 7143 zimbraImapSSLProxyBindPort 7993
    ----

    The last command is important as it restores the link to the correct ports, as these are normally taken by the imap proxy.

    then simply restart zimbra and away you go.

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    Did you disable the proxy before making the clear text login change via the cli? Making the change in the Admin UI works for me on the current 5.0.11, you shouldn't have had the proxy enabled (on a single server install) in the first place but running the following will tell you if it's been set:

    Code:
    zmproxyctl status
    zmprov gs server.domain.com | grep zimbraServiceEnabled
    zmprov gs server.domain.com | grep zimbraServiceInstalled
    
    zmprov  gs fqdn.yourserver.com | grep -i clear
    As you've already said, if the proxy is enabled then run this:
    Code:
    zmproxyctl stop
    zmprov ms server.domain.com -zimbraServiceEnabled imapproxy
    zmcontrol stop
    zmcontrol start
    and reset the ports you should run the following (on one line):

    Code:
    zmprov -l ms server.domain.com zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995 zimbraPop3ProxyBindPort 7110 zimbraPop3SSLProxyBindPort 7995 zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraImapProxyBindPort 7143 zimbraImapSSLProxyBindPort 7993
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    MGSteve is offline Senior Member
    Join Date
    Oct 2008
    Posts
    56
    Rep Power
    6

    Default

    ah. d'oh! Hadn't spotted the proxy setting on the services tab!

    Would be nice if it was a bit clearer that you need to disable the proxy to allow clear text logins though....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 08-07-2008, 11:43 PM
  2. [SOLVED] No cleartext logins after upgrade to 5.0.5
    By krknopp in forum Administrators
    Replies: 4
    Last Post: 04-21-2008, 01:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •