Results 1 to 4 of 4

Thread: [SOLVED] DNS problem: localhost not found

  1. #1
    ecobrazim is offline Loyal Member
    Join Date
    Sep 2008
    Location
    Belgium
    Posts
    91
    Rep Power
    6

    Default [SOLVED] DNS problem: localhost not found

    Hi all,

    I am so close to getting zimbra working. Just one more obstacle!

    I have zimbra natted and the DNS on the firewall doing the natting.

    My problem is that zimbra seems to only look at DNS content and never the hosts file which leads to:

    Code:
    (Host or domain name not found. Name service error for name=localhost type=A: Host not found)
    sure enough:
    Code:
    $ host localhost
    localhost.precognet.com does not exist (Authoritative answer)
    What can I do to get round this problem... other than installing a DNS server on zimbra? Can zimbra not check the DNS first and then the host file?

    Many thanks for your help!
    -eco

  2. #2
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    You may be able to get Zimbra going this way, but personally I think you are fighting a losing battle trying to make Zimbra work without properly configuring DNS. I'd recommend looking at the wiki pages for DNS and Split DNS (which you may need in your case). Also search the forums; there's tons of info on setting up DNS. It's really not that difficult and there are a lot of people willing to help if you run into issues.

  3. #3
    ecobrazim is offline Loyal Member
    Join Date
    Sep 2008
    Location
    Belgium
    Posts
    91
    Rep Power
    6

    Default

    Kind of expected that... I'll install a DNS on zimbra then but doesn't it seem a tad overkill for a localhost query.

    Still, if it's the way to go, that's what I'll do

    Thanks for your reply.
    -eco

  4. #4
    ArcaneMagus's Avatar
    ArcaneMagus is offline Moderator
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Try making sure that your /etc/host.conf file has a line like:
    Code:
    order hosts,bind
    As this tells your system in which order to use resolving services (In this case it uses the hosts file and then bind)

    Your /etc/hosts file should also look similar to:
    Code:
    127.0.0.1       localhost  localhost.localdomain
    internal IP server.domain.tld server

    Edit:
    Looks like you should also check /etc/nsswitch.conf which should have a line like:
    Code:
    hosts:          files dns
    Last edited by ArcaneMagus; 09-26-2008 at 08:47 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem to upgrade 4.5.10 to 5.0.1
    By aguerrave in forum Installation
    Replies: 2
    Last Post: 01-15-2008, 06:08 AM
  2. Firewall rules
    By rmvg in forum Installation
    Replies: 16
    Last Post: 09-04-2007, 02:20 PM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •