Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: why the silence

  1. #1
    martinx is offline Intermediate Member
    Join Date
    Sep 2008
    Posts
    18
    Rep Power
    6

    Angry why the silence

    scenario:

    2 domains (pointing to ip x.x.x.x)
    1 server (mac, ip: x.x.x.x)
    1 zimbra installation.

    mac direct access to internet (no router)

    one domain = fine
    2 domains = cant send/recieve mail depending on config but never full functionality (recieve)

    HOW DO I SET UP ABOVE with mta and all the rest of the settings.
    I dont have a dnsserver (dont think I need it if the mac is hooked up directly with a static IP)

    it didnt take more than a few hours after first download of the evaluation license til I got an email with prices and a very promising future.
    But when I asked a question... silence...
    ok google is a friend, but not this time.
    Manual then... NOTHING.

    is it possible to have the above config or should I scrap this project before we even get around of ordering the real license???

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Well you will require a DNS server as ZCS will need to find the A/MX records. I presume if you are connected directly to the internet then your server has a public IP ? Could you post the results of
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig _yourdomainname_ mx
    dig _yourserverfqdn_
    host `hostname` <- note backticks and not double quotes

  3. #3
    martinx is offline Intermediate Member
    Join Date
    Sep 2008
    Posts
    18
    Rep Power
    6

    Default

    zimbra.nko.se localhost <-- second domain
    213.185.30.83 localhost
    127.0.0.1 localhost
    255.255.255.255 broadcasthost
    ::1 localhost
    fe80::1%lo0 localhost
    ***
    nameserver 81.88.9.218
    nameserver 81.88.9.220
    ***
    ; <<>> DiG 9.4.1-P1 <<>> _nkomail.se_ <--main/first domain
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 21566
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;_nkomail.se_. IN A

    ;; AUTHORITY SECTION:
    . 236 IN SOA A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2008090900 1800 900 604800 86400
    ***
    ; <<>> DiG 9.4.1-P1 <<>> _nkomail.se_
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 4887
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;_nkomail.se_. IN A

    ;; AUTHORITY SECTION:
    . 600 IN SOA A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2008090900 1800 900 604800 86400

    ;; Query time: 111 msec
    ;; SERVER: 81.88.9.218#53(81.88.9.218)
    ;; WHEN: Tue Sep 9 11:04:11 2008
    ;; MSG SIZE rcvd: 105

    ***
    host `hostname`=
    hd5b91e53.k21735.sta.perspektivbredband.net has address 213.185.30.83

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Sorry remove the _'s from the dig commands so
    Code:
    dig yourdomainname mx
    dig yourserverfqdn
    Your hosts file is incorrect any as you have tied your IP to localhost. Have you followed Zimbra™ Collaboration Suite Single Server Installation - Open Source especially the section on DNS ?

    Also, which version of ZCS are you running ?
    Code:
    su - zimbra
    zmcontrol -v
    Last edited by uxbod; 09-09-2008 at 02:10 AM.

  5. #5
    martinx is offline Intermediate Member
    Join Date
    Sep 2008
    Posts
    18
    Rep Power
    6

    Default

    hd5b91e53:~ root# dig nkomail.se

    ; <<>> DiG 9.4.1-P1 <<>> nkomail.se
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2921
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;nkomail.se. IN A

    ;; ANSWER SECTION:
    nkomail.se. 7128 IN A 213.185.30.83

    ;; Query time: 0 msec
    ;; SERVER: 81.88.9.218#53(81.88.9.218)
    ;; WHEN: Tue Sep 9 16:15:53 2008
    ;; MSG SIZE rcvd: 44

    Release 5.0.9_GA_2533.MACOSXx86_10.5, Zimbra, Inc.
    MACOSXx86_10.5 NETWORK edition

    "yourserverfqdn" Im not sure what that is but my servername is the same as our domain = nkomail.se

    And for the hosts settings I have tried everything.
    I have edited the hostsfile so that is almost worn out.

  6. #6
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    According to a external lookup on your domain
    Code:
    ; <<>> DiG 9.4.2-P1 <<>> nkomail.se mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26165
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;nkomail.se.			IN	MX
    
    ;; ANSWER SECTION:
    nkomail.se.		86367	IN	MX	1 213.185.30.83.nkomail.se.
    
    ;; ADDITIONAL SECTION:
    213.185.30.83.nkomail.se. 86367	IN	A	213.185.30.83
    so your server name should be 213.185.30.83.nkomail.se and not nkomail.se.

  7. #7
    martinx is offline Intermediate Member
    Join Date
    Sep 2008
    Posts
    18
    Rep Power
    6

    Default

    "so your server name should be 213.185.30.83.nkomail.se and not nkomail.se."

    do you mean that the server (zimbraserver) should be named "213.185.30.83.nkomail.se". Where in the installationmanual does it say that you have to have the dnslookupname as the servername???

  8. #8
    martinx is offline Intermediate Member
    Join Date
    Sep 2008
    Posts
    18
    Rep Power
    6

    Default

    I took out the ipnumber loopback in the hostsfile and now I cant even send mail...

    Im not sure we understand each other

  9. #9
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    In one of your other posts when you check your hostname you get
    host `hostname`=
    hd5b91e53.k21735.sta.perspektivbredband.net has address 213.185.30.83
    yet your actual MX record is pointing to 213.185.30.83.nkomail.se! So, what is the actual hostname of the server now ?

  10. #10
    martinx is offline Intermediate Member
    Join Date
    Sep 2008
    Posts
    18
    Rep Power
    6

    Default

    I set the hostname/computername manually before the install to "nkomail.se"

    the "hd5b91e53.k21735.sta.perspektivbredband.net"
    is our ISP´s name (reverse lookup) for that IP but that shouldnt be a problem. at least it hasnt with only one domain.

    Previous installs I left the computers hostname untouched and it got the
    "hd5b91e53.k21735.sta.perspektivbredband.net" when I hooked it up to the net but then I had major other problems so I decided to set it manually as I read in one thread in the forum. the servername gets that name when installing and didnt take no for an answer. And when I tried to have two domains I read that I had to have a DNSserver wich I dont... so... I set the name to nkomail.se

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MS offering to buy Yahoo ???
    By Yann2 in forum /etc
    Replies: 372
    Last Post: 05-05-2012, 10:27 PM
  2. SIP based Zimlet?
    By grazman in forum Zimlets
    Replies: 21
    Last Post: 06-23-2009, 11:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •