Results 1 to 4 of 4

Thread: Sending LMTP to localhost

  1. #1
    Mitch is offline New Member
    Join Date
    Aug 2008
    Posts
    3
    Rep Power
    6

    Default Sending LMTP to localhost

    I've got a NAT firewall setup. I don't want to poke a hole for 7025 on the external address so I need postfix to talk to 7025 on either the internal address or localhost. I tried disabling Enable DNS lookups and adding my mail server host as 127.0.0.1 in /etc/hosts. However, now when I try to email an external domain is tries contact the IP of the server's A record rather than the MX record. What am I doing wrong?

    Thanks,
    Mitch

  2. #2
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    You can force jetty to bind to a specific address by setting zimbraLmtpBindAddress on the server config.

    The real problem is that provisioning new accounts will set zimbraMailTransport attribute on the account to something like lmtp:server.domain.tld:7025 where server.domain.tld is taken from the zimbraMailHost attribute and 7025 is taken from zimbraLmtpBindPort of the server.

    Setting zimbraLmtpBindAddress will not change the default behaviour of zimbraMailTransport when provisioning new users.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Mitch is offline New Member
    Join Date
    Aug 2008
    Posts
    3
    Rep Power
    6

    Default

    Yuck. I read about the split DNS workaround. I'll try that.

    Thanks,
    Mitch

  4. #4
    Mitch is offline New Member
    Join Date
    Aug 2008
    Posts
    3
    Rep Power
    6

    Default

    I found the most painless solution was to use iptables:

    iptables -t nat -A OUTPUT -p tcp -d EXTERNAL_IP --dport 7025 -j DNAT --to INTERNAL_IP

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Self-Signed SSL Certificate Causing Crash
    By VxJasonxV in forum Administrators
    Replies: 1
    Last Post: 12-06-2007, 01:24 PM
  2. Why is Tomcat shuting down ever nights?
    By trapanator in forum Administrators
    Replies: 2
    Last Post: 11-30-2006, 11:57 PM
  3. fetchmail: SMTP< 250 Ok: queued as
    By daly1 in forum Installation
    Replies: 4
    Last Post: 08-04-2006, 04:23 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  5. emails don't show up in inbox in browser
    By pstelzer in forum Installation
    Replies: 10
    Last Post: 12-13-2005, 10:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •